PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Flashers/Blinkers not working from switch.

 
Like Tree3Likes
  • 3 Post By ChazBOT

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Jun 2014, 09:31 pm
Young Cruiser
 
Join Date: Jun 2014
Posts: 59
Default Flashers/Blinkers not working from switch.

Hello again new PT friends! My PT cruiser keeps blowing a fuse as soon as I turn on the flashers or use the blinkers. They come on and flash when I use the key less entry, but that is about it. I have replaced the blinker switch and it keeps happening. Any thoughts on this? Driving me crazy!
Reply With Quote
  #2 (permalink)  
Old 27 Jun 2014, 08:48 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Flashers/Blinkers not working from switch.

Have you replaced the multifunction switch - the lever? That's probably got a short. You replaced the blinker module that plugs in, right? That's probably okay...
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles

Last edited by CREWZIN; 27 Jun 2014 at 08:57 am. Reason: word correction
Reply With Quote
  #3 (permalink)  
Old 27 Jun 2014, 09:11 am
sanatanadharma's Avatar
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,092
Default Re: Flashers/Blinkers not working from switch.

Please tell us which fuse is blowing. This helps troubleshooting. Clearly the wiring from the RKE to the (parking) light bulbs is OK.
The flashers operate on a different circuit through separate filaments so the lock/unlock light flash signal is a red herring.


(parking
Quote:
Originally Posted by ChazBOT View Post
Hello again new PT friends! My PT cruiser keeps blowing a fuse as soon as I turn on the flashers or use the blinkers. They come on and flash when I use the key less entry, but that is about it. I have replaced the blinker switch and it keeps happening. Any thoughts on this? Driving me crazy!
Reply With Quote
  #4 (permalink)  
Old 27 Jun 2014, 10:01 am
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Lightbulb Re: Flashers/Blinkers not working from switch.

If the fuse that keeps blowing is fuse #18,here is a PT Cruiser with a somewhat similar issue(w/lots of good wiring schematics there):http://www.justanswer.com/chrysler/4...ser-blows.html
You probably should thoroughly inspect the wiring for the MFS connector plug,and the wiring on the back of the fuse block to see if there are any signs of overheating(melted/burnt).....Because it sounds like your getting a ground fault/short somewhere along the pathway of the turn indicator circuit.
Here is a 'pin-out' diagram for the MFS connector plug:


PT_MFS_pinout_diagram.jpg
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #5 (permalink)  
Old 27 Jun 2014, 03:27 pm
Young Cruiser
 
Join Date: Jun 2014
Posts: 59
Default Re: Flashers/Blinkers not working from switch.

FIXED!!!!!

So I yet again replaced the flasher 15 fuse,blinker switch and flasher (relay? goes on the back of the switch.) and now they work. I might have gotten 2 bad switches or a bad relay last time.
Reply With Quote
  #6 (permalink)  
Old 28 Jun 2014, 08:42 am
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Thumbs up Re: Flashers/Blinkers not working from switch.

Quote:
Originally Posted by ChazBOT View Post
I might have gotten 2 bad switches or a bad relay last time.
That does happen......Glad you got it fixed.
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #7 (permalink)  
Old 29 Jun 2014, 11:41 pm
Young Cruiser
 
Join Date: Jun 2014
Posts: 59
Default Re: Flashers/Blinkers not working from switch.

Thank you everyone for the help!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stereo not working after replacing Multifunction Switch talows Sound and Security Forum 0 11 Mar 2014 09:31 pm
HELP!! lights, blinkers, & wipers all not working capo General PT Cruiser Discussions 11 26 Jun 2013 09:41 pm
dome light switch on S/W not working outfit Interior Accessories Forum 0 13 Dec 2010 04:17 am
Blinkers and Hazards not working badgingles Tech & Performance Forum 1 03 Sep 2009 08:55 pm
door lock switch not working ptbooga General PT Cruiser Discussions 2 08 Oct 2005 06:00 pm


All times are GMT -5. The time now is 10:39 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors