PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Oil Pressure Sensor ????

 
Like Tree1Likes
  • 1 Post By rob342

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 30 Jun 2014, 04:32 pm
Fresh Cruiser
 
Join Date: Jun 2014
Posts: 5
Default Oil Pressure Sensor ????

Ive got the p0522 code and gonna change the oil Pressure sensor. The parts house asks for sensor with light or without light. how do i know which i need . thanks in advance.
stephen
Reply With Quote
  #2 (permalink)  
Old 30 Jun 2014, 05:48 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Oil Pressure Sensor ????

Did the parts house happen to know if you had a PT Cruiser before asking that question? Never heard on the forum anyone being asked that.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 30 Jun 2014, 06:03 pm
Cool Cruiser
 
Join Date: Sep 2004
Location: .
Posts: 271
Default Re: Oil Pressure Sensor ????

I would go to the dealer for that and not a parts house. Too many people have had issues with after market sensors on the PT.
Reply With Quote
  #4 (permalink)  
Old 30 Jun 2014, 06:18 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Oil Pressure Sensor ????

i used a cheap $9 autozone one. no issues for me. i've used them on my PT, mustang and a 98 malibu. all are still fine/working/not leaking. i'd go to the dealer for a cam sensor, a coil, etc. for oil, it's just a simple pressure switch.
Leroy likes this.
Reply With Quote
  #5 (permalink)  
Old 30 Jun 2014, 06:57 pm
Fresh Cruiser
 
Join Date: Jun 2014
Posts: 5
Default Re: Oil Pressure Sensor ????

Quote:
Originally Posted by CREWZIN View Post
Did the parts house happen to know if you had a PT Cruiser before asking that question? Never heard on the forum anyone being asked that.
im not sure what this means? with light would that be dummy light which i do have

anyway i put it in and now the oil light comes on when it get to operating temp.on the bright side the massive leak i had is now gone.and yes it has plenty of oil
Reply With Quote
  #6 (permalink)  
Old 30 Jun 2014, 07:32 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,364
Default Re: Oil Pressure Sensor ????

Quote:
Originally Posted by nonstopgo68 View Post
anyway i put it in and now the oil light comes on when it get to operating temp.on the bright side the massive leak i had is now gone.and yes it has plenty of oil
Than you still have some kind of problem...you need to do the key dance.


To do the key dance, turn everything in the car off, no stereo, wipers, lights, etc., just to keep the system load down. Turn your key to the accessory position, that is two clicks prior to the start. So, you have Off, Acc, On, and Start (which is the spring-loaded position). Turn to Acc, wait a few seconds, then On, Acc, On, Acc, and On... leave it in the On position (NOT THE MOTOR START POSITION!), you should see a series of dashes ------ at your Odometer, while the PT runs the internal diagnostics testing. Takes maybe 10 to 15 seconds or so and then it will return the DTC's (diagnostic trouble codes).

Than download the Diagnostic Trouble Codes.pdf from PT CRUISER TECHNICAL DOCUMENTS LIBRARY
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #7 (permalink)  
Old 30 Jun 2014, 08:43 pm
Fresh Cruiser
 
Join Date: Jun 2014
Posts: 5
Default Re: Oil Pressure Sensor ????

ok thank you so much for this info. it is greatly appreciated. will do 1st am.
i admit that i did change the sensor out without checking the oil press.
i had a major leak and its poss that the prob now lies in the harness itself. the light was coming on before but it would go off after turning the switch off and on. now it seems to come on when up to operating temp which still could be the switch itself not being oe or some crap. ill try this and check the oil pressand then the wiring diagram to see what makes this light come on
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure sensor adventure mommacrstl Tech & Performance Forum 40 26 Jun 2017 10:31 am
Install - Oil Pressure Sensor geronimo Tech & Performance Forum 27 02 Feb 2015 04:31 pm
HOW TO: oil pressure sensor replacement rob342 Tech & Performance Forum 5 12 Sep 2013 04:13 am
oil pressure sensor/cyl #1 misfire conrad General PT Cruiser Discussions 3 01 Jun 2013 02:09 pm
releasing the oil pressure sensor geronimo General PT Cruiser Discussions 0 29 Mar 2010 03:31 pm


All times are GMT -5. The time now is 12:18 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors