PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Issues with cruiser I just purchased.

 
Like Tree6Likes
  • 2 Post By xwing777
  • 3 Post By quicksilverdon
  • 1 Post By quicksilverdon

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Jul 2014, 06:19 pm
Fresh Cruiser
 
Join Date: Jul 2014
Posts: 3
Question Issues with cruiser I just purchased.

Hello, I'm Katrina from Georgia. I just joined the group today. I hope I'm posting in the right spot. So I purchased this car last week, and it's been a headache. It's used. The vehicle has under 145 thousand miles. The service engine light is on and when I took it to advance auto I got codes for camshaft sensor( I was able to change it myself, after looking at a video on youtube), go me! The other code was a P0507 something to do with idle speed/vacuum leak/dirty throttle bottle is what the reading was. My issue is when I have the air on and I'm completely stopped the air doesn't blow very well until I start moving again. My biggest concern is when I'm stopped and only when the air is on there is the shake/vibration. I don't getting different answers from different shops and I do believe the main reason is because I'm a female and the second is maybe some of them really don't know what their talking about.
Reply With Quote
  #2 (permalink)  
Old 29 Jul 2014, 07:33 pm
xwing777's Avatar
Senior Cruiser
 
Join Date: Jan 2009
Location: Taylorsville NC
Posts: 1,106
Default Re: Issues with cruiser I just purchased.

Sounds like the Idle air control valve (iac). You can search youtube for howto. Simple quick job yjay only cost you a can of carb cleaner
boonie2 and Tbrown like this.
__________________
.
2004 Almond GT, autostick - Only car shows, some weekends but with Stage1!
2003 cranberry 5 speed GT - Fishing with a sleeper Stage3 setup!
Reply With Quote
  #3 (permalink)  
Old 29 Jul 2014, 08:28 pm
Fresh Cruiser
 
Join Date: Jul 2014
Posts: 3
Default Re: Issues with cruiser I just purchased.

Thanks xwing777!! The dealership where I purchased the vehicle claimed they fix the issue/replaced the part when the checked the service engine light. However the check engine light is still on an it's still showing the idle control sensor as the issue. thanks!
Reply With Quote
  #4 (permalink)  
Old 29 Jul 2014, 08:33 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Issues with cruiser I just purchased.

I will bet the issue with your A/C is the engine fan - it has 2 speeds, and I'll bet one speed is out.
Open hood, start engine, turn A/C on - engine fan should be on - I bet it isn't...
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 29 Jul 2014, 09:40 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,895
Default Re: Issues with cruiser I just purchased.

Quote:
Originally Posted by quicksilverdon View Post
I will bet the issue with your A/C is the engine fan - it has 2 speeds, and I'll bet one speed is out.
Open hood, start engine, turn A/C on - engine fan should be on - I bet it isn't...
I have to agree with QSD on this. The pump puts more load on the engine with the fan not working.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #6 (permalink)  
Old 29 Jul 2014, 09:53 pm
Fresh Cruiser
 
Join Date: Jul 2014
Posts: 3
Default Re: Issues with cruiser I just purchased.

Thanks quicksilverdon!!!!
I just went out and did as you said, and you are correct. I'm sorry for all the questions guys but I'm just trying to learn. I realize that some things I can do for cheaper, rather than having to pay labor cost at a shop. Is it expensive to get the fan fixed. I was when I got the oil change that the air control valve was changed out because of the color of the part was lighter than the piece it connects to on the car. I went with it. Again I'm learning. I really appreciate all you for responding and helping me out..... So if the air control valve was changed, why do you think that the check engine light is still on and giving the same exact code P0507
Reply With Quote
  #7 (permalink)  
Old 29 Jul 2014, 10:02 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Issues with cruiser I just purchased.

Fan will have to be replaced.
Do a search here and read about replacing it - many have done it themselves...
Tbrown likes this.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
bumpy road with newly purchased 2001 pt cruiser limited mrstolleson Tech & Performance Forum 9 08 Jul 2014 08:48 pm
02 pt cruiser, just purchased, no oil pressure 71cuda2 Tech & Performance Forum 23 28 Apr 2014 06:00 pm
Just Purchased a 2008 Sunset crystal Dream cruiser Johnnyjet General PT Cruiser Discussions 69 10 Aug 2013 08:27 pm
Purchased 1st PT today Davidenorth Welcome New PT Cruiser Members 18 25 Feb 2012 08:46 pm
Just purchased the wife a 2002 PT Cruiser; Intro and questions. FleshEater General PT Cruiser Discussions 21 29 Mar 2011 08:46 pm


All times are GMT -5. The time now is 06:27 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors