PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2006 Cruiser Turn signals and Hazards

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Aug 2014, 08:12 pm
Fresh Cruiser
 
Join Date: Aug 2014
Posts: 3
Default 2006 Cruiser Turn signals and Hazards

I have a 2006 Cruiser, base model. During a recent trip, all my turn signals and my hazards quit working. The bulbs are fine. We've tried replace the Multi-function switch, but that didn't work. I find it hard to believe that all the relays, if I could even find them, went at the exact same moment and I know everything went at once.

Does anyone have any ideas? I've tried searching this forum, but no luck there. Everyone talks of the MFS, but that is not the issue with my car.

Help, please?
Reply With Quote
  #2 (permalink)  
Old 19 Aug 2014, 08:14 pm
Young Cruiser
 
Join Date: Apr 2014
Location: El Paso TX
Posts: 81
Default Re: 2006 Cruiser Turn signals and Hazards

blown fuse maybe? might be a possibility
Reply With Quote
  #3 (permalink)  
Old 19 Aug 2014, 08:15 pm
Fresh Cruiser
 
Join Date: Aug 2014
Posts: 3
Default Re: 2006 Cruiser Turn signals and Hazards

The 2006 does not have a fuse for the signals or hazards. I would like to meet the person who thought that was a good idea. I have a few choice words to say to them.
Reply With Quote
  #4 (permalink)  
Old 19 Aug 2014, 08:19 pm
Young Cruiser
 
Join Date: Apr 2014
Location: El Paso TX
Posts: 81
Default Re: 2006 Cruiser Turn signals and Hazards

To be honest, I just guessed and don't really know if they had fuses or not :S
Reply With Quote
  #5 (permalink)  
Old 19 Aug 2014, 08:54 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,296
Default Re: 2006 Cruiser Turn signals and Hazards

I have been reading about bad light bulb sockets but on both sockets? Maybe a short somewhere or a bad ground wire contact? Are you measuring getting any voltage at the sockets with the light bulb out with the turn signal on?
Reply With Quote
  #6 (permalink)  
Old 19 Aug 2014, 08:59 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,296
Default Re: 2006 Cruiser Turn signals and Hazards

Also is the turn signals working in the dashboard?
Reply With Quote
  #7 (permalink)  
Old 19 Aug 2014, 09:02 pm
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: 2006 Cruiser Turn signals and Hazards

Quote:
Originally Posted by libilou View Post
I have a 2006 Cruiser, base model. During a recent trip, all my turn signals and my hazards quit working. The bulbs are fine. We've tried replace the Multi-function switch, but that didn't work. I find it hard to believe that all the relays, if I could even find them, went at the exact same moment and I know everything went at once.

Does anyone have any ideas? I've tried searching this forum, but no luck there. Everyone talks of the MFS, but that is not the issue with my car.

Help, please?
Try disconnecting the battery and resetting the PCM. Search this forum for that procedure. A while back I had a similar situation with my PT where it had no turn signals and only the high beams worked. After disconnecting the battery, that fixed everything and the problem has not happened since. Can't hurt and won't cost you anything.
Reply With Quote
  #8 (permalink)  
Old 19 Aug 2014, 09:22 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,296
Default Re: 2006 Cruiser Turn signals and Hazards

There might be a combination flasher for both the turn signals and the hazards. It should be plugged into the MFS on the steering column. This would be the first thing I would replace before doing the other two suggestions above.
Reply With Quote
  #9 (permalink)  
Old 19 Aug 2014, 10:47 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: 2006 Cruiser Turn signals and Hazards

There is no flasher as it is built into the TIPM or at least that is where I think it is because I can't find one anywhere. I know it's not part of the MFS. Disconnecting the battery will reset the TIPM and if that doesn't fix it then a dealer will have to scan the TIPM and see if it can be reflashed or if it needs replaced.
Reply With Quote
  #10 (permalink)  
Old 20 Aug 2014, 12:34 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,296
Default Re: 2006 Cruiser Turn signals and Hazards

Ray
Thank you for your more accurate information on the flasher. According to the Haynes Manual 2006 Pt Cruiser and up does not have the flasher. I now agree with what Rays recommends.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No turn signals. Fuse Blows when Hazards turned off JerryJovi Northwest PT Forum 1 15 May 2014 08:16 pm
no turn signals Darkchylde Tech & Performance Forum 13 29 Mar 2014 10:44 am
INDICATORS TURN SIGNALS HAZARDS PATGAS Tech & Performance Forum 9 29 Oct 2013 04:59 pm
Hazards and Turn signals out. KrisBo Tech & Performance Forum 4 29 Dec 2011 05:23 pm
No turn signals, wipers, washers for 2006 pt thundert79 General PT Cruiser Discussions 4 13 Dec 2008 09:55 pm


All times are GMT -5. The time now is 02:31 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors