PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Ack! Code P 0340 on a 2010 we bought yesterday!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Aug 2014, 07:34 pm
Fresh Cruiser
 
Join Date: Aug 2014
Posts: 1
Unhappy Ack! Code P 0340 on a 2010 we bought yesterday!

My wife bought her 2010 PT Cruiser Couture Edition yesterday from the dealership (used, of course, but has less than 25k miles on her). When she went to start it up after work, she had trouble starting it (started on the third try) then once she started driving the check engine light came on and it went into limp mode. She got it home and I checked for the error code by turning the key on an off 3 times and error code P 0340 came up. Did some research and learned that it is the cam position sensor. I decided to take her out for a spin to see if I could get it to replicate what it did to my wife and it ran like a champ. Still has the check engine light and shows the error code. Dealer is coming to get it tomorrow. Should I just tell them to replace the cam position sensor, or do you think there is something else afoot here?

Thanks!
Reply With Quote
  #2 (permalink)  
Old 26 Aug 2014, 08:49 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,325
Default Re: Ack! Code P 0340 on a 2010 we bought yesterday!

Sometimes the cam sensor plug will come loose, if you unplug it & plug it back in..it might fix the problem. Before you do this, it's a good idea to unhook the negative battery cable 1st...this will also erase your code, but if you do have a cam sensor problem the code will come back.
If the dealer is going to pick it up, let them worry about it...I wouldn't mention it to them...there could be another problem & you don't want them not to look.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
code 0340 leslie381 Tech & Performance Forum 2 19 May 2012 07:56 pm
0340 Code Jaimez Tech & Performance Forum 20 20 Sep 2011 01:21 pm
Just bought my cruiser yesterday <3 PTBlondeRose Welcome New PT Cruiser Members 14 25 Apr 2011 09:34 am
Error code 0340 Callygirl Tech & Performance Forum 6 22 Nov 2009 10:30 am
Bought a 2003 PT Cruiser GT Turbo 2.4L Yesterday - Some Questions polira General PT Cruiser Discussions 9 17 Aug 2008 09:04 am


All times are GMT -5. The time now is 01:56 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors