PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Hood jets not spraying

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Aug 2014, 11:19 pm
Cool Cruiser
 
Join Date: Apr 2014
Location: Missouri
Posts: 430
Default Hood jets not spraying

Hey guys it's me again. I was out driving today and tried to clean my windshield when I noticed my jets not spraying. I did replace them because the OE were dried and crumbly. I did notice that when I hit the lever for the jets there is no sound like it is trying to spray, the wipers just run. I did add more water to make sure there was something in there. Any ideas? Is it hard to change the pump? TIA. This forum rules!!!
__________________


2005 Purple Pt Touring 130k Still Running Strong

New timing belt and water pump at 130k.
Reply With Quote
  #2 (permalink)  
Old 29 Aug 2014, 10:35 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,882
Default Re: Hood jets not spraying

I would check for a fuse first. I don't know witch.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 29 Aug 2014, 11:02 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,325
Default Re: Hood jets not spraying

Quote:
Originally Posted by 05purplept View Post
Hey guys it's me again. I was out driving today and tried to clean my windshield when I noticed my jets not spraying. I did replace them because the OE were dried and crumbly. I did notice that when I hit the lever for the jets there is no sound like it is trying to spray, the wipers just run. I did add more water to make sure there was something in there. Any ideas? Is it hard to change the pump? TIA. This forum rules!!!

Did you just change them..??
I know when I changed mine, that because the old ones were brittle it had little bits of plastic in the lines & I had to blow/suck them out. Try unhooking 1 side & than hit the washer...if water comes out than the sprayers are clogged...if not, than it's something else.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #4 (permalink)  
Old 29 Aug 2014, 03:24 pm
Cool Cruiser
 
Join Date: Apr 2014
Location: Missouri
Posts: 430
Default Re: Hood jets not spraying

lion, good point. i'll try that. i actually changed them a couple months ago, just haven't used them in a while.

busted, i try that too. it's usually the easy stuff right.

also i think these are a higher flow rate. any idea if that could cause the pump to burn out? thanks again.
__________________


2005 Purple Pt Touring 130k Still Running Strong

New timing belt and water pump at 130k.
Reply With Quote
  #5 (permalink)  
Old 29 Aug 2014, 04:01 pm
Banned
 
Join Date: Mar 2014
Posts: 13
Default Re: Hood jets not spraying

When it gets hot outside mine dribble for some reason.

Probably the nozzles since they are loose (not lose)

One of these days I will get around to looking at it closer
Reply With Quote
  #6 (permalink)  
Old 29 Aug 2014, 04:33 pm
KA9VQF's Avatar
Cool Cruiser
 
Join Date: Jul 2014
Location: Savanna Illinois
Posts: 460
Default Re: Hood jets not spraying

When we got our convertible the passengers side nozzle did not spray at all and the drivers side one barely made it to the windshield.

After a few days of this I decided to look under the hood and found the passengers side hose was loose. It was close to where it is supposed to hook on but not actually attached.

I put it on and tried them again. Success! In a few more days I had the same problem. I cured it by putting a zip tie on the hose to keep it on the nozzle.
Reply With Quote
  #7 (permalink)  
Old 29 Aug 2014, 04:41 pm
Young Cruiser
 
Join Date: Apr 2014
Location: El Paso TX
Posts: 81
Default Re: Hood jets not spraying

Maybe checking if the back wiper washer gets water too? if not then the pump could be your problem.
Front and back nozzles use the same pump for both.

Last edited by RacerX125; 29 Aug 2014 at 04:52 pm.
Reply With Quote
  #8 (permalink)  
Old 29 Aug 2014, 06:12 pm
Cool Cruiser
 
Join Date: Apr 2014
Location: Missouri
Posts: 430
Default Re: Hood jets not spraying

i didn't think about that. yes my back window does still spray. i'll check the other things when i leave from work and put an update either tonight or tomorrow. thanks guys. this forum is the greatest. always quick and usable answers. thanks again!!
__________________


2005 Purple Pt Touring 130k Still Running Strong

New timing belt and water pump at 130k.
Reply With Quote
  #9 (permalink)  
Old 29 Aug 2014, 07:20 pm
Young Cruiser
 
Join Date: Apr 2014
Location: El Paso TX
Posts: 81
Default Re: Hood jets not spraying

the pump has a valve that opens depending on where it needs the water to go so maybe either that failed or your multifunction switch that controls the washers is not working properly maybe or you have a clogged line. you can probably remove the pump and jump the motor and see if it works if it does then you multifunction switch that has the wipers is bad and is not energizing the motor pump for the front.
Check the shop manual posted in this forum and has good info on the pump

Last edited by RacerX125; 29 Aug 2014 at 07:25 pm.
Reply With Quote
  #10 (permalink)  
Old 29 Aug 2014, 07:42 pm
Vlefaive's Avatar
Senior Cruiser
 
Join Date: Jun 2012
Location: Whitby ON Canada
Posts: 1,630
Default Re: Hood jets not spraying

Having gone thru a few ( I now have them insulated ) as they crumble quite readily ( every year and a half )I'll tell you that hunks of plastic find their way into the tubing. Replace tubing and all will be well.
__________________
'03 GT Blue/ autostick.. 160,000KM ( That's 100,000miles for y'all South of the border ) All the options, the heated leather is a must up here in Canada, Love the solid heavy duty feel and obvious Torque.. The Turbo is strong, fast and reliable.. People that don't understand the love of a PT, probably don't deserve to.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adjusting Wiper Fluid Jets?? William_F General PT Cruiser Discussions 6 10 Jan 2010 07:39 am
Replace washer jets spanglish Exterior Accessories Forum 4 04 Dec 2009 11:39 am
Wipers w/ fluid jets Dekard General PT Cruiser Discussions 8 17 May 2004 03:10 pm
Hood Lift Kits/Hood Struts Blaneb Vendors & Buyers Forum 0 25 Nov 2003 10:35 am


All times are GMT -5. The time now is 03:57 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors