PT Cruiser Forum

PT Cruiser Forum (http://www.ptcruiserlinks.com/forum/)
-   Tech & Performance Forum (http://www.ptcruiserlinks.com/forum/tech-performance-forum/)
-   -   Lean Condition 171 Driving Me Nuts! (http://www.ptcruiserlinks.com/forum/tech-performance-forum/54231-lean-condition-171-driving-me-nuts.html)

Songwright 01 Sep 2014 06:52 pm

Lean Condition 171 Driving Me Nuts!
 
Hello all. I am new to the forum. I am a lifelong mechanic, I have owned several PT Cruisers, but currently just have my wife's bone-stock 2006 touring edition. A few days ago, I was about 35 miles from home, and the car wouldn't start. It seemed to be not getting fuel, so I got a ride home, gathered lots of tools and a fuel pump and went back to change the pump in the parking lot. A bit of a pain, but not too bad, all things considered. However, because I live on a dirt road, I found a thick layer of very fine sand on top of the tank and I had no way to blow it all off. Inevitably, a pretty good bit of it went into the tank when I pulled the pump module - not good! But at that point, I wanted to get the car home. I put the new pump into the module, put everything back together, and voila - runs just like new. Well, for about 10 miles anyway. Wife and I stopped to get some food, and when she came back out, the check engine light came on. Car seemed to run fine for her going home though. I scanned the codes and got 171. But it was running fine, so I cleared the codes and proceded to drive the car. Well, about 100 miles later, I've got another 171 code and now it acts like it's starving for fuel. So, I pulled the tank again. Yep, new fuel strainer all clogged with dirt. Ooh, this is expensive - bought another fuel pump, drained all the fuel out, swished it around until it looked clean, put it all back together, and hey, runs just like a new one again. For a few days then it's back to the won't go thing. So, at this point, I'm thinking maybe I managed to get some of the sand into the line and it got to the injector screens. Soooo, I bought new injectors. I figure at 150K miles it wouldn't hurt - particularly with the 30% discount at Advance. Well, that didn't fix it. Heck, might even be a little worse, and I got a 2096 code to go with the 171. Remember, this is an 06, so I don't have any way to check the fuel pressure, but I strongly believe it's still a fuel pressure problem. I'm leaning toward replacing the whole fuel pump module because I guess some dirt must have somehow messed up the pressure regulator. Does anyone have any other suggestions, or perhaps some dynamite?

CREWZIN 01 Sep 2014 07:07 pm

Re: Lean Condition 171 Driving Me Nuts!
 
Welcome to the forum and I agree it might be the fuel pressure. Sorry to say, you didn't say that you pulled the tank for the third time, only that you replaced the injectors. I think you managed to get a lot more dirt/sand in the tank than you thought. Might have to clean out the entire tank and not just the filter. Maybe blow out the lines from the tank up to the injectors.

Songwright 01 Sep 2014 07:29 pm

Re: Lean Condition 171 Driving Me Nuts!
 
Right, I haven't had it back down since I put the second new fuel pump in. But when I did that, I drained every bit of gas out, put some more in and swished it around and drained it out again. We're talking hold it up over a bucket and drain out through the filler neck. It was looking very clean in there before I put it back together, and I have a hard time believing I left enough in there to clog another filter. That's why I think it may now be the regulator. But that price tag is getting tough to swallow. I've never been one to throw parts at a problem, so I'm feeling pretty foolish at this point! Still, I'm scratching my head as to what else to do, and I've already ordered the new complete module. If I magically discover something else before I install it, I can always take it back. The good news is that I'm really good at dropping the tank...


All times are GMT -5. The time now is 09:39 pm.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243