PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Water pump and Timing belt changed, starts and stalls

 
Like Tree5Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Sep 2014, 06:23 pm
Fresh Cruiser
 
Join Date: Aug 2009
Location: Northern Ontario, Canada
Posts: 19
Default Water pump and Timing belt changed, starts and stalls

Good Day !

Last week, due to leaking anti-freeze and overheating, the first mechanic says it's the water pump, after testing the pressure. He declines to service my car as he's aware pt's engines are set in there tight + it's a 6-7 hour job.

Second mechanic also says it's the water pump and knowing that they are buggars to change, he agrees to service it. I order water pump, timing belt, serpentine, AC belt and power steering belt for my 2001 Pt Cruiser.

BTW...the parts guy advises me that 2001 model engines were manufactured for that year only, then chrysler changed their model engines after that ? I'm in Canada... Eh !

I picked up the car two days later, no more overheating problems. Now the car starts and stalls. Started it up again and gave it gas, it seems to be idling too low.

He pulls the battery cable off for 10 minutes to clear any codes. He hooks up the battery and starts the car and idles perfectly for about 1 minute and a half, then goes back to a low idle below 1000 rpms.

He did take notice that the previous timing belt was 2 notches off, and I've been running it that way since 2008. The previous owner changed the timing belt, just before I purchased it in 2008.

Does the car need to be flashed by the dealer ?

Thanks
__________________
2001 PT Cruiser
" Little Rascal "

Last edited by Rascal; 12 Sep 2014 at 08:32 pm.
Reply With Quote
  #2 (permalink)  
Old 12 Sep 2014, 09:03 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,895
Default Re: Water pump and Timing belt changed, starts and stalls

I doubt very seriously that you were 2 notches off and didn't notice. And I suppose It's right now and won't run. Here are some high quality pics that show the timing. One tooth off is very noticable. Sounds like you should check the codes in the pcm to confirm this.

HARMONIC BALANCER & CRANK SPROCKET REMOVEL AND INSTALL TOOL AND TIPS!!!!
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 13 Sep 2014, 06:17 am
Senior Cruiser
 
Join Date: Jun 2014
Posts: 1,630
Default Re: Water pump and Timing belt changed, starts and stalls

If stalling is the only problem and the engine is running smoothly and feels like it has not lost power, then take your car on a small tour around town and then out on the highway too. Your computer just needs to re-learn its settings.
boonie2 likes this.
Reply With Quote
  #4 (permalink)  
Old 13 Sep 2014, 08:55 am
Fresh Cruiser
 
Join Date: Aug 2009
Location: Northern Ontario, Canada
Posts: 19
Default Re: Water pump and Timing belt changed, starts and stalls

Prior to posting: I had called the mechanic when it stalled on me a few times getting to my sister's house, after I got it out of his garage. He tells me to give it a try on the highway and like you said, the computer just needs to re-learn its settings. With a friend driving behind me, we take it on the highway and drive for about 15 km with no highway problems. We pull over into the mall parking, I put it in park, it continues to idle, rough and shaky.

We decide to keep going for another 40 km of highway driving with no problems and again it seems to want to stall when the speed goes down to less than 8mph or when I apply the brakes. So I do the pedal dance till I get home. It was getting dark when I parked it so I let it idle for another 3-4 minutes, it kept idling rough, it shakes but it did not choke

Yesterday morning, at the first start, the car idles roughly, slowly chokes and dies. On the second start, I push down on the gas pedal and keep my foot on the gas and rev it up a bit then I let go of the gas, again it does idle, roughly, with the rpm going down to 800 rpm, flutters up close to the 1000 rpm and comes back down between 800 and 900 rpm.

With my foot slightly on the gas pedal, I put the car in drive and take it for in-my-neighborhood spin. It seems to want to stall whenever I apply the brakes slightly, so I do half stops and do the pedal dance, like driving a standard

Before the replacement parts, the car always idled at least above the 1000 rpm with no problems since 2008, although I was told that it seemed that the engine idled fast.

Unfortunately, I need to attend a funeral this afternoon and it's raining out there now, so I will do the pedal dance, again ! I hope to pull the battery cable off sometime later on and will do the key dance too !

Thanks for your input ! I've been a lurker since 2008, and a poster a few times, I do visit this site on a weekly basis, as a guest.
__________________
2001 PT Cruiser
" Little Rascal "
Reply With Quote
  #5 (permalink)  
Old 13 Sep 2014, 09:11 am
Senior Cruiser
 
Join Date: Jun 2014
Posts: 1,630
Default Re: Water pump and Timing belt changed, starts and stalls

Ok well that's what I was getting at. Since it is running poorly already then just driving it to re-learn isn't going to work.

Since it is running roughly it sounds like your mechanic has maybe installed the belt off a tooth or two. It may also be a vacuum leak if one of the hoses hasn't been reconnected. Try searching for some disconnected vacuum lines or even a sensor that hasn't been plugged in.
Reply With Quote
  #6 (permalink)  
Old 13 Sep 2014, 09:48 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,895
Default Re: Water pump and Timing belt changed, starts and stalls

First if it's stalling then someting is not set right. The relearn is overrated on stock PCM. You shouldn't have any drivability issues without it having any history. Most likely not vacuum as this makes for high idle. Timing is off IMHO.
Rascal, zamfir2 and boonie2 like this.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #7 (permalink)  
Old 14 Sep 2014, 09:14 pm
Fresh Cruiser
 
Join Date: Aug 2009
Location: Northern Ontario, Canada
Posts: 19
Default Re: Water pump and Timing belt changed, starts and stalls

It's going back to the garage on Monday afternoon + an overnight !

It should be ready by wednesday at the latest if all goes well, I will post the results. Thanks for the input
__________________
2001 PT Cruiser
" Little Rascal "
Reply With Quote
  #8 (permalink)  
Old 15 Sep 2014, 08:51 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Water pump and Timing belt changed, starts and stalls

It should idle smoothly at 800-900 RPM - 1000 is high.
Anxious to know what the trouble is.
You didn't have A/C or defrost on, did you? Often to do timing belt they drain A/C and if A/C is not right it can load the engine at idle.
3rcruiser likes this.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #9 (permalink)  
Old 17 Sep 2014, 07:31 pm
Fresh Cruiser
 
Join Date: Aug 2009
Location: Northern Ontario, Canada
Posts: 19
Default Re: Water pump and Timing belt changed, starts and stalls

The Mechanic took the negative post off battery, waited for about for 15 minutes then he used a scan tool to diagnose the issue. The scanner showed to re-set idle air control. My " Little Rascal " starts with no problem now and is within the 900 rpm level...

Back to lurking ...
__________________
2001 PT Cruiser
" Little Rascal "
Reply With Quote
  #10 (permalink)  
Old 17 Sep 2014, 08:08 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,339
Default Re: Water pump and Timing belt changed, starts and stalls

Can you tell us how the mechanic re-set the idle air control?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Pump and timing belt bheffner General PT Cruiser Discussions 16 07 Aug 2013 11:10 am
DIY Water Pump/Timing Belt tooter1 Tech & Performance Forum 16 06 Oct 2012 09:18 pm
Timing Belt/Water Pump sonocativo General PT Cruiser Discussions 6 31 Jul 2012 04:11 pm
Timing Belt/Water Pump mybubbles65 General PT Cruiser Discussions 3 04 Oct 2011 04:47 pm
water pump and timing belt bryanschacht Tech & Performance Forum 3 15 Apr 2011 05:32 pm


All times are GMT -5. The time now is 11:04 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors