PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
No power. Help!!!

 
Like Tree6Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Sep 2014, 05:07 pm
Fresh Cruiser
 
Join Date: Aug 2014
Posts: 20
Default No power. Help!!!

I have a 2006 cruiser 100000 miles. Had the timing belt changed recently and while there they told me the computer fried. They replaced it. As I am driving home from mechanic it started to sputter and then died. Everything died no lights or flashers. Basically no power at all. I towed it home and checked brand new battery and it was fine. I have the flashers on while I try to find the problem so I know if it's getting power when I mess with something. My neighbor told me my lights were flashing this morning for about an hour and then went off. They did come on once for me while I was standing there but as soon as u turn the key everything shuts down again. Hooking it up to jump does nothing either. If anyone has any suggestions please let me know. Thanks.
Reply With Quote
  #2 (permalink)  
Old 26 Sep 2014, 05:14 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: No power. Help!!!

if it ran fine before you took it in for the timing belt, i'd go raise hell at the shop. preferably when they're full of customers.
Reply With Quote
  #3 (permalink)  
Old 26 Sep 2014, 05:14 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,374
Default Re: No power. Help!!!

Take it back to the mechanic...it all started with them...you have a warranty, they should fix it.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #4 (permalink)  
Old 26 Sep 2014, 05:17 pm
Fresh Cruiser
 
Join Date: Aug 2014
Posts: 20
Default Re: No power. Help!!!

Trying to do this on my own and the mechanic will never touch my car again. Just looking for some things to check. Checked fuses they r fine.
Reply With Quote
  #5 (permalink)  
Old 26 Sep 2014, 05:25 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,374
Default Re: No power. Help!!!

Quote:
Originally Posted by Cholles View Post
Trying to do this on my own and the mechanic will never touch my car again. Just looking for some things to check. Checked fuses they r fine.
If it's a bad PCM (computer) or they programed it wrong, you need to get it checked. If you start messing with things, they could void your warranty...saying it was fine when you left, you broke it.

Is it throwing any codes..??
boonie2 likes this.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #6 (permalink)  
Old 26 Sep 2014, 05:26 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: No power. Help!!!

At least call the mechanic and see if they still have the old computer and explain what happened...
boonie2 likes this.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #7 (permalink)  
Old 26 Sep 2014, 07:37 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,339
Default Re: No power. Help!!!

Did you try unplugging the battery cable, hit the brakes for a few seconds, wait 15 minutes and then put the battery cable back on?
Reply With Quote
  #8 (permalink)  
Old 26 Sep 2014, 11:44 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,348
Default Re: No power. Help!!!

Are the battery terminals clean and tight?

The pcm is located just above the brake fluid tank, make sure all 4 plugs are pushed all the way in.

Will it turn over when trying to start it with the key?
if not?

Look on the instrument cluster with the key on, is the small round red security light on?
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #9 (permalink)  
Old 27 Sep 2014, 12:14 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,339
Default Re: No power. Help!!!

Quote:
Originally Posted by JoeX View Post
Are the battery terminals clean and tight?

The pcm is located just above the brake fluid tank, make sure all 4 plugs are pushed all the way in.

Will it turn over when trying to start it with the key?
if not?

Look on the instrument cluster with the key on, is the small round red security light on?
I found that when my SKIM fails on my PT Cruiser it will start but then die within 3 seconds. I would either reset the computer with my scanner or I would disconnect the battery cable, step on the brake for a few seconds, put the battery cable back on and then start the car and go home.
Reply With Quote
  #10 (permalink)  
Old 27 Sep 2014, 08:27 am
Fresh Cruiser
 
Join Date: Aug 2014
Posts: 20
Default Re: No power. Help!!!

So I went and had my battery tested which was 2 months old and they said it was dead. When I put the new one in all my lights came on so I tried to start it. At first it cranked and started for a few seconds and died and when I tried to restart everything went black again. When I turn the key it doesn't crank or anything everything just shuts off. Neg ground looks good. New battery terminals.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 PT Cruiser no power to power seat paradyne64 General PT Cruiser Discussions 5 29 Dec 2016 02:54 am
power top and power windows bheffner PT Cruiser Convertible Forum 5 04 Feb 2014 09:55 pm
Power Steering-it takes power just to steer it 05PTGT General Turbo Discussions 8 29 Jan 2013 08:37 pm
How to: Get power to radio and add circuits for power xwing777 Sound and Security Forum 19 10 Jun 2012 04:49 pm
FIXED: No power to power sockets, front or rear InTheBlack Tech & Performance Forum 2 11 Jan 2011 11:12 pm


All times are GMT -5. The time now is 05:03 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors