PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
no bus error

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Oct 2014, 08:35 pm
ejm ejm is offline
Fresh Cruiser
 
Join Date: Oct 2014
Posts: 1
Default no bus error

Hi all. I have a 2005 pt turbo 2.4 convertable. My abs light came on a few months ago and is still on. Then my trac light came on, now recently my engine light and the airbag light are on. They won't go off. Today while I was driving my speedometer stopped working. The car starts right up and runs fine except for some hesitation when I slow down or start moving after a stop. Im also getting a "no bus" message on the odometer. Can someone....ANYONE tell me what the problem might be??
Thanks!!!
Reply With Quote
  #2 (permalink)  
Old 15 Oct 2014, 09:06 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,293
Default Re: no bus error

No bus means that your instrument cluster may not be communicating. I would suggest checking your ground wires under the dash and in the engine compartment.
You should introduce yourself and give some details of your PT Cruiser such as any other warning signs, mileage, components being replaced in the last six months.
What are the engine trouble codes?
Do you have a OBDII Diagnosis Scan Tool to get these engine trouble codes?

Last edited by ptcruisersteve; 16 Oct 2014 at 07:32 am.
Reply With Quote
  #3 (permalink)  
Old 16 Oct 2014, 07:08 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: no bus error

You know, I hope, that whenever any of the lights come on, that particular function isn't working anymore so you've been riding around for months with ABS or traction control. Why did it take this long to seek help and on-line no less. Why didn't you take it to a mechanic or dealer for help?

Apparently, being your first post, you didn't do any kind of searching around for answers or read through any of the forum to see how the forum operates.

NEWLY REGISTERED MEMBERS PLEASE READ THIS...

WELCOME and Forum Rules
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Codes Error lilcruiser Tech & Performance Forum 2 10 May 2012 05:34 am
Error Code bds02pt Tech & Performance Forum 2 29 Jan 2010 03:01 pm
no error codes lt4supr Tech & Performance Forum 4 14 Aug 2009 07:34 pm
Error code 601 COOLSILVER02NV Tech & Performance Forum 7 14 Jul 2009 10:52 am
CPS Error Code smokeydan1 Tech & Performance Forum 16 23 Sep 2008 09:58 pm


All times are GMT -5. The time now is 05:07 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors