PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2.2 CRD poor power and acceleration lag

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Oct 2014, 01:50 am
Fresh Cruiser
 
Join Date: May 2013
Location: Pretoria, South Africa
Posts: 14
Default 2.2 CRD poor power and acceleration lag

Hi guys

So i've been having some trouble I can't seem to work out. I own a 2003 2.2 diesel and for some reason the car has no low end torque, the acceleration is so slow I might go back in time. When you push the accelerator there is about a second delay before it starts going. Any ideas.....
__________________
2003 2.2 crd
Reply With Quote
  #2 (permalink)  
Old 26 Oct 2014, 10:29 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: 2.2 CRD poor power and acceleration lag

Check the hoses going to/from the intercooler - without the turbo, there is little "oomph" from the diesel....
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 26 Oct 2014, 12:09 pm
Fresh Cruiser
 
Join Date: May 2013
Location: Pretoria, South Africa
Posts: 14
Default Re: 2.2 CRD poor power and acceleration lag

Thanks for the reply. Checked all the pipes, no leaks. when it eventually does decide to go it goes... Just a terrible lag. Turbo is fine, can hear it spinning up.
__________________
2003 2.2 crd
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hesistation/Temporary power loss during acceleration Cvette54 Turbo Performance 0 13 Aug 2014 11:31 am
Poor acceleration, no power up hills NuYork Tech & Performance Forum 22 20 Jul 2012 04:11 pm
Poor Mileage and Low Power... GangstaMobile Tech & Performance Forum 10 19 Mar 2012 06:03 am
Oh my, poor PT! JolieCruiser General PT Cruiser Discussions 9 27 Apr 2008 09:47 pm
Poor PT :( ucantcme General PT Cruiser Discussions 21 20 Mar 2008 03:08 pm


All times are GMT -5. The time now is 01:48 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors