PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Heater acting strange

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Nov 2014, 03:27 am
Cool Cruiser
 
Join Date: Apr 2014
Location: Missouri
Posts: 430
Default Heater acting strange

So, I have a remote start. Now that it's getting cold I use it a lot more. I've noticed when I get in the air is cold, but when I rev it a time or two it blows very hot. Any ideas guys?
__________________


2005 Purple Pt Touring 130k Still Running Strong

New timing belt and water pump at 130k.
Reply With Quote
  #2 (permalink)  
Old 17 Nov 2014, 09:04 am
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: Heater acting strange

Coolant low?
Reply With Quote
  #3 (permalink)  
Old 17 Nov 2014, 09:13 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,329
Default Re: Heater acting strange

I would suggest checking the thermostat.
Reply With Quote
  #4 (permalink)  
Old 17 Nov 2014, 10:08 am
Cool Cruiser
 
Join Date: Apr 2014
Location: Missouri
Posts: 430
Default Re: Heater acting strange

uptown, the coolant shouldn't be low. just had the timing belt done by a trusted mechanic. but i will check it.

steve, any way to check the thermo without pulling it?
__________________


2005 Purple Pt Touring 130k Still Running Strong

New timing belt and water pump at 130k.
Reply With Quote
  #5 (permalink)  
Old 17 Nov 2014, 10:26 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,889
Default Re: Heater acting strange

Quote:
Originally Posted by 05purplept View Post
uptown, the coolant shouldn't be low. just had the timing belt done by a trusted mechanic. but i will check it.

steve, any way to check the thermo without pulling it?
Read the poor fuel milage thread you also posted on.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #6 (permalink)  
Old 17 Nov 2014, 10:40 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Heater acting strange

Quote:
Originally Posted by 05purplept View Post
uptown, the coolant shouldn't be low. just had the timing belt done by a trusted mechanic. but i will check it.

steve, any way to check the thermo without pulling it?
Where is the engine temp gauge at? That's the best indication.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #7 (permalink)  
Old 17 Nov 2014, 11:23 am
Cool Cruiser
 
Join Date: Apr 2014
Location: Missouri
Posts: 430
Default Re: Heater acting strange

Temp gauge reads normal. that's the part that I find weird.
__________________


2005 Purple Pt Touring 130k Still Running Strong

New timing belt and water pump at 130k.
Reply With Quote
  #8 (permalink)  
Old 17 Nov 2014, 11:49 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Heater acting strange

Feel the hoses going to/from inside heater core - are they both hot? I suspect heater core has a blockage or the air vent may have a problem.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #9 (permalink)  
Old 17 Nov 2014, 12:17 pm
Cool Cruiser
 
Join Date: Apr 2014
Location: Missouri
Posts: 430
Default Re: Heater acting strange

I'll have to do that after work. I hope its not a blockage. Pita to deal with. Had one on a ranger I used to own.
__________________


2005 Purple Pt Touring 130k Still Running Strong

New timing belt and water pump at 130k.
Reply With Quote
  #10 (permalink)  
Old 17 Nov 2014, 10:11 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,329
Default Re: Heater acting strange

Quote:
Originally Posted by ptcruisersteve View Post
I would suggest checking the thermostat.
I would suggest taking the radiator cap off when the engine is cold, start it up and when it reaches normal temperature see how good is the coolant flow is in the radiator. Then rev it a time or two as you usually do and then let it idle and see if there is a big change in the coolant flow.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio/Nav system acting strange lenwood Sound and Security Forum 2 05 Aug 2014 04:02 pm
car acting funny pryand62 Tech & Performance Forum 3 12 Jan 2013 11:14 am
My Pt Gt has been acting weird. NicksCruiser Tech & Performance Forum 19 09 Jun 2012 11:28 am
PT is acting weird when A/C is on the_jeep_now Tech & Performance Forum 13 22 Aug 2011 09:42 am
Block Heater, Rad Hose Heater, Which?? kb0nly Tech & Performance Forum 13 23 Dec 2008 03:47 pm


All times are GMT -5. The time now is 12:58 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors