PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Engine Temp gauge acting WEIRD!!!

 
Like Tree5Likes
  • 2 Post By ptcruisersteve
  • 1 Post By quicksilverdon
  • 1 Post By LionPT
  • 1 Post By ptcruisersteve

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Dec 2014, 12:53 am
Fresh Cruiser
 
Join Date: May 2014
Location: Tampa, Florida
Posts: 4
Default Engine Temp gauge acting WEIRD!!!

Hey everyone, maybe someone out there can point me to the right answer to my problem.
I'll start at the beginning... The anti-freeze was leaking somewhere because I had to constantly fill it up every 3 days or so and the temperature gauge would rise all the time. I ended up buying some Stop Leak and it seemed to have worked. The canister stayed at the full mark. After that, the temperature gauge continued to rise to 3/4, but the fluids were fine. I decided to replace the thermostat and for a few days it worked perfectly fine. Now when I first start the car and the temperature hits the half way mark, once in idle it begins to rise again to 3/4. It doesn't go past that and it doesn't overheat. If I turn off the car and restart after a couple minutes, the temperature gauge stays at the half way mark for quite awhile, then starts to rise again.
Any suggestions as to what might be going on? The car has never overheated, but I noticed the hose that is attached to the radiator from the thermostat housing gets very very hot. Any help would be great.

Thanks

2009 Pt Cruiser.
Reply With Quote
  #2 (permalink)  
Old 23 Dec 2014, 02:01 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,287
Default Re: Engine Temp gauge acting WEIRD!!!

Is the radiator fans coming on when it gets pass the half mark on the engine temperature gauge?
Do you have any idea where the coolant might have been leaking?
I would recommend you do a coolant pressure test to see if you are still leaking somewhere.
You might have air in your coolant system. You need to burp and bleed your coolant system to make sure you don't have air in your coolant system.
You also might want to see if you have coolant flow by taking the radiator cap off when its cold and see if it starts to flow when the engine warms up.
Reply With Quote
  #3 (permalink)  
Old 23 Dec 2014, 02:06 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Engine Temp gauge acting WEIRD!!!

Agree w/Steve.
You might also buy a remote infrared thermometer - It reads the temperature of what you point it at - they are cheap - use it to see if your radiator has hot/cool spots indicating a problem.
Bedard666 likes this.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 23 Dec 2014, 06:52 am
Fresh Cruiser
 
Join Date: May 2014
Location: Tampa, Florida
Posts: 4
Default Re: Engine Temp gauge acting WEIRD!!!

Awesome!! Thanks for the info guys. I will take it in for a flush in case of air, but also check the temperature and to see if there's still a leak.

To answer Steve's questions:
1. The fan does come on when it hits the half way mark.
2. I believe the coolant was leaking in the coolant reservoir.


Thanks again both of you. I'll try your suggestions and post back.

Happy Holidays.

Rob
Reply With Quote
  #5 (permalink)  
Old 23 Dec 2014, 07:05 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,318
Default Re: Engine Temp gauge acting WEIRD!!!

Most stop leaks tell you to remove the thermostat before use...you replaced the thermostat after & problem went away for a few days & came back. It's possible that the stop leak also clogged up the new thermostat because it never left the radiator. I'd pull it out again & drive car for a day, than put a new one in...JMO
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #6 (permalink)  
Old 23 Dec 2014, 07:11 am
Fresh Cruiser
 
Join Date: May 2014
Location: Tampa, Florida
Posts: 4
Default Re: Engine Temp gauge acting WEIRD!!!

It's quite possible that the stop leak clogged it. Never thought of that. Thank you. Question.. Is it safe to drive without the thermostat even if it's for a day?

Thanks again.

Rob
Reply With Quote
  #7 (permalink)  
Old 23 Dec 2014, 09:38 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,287
Default Re: Engine Temp gauge acting WEIRD!!!

The engines in the PT Cruiser are not designed to run without the thermostat. The thermostat does not cost that much and going through the trouble of removing it why not just replace it so you don't have to remove the thermostat housing again to put a thermostat back in it.
I never recommend stop leak as it's only a temporary fix and sometimes it creates more problems than what you start off with.

Last edited by ptcruisersteve; 23 Dec 2014 at 09:41 am.
Reply With Quote
  #8 (permalink)  
Old 23 Dec 2014, 10:42 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Engine Temp gauge acting WEIRD!!!

Quote:
Originally Posted by Bedard666 View Post
It's quite possible that the stop leak clogged it. Never thought of that. Thank you. Question.. Is it safe to drive without the thermostat even if it's for a day?

Thanks again.

Rob
Safe, yes. You'll get worse mileage, the car will not warm up, but should won't damage anything. Not a long-term solution....
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #9 (permalink)  
Old 23 Dec 2014, 12:26 pm
Young Cruiser
 
Join Date: Aug 2014
Location: Slinger, WI
Posts: 52
Default Re: Engine Temp gauge acting WEIRD!!!

I had a similar issue with mine once i got the leak fixed it turned out the engine coolant temp sensor was bad. Not an expensive fix if that is the problem, also a pretty quick repair took me less than 15 min to replace.
__________________
Reply With Quote
Reply

Tags
temperature, thermostat


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
04/2.4 flutuation temp gauge/engine hesitation Puddin General PT Cruiser Discussions 6 17 Feb 2013 11:37 am
My Pt Gt has been acting weird. NicksCruiser Tech & Performance Forum 19 09 Jun 2012 11:28 am
PT is acting weird when A/C is on the_jeep_now Tech & Performance Forum 13 22 Aug 2011 09:42 am
Sunroof acting weird Franksredpt General PT Cruiser Discussions 2 10 Apr 2009 11:12 pm
Dash acting weird Nikkortim General PT Cruiser Discussions 8 04 Sep 2005 06:30 pm


All times are GMT -5. The time now is 09:47 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors