PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Could installing a new stereo make my pt overheat?

 
Like Tree1Likes
  • 1 Post By quicksilverdon

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Dec 2014, 08:49 pm
Fresh Cruiser
 
Join Date: Dec 2014
Location: Washington State
Posts: 13
Default Could installing a new stereo make my pt overheat?

I recently installed a new system in my PT. It was okay for a while, then I started my car to charge up the battery and after about 10 of running idle my temp light came on and it started dumping fluid on the ground, overheating. Never once had this problem before. Now when I drive it, my temp gauge will fluctuate from about 50 to 35 percent back and forth. I checked my fuses and my relays click on and off and I light tested my fan and am getting no light from high or low. My fan doesn't come on at all. Not real mechanically inclined but think its the fan. Does anyone else have anything they think it could be?
Not sure if this matters but my belt always squeals when I start my car of turn up my heater and fan
__________________
Cassidy Wall

2001 PT Cruiser "The OG PT"
17" Incubus Valera (Peel Coat Matte Black)
Ecsta ZR 205/45/17
Rockford Fosgate PMX-2
Sundown Audio Z-12 V.4 D1 Rev 2
Cadence ZRS C2 4k Amp
Mb Quart mids and tweets powered by phoenix gold
ST Suspensions 90272 Coilovers
Magnaflow 15680 2 1/4 single cat-back exhaust
Reply With Quote
  #2 (permalink)  
Old 29 Dec 2014, 09:26 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: Could installing a new stereo make my pt overheat?

not sure where you are but the low speed fan should be ON when the ac or defrost is on unless you have a turbo then i dnt know but id say its the fan what year how many miles any mods???? do not drive it hot or it will be a expensive fix
Reply With Quote
  #3 (permalink)  
Old 29 Dec 2014, 09:27 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Could installing a new stereo make my pt overheat?

Let car cool off completely and open radiator cap and top it up to the brim.
Yes, your fan probably died and and the reason temp gauge fluctuates is because you lost some coolant and air got in your system.

And the fan probably died on its own the reason you overheated is because you idled for so long.
Handy_Cruiser likes this.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles

Last edited by quicksilverdon; 29 Dec 2014 at 09:34 pm. Reason: added last sentence
Reply With Quote
  #4 (permalink)  
Old 30 Dec 2014, 07:14 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,353
Default Re: Could installing a new stereo make my pt overheat?

Quote:
Originally Posted by PTCass View Post
I recently installed a new system in my PT. It was okay for a while, then I started my car to charge up the battery and after about 10 of running idle my temp light came on and it started dumping fluid on the ground, overheating. Never once had this problem before. Now when I drive it, my temp gauge will fluctuate from about 50 to 35 percent back and forth. I checked my fuses and my relays click on and off and I light tested my fan and am getting no light from high or low. My fan doesn't come on at all. Not real mechanically inclined but think its the fan. Does anyone else have anything they think it could be?
Not sure if this matters but my belt always squeals when I start my car of turn up my heater and fan
New here....and a question
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HOW DO I MAKE MY STOCK STEREO I POD OR SMART PHONE COMPATIBLE? Busted_PT Sound and Security Forum 68 13 Aug 2013 04:31 pm
Issue installing aftermarket stereo 2w0 Sound and Security Forum 3 07 Aug 2012 07:19 pm
Another Overheat PT PTJohn Tech & Performance Forum 4 15 Sep 2011 12:53 pm
New to PT Stereo installing KuroKruiser Sound and Security Forum 10 22 Apr 2010 11:15 pm
Help Installing after market stereo CruisingCali Sound and Security Forum 3 29 May 2009 11:49 am


All times are GMT -5. The time now is 06:47 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors