PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Acceleration Issues?

 
Like Tree6Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Jan 2015, 09:33 am
Fresh Cruiser
 
Join Date: Jan 2015
Posts: 8
Default Acceleration Issues?

Hey there! I'm new so if this has been answered already I am sorry, I didn't see anything like it anywhere.

I have a 2007 PT Cruiser, Touring Edition with just over 70k. I bought it just over a month ago, has been great but something happened Wednesday and last night that is bothering me. Drove approx 80miles on HWY 24 to my moms house, pulled off my exit to a stoplight and stopped. Once it turned green I went to accelerate and my pedal was almost sticky, and then it jumped and revved and accelerated quickly and continued to do it until I got to the house and turned the car off. I thought my floor mat was sticking under my pedal so I moved it to my back seat, away from the pedal. Drove to grocery store (through 2 lights) and no issues, yay it's fixed, or so I thought. Drove it around town that night and yesterDAY and was fine. Drove back the 80 miles to my house and once I got off my exit and it started doing the exact same thing.

Both times I did use cruise control for a period of the drive, but I am at a loss as to what this could be and am a little scared to drive it even though it was fine today. Has anyone else had a similar issue? Is this something that I need to take to the mechanic today, or just watch? Thanks!
thecabinguy likes this.
Reply With Quote
  #2 (permalink)  
Old 02 Jan 2015, 09:41 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Default Re: Acceleration Issues?

Quote:
Originally Posted by KCCOInMyPT View Post
Hey there! I'm new so if this has been answered already I am sorry, I didn't see anything like it anywhere.

I have a 2007 PT Cruiser, Touring Edition with just over 70k. I bought it just over a month ago, has been great but something happened Wednesday and last night that is bothering me. Drove approx 80miles on HWY 24 to my moms house, pulled off my exit to a stoplight and stopped. Once it turned green I went to accelerate and my pedal was almost sticky, and then it jumped and revved and accelerated quickly and continued to do it until I got to the house and turned the car off. I thought my floor mat was sticking under my pedal so I moved it to my back seat, away from the pedal. Drove to grocery store (through 2 lights) and no issues, yay it's fixed, or so I thought. Drove it around town that night and yesterDAY and was fine. Drove back the 80 miles to my house and once I got off my exit and it started doing the exact same thing.

Both times I did use cruise control for a period of the drive, but I am at a loss as to what this could be and am a little scared to drive it even though it was fine today. Has anyone else had a similar issue? Is this something that I need to take to the mechanic today, or just watch? Thanks!
Check the throttle body to dee if shaft or blade hanging. Lub the pivot points and a little on the cables. Clean the throttle body with some spray carb cleaner. These would be the most likely issues. If that doesn't help. Look at the gas peddle end and see if you need to do something there.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 02 Jan 2015, 09:48 am
Fresh Cruiser
 
Join Date: Jan 2015
Posts: 8
Default Re: Acceleration Issues?

Thank you! I haven't even made my first payment and was starting to get worried! I'll try this and go from there.
Reply With Quote
  #4 (permalink)  
Old 02 Jan 2015, 09:52 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Default Re: Acceleration Issues?

Quote:
Originally Posted by KCCOInMyPT View Post
Thank you! I haven't even made my first payment and was starting to get worried! I'll try this and go from there.
Is it sticking and suddenly pops loose and you push it to far when this happens?
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #5 (permalink)  
Old 02 Jan 2015, 10:00 am
Fresh Cruiser
 
Join Date: Jan 2015
Posts: 8
Default Re: Acceleration Issues?

No, i pressing down like normal, and it starts slow and guns (from 1rpm to about 2\2.5rpm) with no additional pressure on the accelerator.
Reply With Quote
  #6 (permalink)  
Old 02 Jan 2015, 10:18 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Default Re: Acceleration Issues?

Quote:
Originally Posted by KCCOInMyPT View Post
No, i pressing down like normal, and it starts slow and guns (from 1rpm to about 2\2.5rpm) with no additional pressure on the accelerator.
Try the stuff i said can't hurt. But I will give this some more thought. Almost sounds like pushing resume on the cruise. but you didn;t say you did that.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #7 (permalink)  
Old 02 Jan 2015, 10:25 am
Cool Cruiser
 
Join Date: Apr 2014
Location: Missouri
Posts: 430
Default Re: Acceleration Issues?

a friend of mine had a bonneville that did the same thing. it was the cruise control. i would try taking a trip without the cruise and see if it happens again. sounds like it may just be the cruise control has a problem. the bonneville ran on vacuum and one of the lines had a leak. not sure how ours is controlled but that's just my opinion and experience. thanks.
__________________


2005 Purple Pt Touring 130k Still Running Strong

New timing belt and water pump at 130k.
Reply With Quote
  #8 (permalink)  
Old 02 Jan 2015, 12:56 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Acceleration Issues?

Quote:
Originally Posted by GrapeApe View Post
a friend of mine had a bonneville that did the same thing. it was the cruise control. i would try taking a trip without the cruise and see if it happens again. sounds like it may just be the cruise control has a problem. the bonneville ran on vacuum and one of the lines had a leak. not sure how ours is controlled but that's just my opinion and experience. thanks.
I agree symptoms do sound like cruise - I think there's a fuse for cruise - pull that to be sure it cannot engage and see.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #9 (permalink)  
Old 02 Jan 2015, 03:16 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,759
Cool Re: Acceleration Issues?

Quote:
Originally Posted by Busted_PT View Post
Check the throttle body to dee if shaft or blade hanging. Lub the pivot points and a little on the cables. Clean the throttle body with some spray carb cleaner. These would be the most likely issues. If that doesn't help. Look at the gas peddle end and see if you need to do something there.
Yup! This would be the first thing to check.
Last fall, I popped-in the painted intake modesty cover for a show, and disturbed the throttle cables or a connection.
The next time I started her, she was reving out of control; tapping the pedal did nothing to change that.
Shut her off quickly; checked all connections; and worked the throttle body cables a little; all has been good since.
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #10 (permalink)  
Old 02 Jan 2015, 04:17 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,346
Default Re: Acceleration Issues?

I would take off the cable cover off and work the throttle body by hand to see if was binding. But I would look for air leak around the throttle body too. Especially the air intake flex pipe..
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
acceleration issue Jaredcruiser185 Turbo Performance 10 08 Sep 2014 08:47 pm
PT Cruiser high rpms and strange acceleration issues CarNoob85 Tech & Performance Forum 9 28 Jan 2014 09:50 pm
Noise upon acceleration ncbeachchick Tech & Performance Forum 5 04 Dec 2009 07:22 am
speaker issues, wattage of stereo, door speaker replacement issues fabes89 General PT Cruiser Discussions 9 02 Jun 2009 10:59 am
Hesitation in Acceleration imduke2u Tech & Performance Forum 8 06 Jul 2002 07:36 pm


All times are GMT -5. The time now is 05:45 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors