PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
PT Cruiser cluster electrical issue solved, might help others..

 
Like Tree6Likes
  • 6 Post By lwprofile

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Jan 2015, 07:02 pm
Fresh Cruiser
 
Join Date: Jan 2015
Posts: 8
Default PT Cruiser cluster electrical issue solved, might help others..

I work on PT Cruisers once a week in our shop, and have found them to be mostly pleasing to repair. Enough so that I bought my daughter a 2005 GT Turbo, with everything, and she loves it.

To the point:
Ive spent the last two days working on a electrical issue on a 2006 Touring Edition where four seconds after turning the key on (or starting the vehicle) the gauges went dead while all the idiot lights came on and stayed on (including lights). Car ran and drove fine though.
I spent a while reading all of your threads on here and proceeded to check, clean all cables, grounds, checked computer (and reflashed), control module/fusebox, ignition elect switch, etc.

As I scanned each items communication, item by item, I finally came to the airbag module (underneath center console) and found it not to be communicating.
After removal of the console, I found it had fluid on it (maybe a spilled drink in center console, not sure).
This was the problem, and fixed it.
I hope this might help someone else, and am posting as I did not read in any of the posts on this issue that anyone checked this.
Best wishes.
Reply With Quote
  #2 (permalink)  
Old 13 Jan 2015, 07:40 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: PT Cruiser cluster electrical issue solved, might help others..

Welcome.
Strange.
Probably the airbag would not have deployed if it was needed, so that's another benefit.
Very helpful first post.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 13 Jan 2015, 08:06 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,883
Default Re: PT Cruiser cluster electrical issue solved, might help others..

Sounds like you have some good electrical troubleshooting skills. Welcome.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #4 (permalink)  
Old 13 Jan 2015, 09:39 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,455
Thumbs up Re: PT Cruiser cluster electrical issue solved, might help others..

Well Done, Cruiser Grasshopper!
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #5 (permalink)  
Old 13 Jan 2015, 09:56 pm
Senior Cruiser
 
Join Date: Jun 2014
Posts: 1,611
Thumbs up Re: PT Cruiser cluster electrical issue solved, might help others..

Nice post! Thanks for posting!
Reply With Quote
  #6 (permalink)  
Old 13 Jan 2015, 10:14 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: PT Cruiser cluster electrical issue solved, might help others..

Quote:
Originally Posted by lwprofile View Post
I work on PT Cruisers once a week in our shop, and have found them to be mostly pleasing to repair. Enough so that I bought my daughter a 2005 GT Turbo, with everything, and she loves it.

To the point:
Ive spent the last two days working on a electrical issue on a 2006 Touring Edition where four seconds after turning the key on (or starting the vehicle) the gauges went dead while all the idiot lights came on and stayed on (including lights). Car ran and drove fine though.
I spent a while reading all of your threads on here and proceeded to check, clean all cables, grounds, checked computer (and reflashed), control module/fusebox, ignition elect switch, etc.

As I scanned each items communication, item by item, I finally came to the airbag module (underneath center console) and found it not to be communicating.
After removal of the console, I found it had fluid on it (maybe a spilled drink in center console, not sure).
This was the problem, and fixed it.
I hope this might help someone else, and am posting as I did not read in any of the posts on this issue that anyone checked this.
Best wishes.
Was there any engine trouble codes when you were working on this problem and if so what codes? Thanks for the information.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!! I have an electrical issue Destroyer4 General PT Cruiser Discussions 8 19 Jun 2015 08:23 am
*Possibly solved cranking issue*....Strangely Enough PTCruisn81 Tech & Performance Forum 2 16 May 2013 02:57 am
Charging Issue Solved Many Thanks!!!! RMoore Tech & Performance Forum 0 27 Aug 2012 04:31 pm
Cluster electrical problem? lights flash guages go right to left then out. sterioffs General PT Cruiser Discussions 0 21 Aug 2012 06:53 pm
Electrical issue? DMod General PT Cruiser Discussions 38 23 Jan 2012 08:49 pm


All times are GMT -5. The time now is 09:09 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors