PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
08 PT Code P-0016 returns

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Jan 2015, 06:03 pm
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default 08 PT Code P-0016 returns >UPDATED<

I am stumped, we have spent a good bit of money this past fall getting everything up to snuff on our 08 PT and I am still having a serious issue.

P-0016
Possible causes
- Engine oil dirty
- Incorrect engine viscosity
- Crankshaft position sensor circuit is open or shorted
- Camshaft position sensor circuit is open or shorted
- Faulty crankshaft position sensor
- Faulty camshaft position sensor
- Timing gear misalign

Well, back tracking, we did the following within the last 45-60 days
New Plugs & Wires
Oil & Filter
New Air Filter
New Timing Belt, Water Pump, Pulley & Tensioner
New Drive Belts
New Cam Sensor
New Crank Sensor
New Battery

This code comes up randomly
Tonight for example.
I leave the university to head home, I get a few miles and it starts missing bad, barely accelerates and only if I sort of pump tap gingerly on the gas pedal. Takes a mile to get up to 45mph.

I get home, my guy resets the computer & now its fine again.
This has happened 3 times in the past 12 days!

I am stumped, Any ideas?


Edit,,, maybe this is a coincidence but 2 of the 4 times this has occurred it was just after going over some bumpy/rough road.

Last edited by Sarasmiles; 16 Jan 2015 at 04:01 pm.
Reply With Quote
  #2 (permalink)  
Old 14 Jan 2015, 06:47 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,328
Default Re: 08 PT Code P-0016 returns

Quote:
Originally Posted by Sarasmiles View Post
- Crankshaft position sensor circuit is open or shorted
- Camshaft position sensor circuit is open or shorted

Edit,,, maybe this is a coincidence but 2 of the 4 times this has occurred it was just after going over some bumpy/rough road.

Check the plugs/wires to the Crank & Cam Sensors...don't wiggle them, unplug them & plug them back in.
Also is there any oil leaking from the Cam Sensor..??
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #3 (permalink)  
Old 14 Jan 2015, 07:12 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: 08 PT Code P-0016 returns

Read the whole thread - don't worry about the code:
2001 pt with p0320 code

Hope it helps.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 14 Jan 2015, 07:18 pm
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default Re: 08 PT Code P-0016 returns

Quote:
Originally Posted by quicksilverdon View Post
Read the whole thread - don't worry about the code:
2001 pt with p0320 code

Hope it helps.

Are those wires routed the same on the 08?

Since I have no lift,, what would be the easiest way to check this,,
I assume, jack it up, right front tire off?
Or can it be seen from elsewhere?

Reply With Quote
  #5 (permalink)  
Old 14 Jan 2015, 07:21 pm
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default Re: 08 PT Code P-0016 returns

Quote:
Originally Posted by LionPT View Post
Check the plugs/wires to the Crank & Cam Sensors...don't wiggle them, unplug them & plug them back in.
Also is there any oil leaking from the Cam Sensor..??
No oil at cam sensor, the crank sensor was just installed last Saturday in hopes it was the problem.

Also,, when the mis-fire event happens, the check engine light blinks. I do not however get any mis-fire codes? I thought that was interesting in itself.
Reply With Quote
  #6 (permalink)  
Old 14 Jan 2015, 07:45 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: 08 PT Code P-0016 returns

Quote:
Originally Posted by Sarasmiles View Post
Are those wires routed the same on the 08?

Since I have no lift,, what would be the easiest way to check this,,
I assume, jack it up, right front tire off?
Or can it be seen from elsewhere?

Drive it up on ramps. Plastic "Rhino ramps" are perfect for the PT. No need to take wheel off. Get a big piece of cardboard and slide under.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #7 (permalink)  
Old 14 Jan 2015, 08:32 pm
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default Re: 08 PT Code P-0016 returns

I wont be able to even try getting under there until at the earliest tomorrow.



Now that this has been pointed out, I wonder if when I had the belts and stuff done if they disturbed that harness & clip?
Wouldn't that be a kick in the butt?

I did all the preventative service just to be messed up by something like this?
Add in the brakes & tires & sway bar bushings we just did with the other stuff and I am in it for nearly 2 grand!
Reply With Quote
  #8 (permalink)  
Old 14 Jan 2015, 11:15 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: 08 PT Code P-0016 returns

Quote:
Originally Posted by Sarasmiles View Post
I wont be able to even try getting under there until at the earliest tomorrow.



Now that this has been pointed out, I wonder if when I had the belts and stuff done if they disturbed that harness & clip?
Wouldn't that be a kick in the butt?

I did all the preventative service just to be messed up by something like this?
Add in the brakes & tires & sway bar bushings we just did with the other stuff and I am in it for nearly 2 grand!
Not likely. Others have had this happen with no work having been done in the area....
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #9 (permalink)  
Old 14 Jan 2015, 11:56 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,300
Default Re: 08 PT Code P-0016 returns

I would suggest physically checking both the Camshaft and Crankshaft sensor wires going from one end to the other end. You might have a chance that the wiring on one of them is rubbing against ground somewhere.
Did you buy Mopar Camshaft and Crankshaft sensors?
Reply With Quote
  #10 (permalink)  
Old 15 Jan 2015, 08:06 am
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default Re: 08 PT Code P-0016 returns

Quote:
Originally Posted by ptcruisersteve View Post
I would suggest physically checking both the Camshaft and Crankshaft sensor wires going from one end to the other end. You might have a chance that the wiring on one of them is rubbing against ground somewhere.
Did you buy Mopar Camshaft and Crankshaft sensors?
All Mopar parts/sensors.

Last night I drove around about 20 miles without issue. But that means nothing at this point as this has been an ongoing problem.

This car is garage kept and very clean.
Visually from the top everything looks great.
Headed to the shop in a bit, hopefully they will be able to locate the problem.

That harness in the picture, what else is going through that sleeve? Is it just the crank sensor or are there other wires present as well?

I have been having an ongoing intermittent P0420 as well.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
P0420 code Converter Code? 2008/110,000 miles Sarasmiles Tech & Performance Forum 8 28 Mar 2014 07:08 pm
code 0016 missing when warm spanky911 General PT Cruiser Discussions 4 14 Sep 2013 12:59 pm
gas pedal vibration returns edb General PT Cruiser Discussions 4 28 Sep 2012 09:56 am
eror codes 0344 0016 0522 graydon1973 Tech & Performance Forum 6 24 Sep 2012 08:35 pm
PINKS: ALL OUT | Armdrop Live returns on June 5/6 2009 TMPracing Canada PT Forum 0 20 Nov 2008 03:10 pm


All times are GMT -5. The time now is 03:27 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors