PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2008 PT Cruiser Idle Issues

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 31 Jan 2015, 06:07 pm
Fresh Cruiser
 
Join Date: Jan 2015
Posts: 6
Default 2008 PT Cruiser Idle Issues

I have a 2008 PT Cruiser that we know and understand very well. However I have been stumped trying to understand the Idle conditions. Need to Brainstorm with some Experts.

The Car has 110,000miles, has been basically rebuilt by myself. Timing Belt, Water pump fuel injector, most all sensors, hoses, etc... Many lessons learned during the project. After the project, the car has been running fantastic.

Recently, my wife who drives this car everyday... complained about small vibration when stopped, with the car in gear and the A/C on.... Now I understand.... the load on the engine my cause some drop. However, the ECM should monitor the MAP and adjust the TPS and IAC Valve according to the change in Air Flow relative to the Load on the engine...So I started to diagnose the problem.... The Car Seems to Drop 200rpm's for A/C and another 200rpm's when the car in in gear. So I manually adjusted the Idle Screw, to eliminate the slight vibration when fully loaded.... This worked... Until the Engine Light Came on, with P0507 code High Idle Code.... So I did more research... I reset the idle screw, checked each Sensor and cleaned the IAC.... and I still get this 200rpm drop for each load.... with the engine light still coming on...I want to know if the car's ECM should be smart enough to adjust for the varying loads, so that the RPM's remain the same. Currently, I need to Idle at 1200rpm, to account for the drop in A/C load and Car in Drive Load.... Thus resulting in 800rpm fully loaded and smooth idle. However the engine light is still on... What am I missing?... Need to get the Engine light off and have the car run smooth at fully loaded condition. Is this possible with these engines..? 1200rpm seems high... However, if I set the idle down too low the car vibration gets worse, when fully loaded..., Could the MAP, TPS or IAC loose some accuracy with age? Also just noticed, when the car starts.. it ramps to 1800rpm, then within 15-20sec everything normalizes, at 1100-1200rpms (no A/C, in Park).... Any thoughts?

Last edited by helirush; 31 Jan 2015 at 07:04 pm.
Reply With Quote
  #2 (permalink)  
Old 31 Jan 2015, 06:49 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,476
Default Re: 2008 PT Cruiser Idle Issues

Is your radiator fan low speed and high speed working okay?
Is your A/C working properly? Did you disconnect the A/C lines when you replaced your timing belt?
Did you check or replace your upper and lower torque struts after you replaced your timing belt?
Reply With Quote
  #3 (permalink)  
Old 31 Jan 2015, 07:53 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,424
Default Re: 2008 PT Cruiser Idle Issues

Some things you posted don't made sense to me...so here goes...
  • You can't really clean the AIC in the G2's, 2006-2010...it needs to be replaced.
  • The is no idle screw, it can be adjusted in the computer by a mechanic...did you do this or just adjust the throttle linkage..??

Are you getting any other codes..??
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #4 (permalink)  
Old 31 Jan 2015, 09:14 pm
Fresh Cruiser
 
Join Date: Jan 2015
Posts: 6
Default Re: 2008 PT Cruiser Idle Issues

Fan is working. Blows cold at Idle, no over heating problems.

Did not detach A/C lines when we did the engine maintenance.

Replaced all 3 motor mounts when we did the maintenance.

IAC Valve is certainly cleanable. Took it out and removed all the carbon with good carburetor cleaner.

There is an Idle screw on the back side. It is factory set and requires a secure Torx head to turn. Adjusting will advance the idle manually. However, It must affect the computers ability to get the proper Air/Fuel Mix, not sure.

No change to the Throttle linkage.

Again.. the car runs great, and this vibration is only at 700rpm or lower. The Code P0507 seems to come and go. Could be because I have been manually adjusting the idle and the computer does not like it...
Reply With Quote
  #5 (permalink)  
Old 31 Jan 2015, 10:30 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,476
Default Re: 2008 PT Cruiser Idle Issues

Does it idle rough when you are only in park or drive or both?
Reply With Quote
  #6 (permalink)  
Old 31 Jan 2015, 10:53 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,357
Default Re: 2008 PT Cruiser Idle Issues

Quote:
Originally Posted by LionPT View Post
Some things you posted don't made sense to me...so here goes...
  • You can't really clean the AIC in the G2's, 2006-2010...it needs to be replaced.
  • The is no idle screw, it can be adjusted in the computer by a mechanic...did you do this or just adjust the throttle linkage..??

Are you getting any other codes..??
I agree with LionPT to change the IAC. Computer is likely sending the signal for IAC but it is not responding, the light comes on when you adjusted the screw because idle is out of spec for the condition.
OR get it scanned and watch for signal and idle change to IAC
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #7 (permalink)  
Old 01 Feb 2015, 12:39 am
Fresh Cruiser
 
Join Date: Jan 2015
Posts: 6
Default Re: 2008 PT Cruiser Idle Issues

With Normal Idle (No A/C and in Park) it is perfect. The RPM's drop 200 with Full A/C, then another 200 when in Drive with foot on Brake. These drops may be normal, however anything below 700 the vibration starts. Thus is why I played with the Idle Screw, just to raise it a few hundred RPM, so the lower threshold never gets below 700. unfortunately this causes the Engine light to come on with the P0507 code.... I realize that the PCM is designed to adjust Fuel/Air, unfortunately, with PCM only, the RPM drops into the vibration zone which is below 700rpm. Any suggestions to improve Low RPM performance?
Is it possible for the IAC to perform poorly?
Reply With Quote
  #8 (permalink)  
Old 01 Feb 2015, 04:13 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,476
Default Re: 2008 PT Cruiser Idle Issues

I would suggest doing a fuel leak test.
I have had idle problems and have solved it with fuel injection cleaner.
Reply With Quote
  #9 (permalink)  
Old 01 Feb 2015, 12:18 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: 2008 PT Cruiser Idle Issues

Quote:
Originally Posted by helirush View Post
With Normal Idle (No A/C and in Park) it is perfect. The RPM's drop 200 with Full A/C, then another 200 when in Drive with foot on Brake. These drops may be normal, however anything below 700 the vibration starts. Thus is why I played with the Idle Screw, just to raise it a few hundred RPM, so the lower threshold never gets below 700. unfortunately this causes the Engine light to come on with the P0507 code.... I realize that the PCM is designed to adjust Fuel/Air, unfortunately, with PCM only, the RPM drops into the vibration zone which is below 700rpm. Any suggestions to improve Low RPM performance?
Is it possible for the IAC to perform poorly?
My '05 may be different, but my idle when warmed up in gear is about 750 - if I turn on A/C, idle goes up a hundred rpm or so, and idle stays smooth, and it is my understanding that it is the IAC that adjusts for A/C (and load in general).
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #10 (permalink)  
Old 01 Feb 2015, 05:11 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,476
Default Re: 2008 PT Cruiser Idle Issues

If there was something wrong with the IAC wouldn't you get an engine trouble code related to it? Quicksilverdon made a point about the rpm increasing when you turn on the A/C. On my 2008 PT Cruiser also drops between 100 to 200 rpm when I turn on the A/C and when I put it in drive but only for a second or so and then it goes back to approx. 750 rpm.

What is your rpm when its cold and when the engine is running at normal temperatures?

Has this problem existed since you replaced the timing belt?

Was there a reason for replacing most sensors?

Has the Map Sensor been checked?

Sometimes when the timing belt gets replaced vacuum hoses get stretched and becomes loose from the engine being moved. I would suggest checking for intake manifold leaks.

Last edited by ptcruisersteve; 01 Feb 2015 at 08:31 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 touring rough idle running out of ideas. poppagott Tech & Performance Forum 13 29 Jun 2014 07:01 pm
serious idle issues oldsguru2 Tech & Performance Forum 5 15 May 2012 08:17 pm
2008 PT Suspension Issues PokonoPT Wheels, Tires, Suspension 3 28 Feb 2012 05:19 am
06 GT Idle Issues War_Eagle Turbo Performance 2 06 Feb 2012 07:32 pm
2008 PT Starting Issues PTcruisinator Tech & Performance Forum 2 14 Jan 2010 08:25 pm


All times are GMT -5. The time now is 07:36 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors