PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Tach and temp gauge don't read accurate

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Feb 2015, 10:06 pm
Fresh Cruiser
 
Join Date: Jan 2015
Location: Cape Coral, FL
Posts: 3
Default Tach and temp gauge don't read accurate

I have been searching the forum a while and didn't find other topics with this issue but sorry if I missed one. Very helpful forum overall though considering I just did a total head job, water pump and timing belt in my 01 with all hand tools and never disconnected the a/c thanks to dozens of posts i read on here!

Anyways- the issue, since I bought it is tach reads low by over 1k rpm. Idles at 0. Turns about 700 rpm at 50 mph in O/D (AT car). Didn't bother me. All cluster lights were burnt out so I got a ten pack of #74 off amazon for a sweet price, pulled cluster, replaced all bulbs, reinstalled and ever since temp gauge starts at 3/4 mark and stops just past H. (Probably a needle stopper in there) I did the hold down trip od button and turn on ignition reset feature two separate times. Display cycles and all gauges run through their paces but coolant gauge starts at 3/4 and taps out past H and tach starts at 0 but taps out before 6.

I don't worry about tach but I want a working temp gauge. This started after cluster bulb replacement but before engine rebuild. Any ideas from anyone are welcome!
Reply With Quote
Reply

Tags
gauges, instrument cluster, tach, temp gauge


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Temp gauge please help Cyclone35 General PT Cruiser Discussions 4 18 Feb 2011 02:58 pm
Outside Temp Gauge Jeff V General Turbo Discussions 20 13 Dec 2010 06:00 pm
Gas gauge doesn't read full even though it is chaase Tech & Performance Forum 2 12 Apr 2009 04:08 pm
Tach, Speedo & gas gauge not working?! mothersonion General PT Cruiser Discussions 2 15 Sep 2008 09:12 pm
Tach Gauge balvarez814 Tech & Performance Forum 2 27 Aug 2008 02:04 pm


All times are GMT -5. The time now is 12:33 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors