PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Two Questions: Error on Odometer and Instrument Cluster removal

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Feb 2015, 07:37 pm
Fresh Cruiser
 
Join Date: Feb 2015
Posts: 1
Default Two Questions: Error on Odometer and Instrument Cluster removal

Hello everyone.

I recently got a PT Cruiser in excellent physical shape, but with a bunch of electrical problems that I've been working through.

My task-du-jour is getting the instrument cluster repaired/replaced. Currently the odometer shows "Error". The general consensus seems to be to replace it. However, being the cheap person I am, I was thinking I'm going to walk over it with a solder iron before I break down and spring for a new Instrument Cluster.

Couple questions:
  1. Does anyone have a link to remove the Instrument Cluster for a 2006-2010. I have found the other videos that deal with older models, and I'm after something for my model year.
  2. Does this car store the odometer reading in the cluster or is it stored on the PCM
  3. If it is stored on the cluster, does anyone know what the eeprom is, and possibly have a dump of one? (Assume I'm exceptionally well equipped to deal with reading chips)
  4. And while I'm at it, does anyone have the *Correct* service manual for this year. I've found the 2000 page one, but the schematics aren't correct and AllData is useless.

Thanks for any information!

Cheers
(PS: I've searched the forums, and there is an enormous amount of results for "Odometer")
Reply With Quote
  #2 (permalink)  
Old 05 Feb 2015, 08:51 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,420
Default Re: Two Questions: Error on Odometer and Instrument Cluster removal

Quote:
Originally Posted by gbestwick View Post
Hello everyone.

I recently got a PT Cruiser in excellent physical shape, but with a bunch of electrical problems that I've been working through.

My task-du-jour is getting the instrument cluster repaired/replaced. Currently the odometer shows "Error". The general consensus seems to be to replace it. However, being the cheap person I am, I was thinking I'm going to walk over it with a solder iron before I break down and spring for a new Instrument Cluster.

Couple questions:
  1. Does anyone have a link to remove the Instrument Cluster for a 2006-2010. I have found the other videos that deal with older models, and I'm after something for my model year.
  2. Does this car store the odometer reading in the cluster or is it stored on the PCM
  3. If it is stored on the cluster, does anyone know what the eeprom is, and possibly have a dump of one? (Assume I'm exceptionally well equipped to deal with reading chips)
  4. And while I'm at it, does anyone have the *Correct* service manual for this year. I've found the 2000 page one, but the schematics aren't correct and AllData is useless.

Thanks for any information!

Cheers
(PS: I've searched the forums, and there is an enormous amount of results for "Odometer")

It's pretty easy...
Pull off the the driver & passenger pillars & starting at the 2 end corners...pop out the corners of the dash...then take a flat plastic tool & just pull it along the front of the dash. Once the few clips are popped...just grab the back on the dash & pull it forward.

Watch this video about 1 min in.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost

Last edited by LionPT; 05 Feb 2015 at 08:53 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nothing working on instrument cluster probesport Tech & Performance Forum 49 24 Feb 2018 06:32 pm
Could it just be the instrument cluster? ukbeachbum General PT Cruiser Discussions 21 17 Sep 2015 08:50 pm
instrument cluster issues 05ptcruiser Tech & Performance Forum 2 08 Feb 2012 08:21 pm
Instrument Cluster for 2002 Bigdaddy_1106 Tech & Performance Forum 2 28 Jul 2011 11:20 am
Dead Instrument Cluster JohnBrehm General PT Cruiser Discussions 0 09 Jan 2011 10:16 pm


All times are GMT -5. The time now is 05:42 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors