PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
ABS Issues - Need help

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 25 Mar 2015, 01:15 pm
Fresh Cruiser
 
Join Date: Jul 2013
Location: Jacksonville, FL
Posts: 32
Default ABS Issues - Need help

I posted some issues regarding my ABS/Traction issues a couple of weeks ago but still can't seem to get a resolve.

The ABS and Trac lights go on and off but report no codes. The sensors are all reporting the same wheel speed when tested. I sometimes feel vibration on the brake pedal and sometimes can hear a rubbing sound when driving slowly, particular when slowly curving (as in a park). Sometimes when making sharp turns or hard turns (merging from one highway to the next), I here a pop/crack/something sound. Its definitely coming from the front of the car, I think more on the driver's side. The car has new control arms, bushings, shocks, tie rods.... everything seems tight on the front end but I still hear the noise and have the ABS issues.

One other odd piece of information: When the weather is cool and rainy, the issues are SIGNIFICANTLY reduced. Most times in that weather, the brakes never make the vibration/sound even though the lights may still come on.

Suggestions? Thoughts?
Need some thoughts on this one, the mechanic has not found anything that explains these issues yet.

Thanks!
Reply With Quote
Reply

Tags
abs, traction


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tie Rod issues maybe? 911Gal Wheels, Tires, Suspension 7 02 May 2015 12:23 pm
Lug issues Crid Tech & Performance Forum 19 10 Aug 2013 02:58 pm
UK MOT issues davea300 Europe PT Forum 16 15 Jul 2013 02:43 am
A/C issues... usmcwifey Tech & Performance Forum 8 07 Apr 2010 07:36 am
speaker issues, wattage of stereo, door speaker replacement issues fabes89 General PT Cruiser Discussions 9 02 Jun 2009 10:59 am


All times are GMT -5. The time now is 01:20 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors