PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
A/C not working - 2005 PT Cruiser

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Jul 2015, 10:34 am
Fresh Cruiser
 
Join Date: Jul 2015
Posts: 6
Default A/C not working - 2005 PT Cruiser

I have a 2005 pt cruiser and the a/c isn't working. Here's what I know so far:

-I have check the lines and there is coolant in the system
-I bought one of those a/c pros to add coolant and when I hooked it up, the arrow (not the one for the temperature outside), but the arrow for the system went to the red
-I checked the a/c fuse and relay and both are good
-I don't hear the click of the compressor turning on and off

I would appreciate any help, advice or info. Thanks.
Reply With Quote
  #2 (permalink)  
Old 08 Jul 2015, 01:54 pm
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,192
Default Re: A/C not working - 2005 PT Cruiser

Because Trump

Last edited by sanatanadharma; 10 Nov 2016 at 06:24 pm.
Reply With Quote
  #3 (permalink)  
Old 08 Jul 2015, 03:54 pm
Fresh Cruiser
 
Join Date: Jul 2015
Posts: 6
Default Re: A/C not working - 2005 PT Cruiser

I checked the fuses and they are good.
Reply With Quote
  #4 (permalink)  
Old 08 Jul 2015, 05:49 pm
Fresh Cruiser
 
Join Date: Jul 2015
Posts: 6
Default Re: A/C not working - 2005 PT Cruiser

I have a question, on my 2005 PT Cruiser, there are 2 service ports for the a/c, one by itself up on top that is very easy to get to, and another down by the fan in front that is very hard to get to. Which one is the one that I am suppose to hook to to charge the a/c? I know there is some coolant in it because I took the cap off the top port and pushed in the pin in the middle and some came out, so I know there is some in there, but which port do I hook to, to check the coolant or add freon to????
The top one is the one that I tried to add freon with before and when I hooked up to it, the arrow went straight to the RED.
I did some research today and did what it said, started the car, and let it run for a few minutes with a/c on (but there was no cold air obviously), then I turned it off and felt of the lines and the line on top that is easy to get to was hot to the touch and the one down by the fan, that was hard to reach seems cool to the touch or atleast definitely cooler than the other one. Did I do it wrong the first time??? I would appreciate any advice on which one is suppose to be the one to hook up and add coolant to.
Reply With Quote
Reply

Tags
a/c problems


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 PT Dream Cruiser - Brake and Tail Lights Stopped Working ArkansasTraveler General PT Cruiser Discussions 5 10 Aug 2015 07:42 pm
2005 PT Cruiser left side brake light not working bbodb1 General PT Cruiser Discussions 6 27 May 2014 07:13 pm
OEM radio - 2004 put in a 2005 - just stopped working thehoghunter Sound and Security Forum 7 27 Jan 2013 08:08 am
Rear Window Defroster not working after head gasket repair - 2005 PT Cruiser easkey Tech & Performance Forum 4 26 Dec 2012 01:52 pm
2005 2005 Convertible top/drivers windows not working rabidaardvark PT Cruiser Convertible Forum 6 08 Sep 2010 10:48 pm


All times are GMT -5. The time now is 10:42 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors