PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
high idle

 
Like Tree1Likes
  • 1 Post By JRH01cruiser

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01 Sep 2015, 09:51 pm
Fresh Cruiser
 
Join Date: Aug 2015
Location: Illinois
Posts: 8
Default high idle

Hello my name is John ( newbie )I inherited a one owner 2001 PT Cruiser non-turbo from the in laws recent timing belt and water pump replacement, thermostat replacement, I do have a question though, the air conditioning is blowing warm now when very recently was working fine, and when I firstly turn on the blower I hear a strange sound from the engine area. I don't mind yet because the summer is winding down but what I am wondering about is I had the classic idle trouble that would bounce up and down ( engine RPM ) BUT first upon cold start the idle would climb high to around 2800 or a bit lower and then the idle would not hold steady ( idle jump ), I had cleaned the IAC device very well, took the negative battery cable off then put back on to reset the PCM, and now all I have is the constant high idle, my guess is the TPS device or maybe that IAC device is non functioning all together? I APPRECIATE this forum especially crewzin
Reply With Quote
  #2 (permalink)  
Old 01 Sep 2015, 10:50 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: high idle

try removing the IAC again, gently pull the pintle valve inside forward a bit so you are sure it's closed when you reinstall it. when you reinstall it, leave the connector off and start the car. see where the idle is then.
-if it's still high it's likely a vacuum leak or the TB sticking partially open.
-if the idle is low and stays low, you need to find out why it the IAC is opening too much(as opposed to wasting money on a new one).

note: this will throw a code that you'll need to clear either with a scanner or by disconnecting the battery and stepping on the brake for a few seconds.

you can test the TPS with a multimeter. they hardly ever go bad though.
more on that here. Revving a little too high & not dropping quickly note the 0.6v is approximate as the computer tares it out like a digital scale

if you think it's a vacuum leak, be sure to check the steel EGR tube (and its O-ring) that bolts to the back of the intake. it's easy to miss if you're looking for a rubber hose leaking

Last edited by rob342; 01 Sep 2015 at 11:08 pm.
Reply With Quote
  #3 (permalink)  
Old 01 Sep 2015, 11:52 pm
Fresh Cruiser
 
Join Date: Aug 2015
Location: Illinois
Posts: 8
Thumbs up Re: high idle

Thank you rob342 I will proceed with those steps and then post my reply, have a great evening.
rob342 likes this.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Engine Idle and NO CODES Docjava66 General Turbo Discussions 23 19 Oct 2014 12:44 pm
Rough idle when fan at high speed whitty1700 Tech & Performance Forum 8 19 May 2013 02:24 pm
high idle after fuel additive scottc123fish Tech & Performance Forum 8 24 Oct 2012 10:43 pm
High idle 2001cruising Tech & Performance Forum 17 12 Sep 2012 09:17 am
2003 MT High Idle Sturdevant General Turbo Discussions 6 11 Sep 2007 09:55 pm


All times are GMT -5. The time now is 03:37 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors