PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2007 PT Cruiser won't start

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Oct 2015, 01:18 pm
Fresh Cruiser
 
Join Date: Oct 2015
Posts: 4
Default 2007 PT Cruiser won't start

I try to start it and all the lights for the gear selector light up on the dashboard. I have disconnected the negative cable for a few minutes and it will reset the light to only light up for park but once I try starting it again it puts all the gear selector lights back on and just clicks...new battery that has tested good...Not sure where to go from here. All other lights come on with no problem...just acts like it is locking the ignition.

Any help would be appreciated. I am trying to avoid having it towed to a dealership
Reply With Quote
  #2 (permalink)  
Old 14 Oct 2015, 01:40 pm
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,883
Default Re: 2007 PT Cruiser won't start

I am sure you will get more informed responses, but...

What do you mean by tested fine? Is the battery fully charged? Did you try boosting it? Double/triple check the connections? I'm guessing you did since you pulled the negative, but worth a shot. These things can act kind of whacky when the battery is low or the cables questionable.

I would try briskly (slamming?) the tilt wheel up and down and moving it in and out of park a few times and/or trying to start it in neutral. Probably won't work, but it is free.

Good luck

Last edited by Fk5; 14 Oct 2015 at 02:22 pm.
Reply With Quote
  #3 (permalink)  
Old 14 Oct 2015, 01:46 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,444
Default Re: 2007 PT Cruiser won't start

Quote:
Originally Posted by bacoffey View Post
I try to start it and all the lights for the gear selector light up on the dashboard. I have disconnected the negative cable for a few minutes and it will reset the light to only light up for park but once I try starting it again it puts all the gear selector lights back on and just clicks...new battery that has tested good...Not sure where to go from here. All other lights come on with no problem...just acts like it is locking the ignition.

Any help would be appreciated. I am trying to avoid having it towed to a dealership

How new is the battery..??
When you had it tested, did you get it load tested..??

Check these 2 ground wires next to the air box, pull them off & look for corrosion. Also make sure your battery terminals are clean & tight.

__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #4 (permalink)  
Old 14 Oct 2015, 02:12 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,598
Default Re: 2007 PT Cruiser won't start

I would suggest trying to start it in neutral if you can.
Reply With Quote
  #5 (permalink)  
Old 14 Oct 2015, 02:28 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,365
Default Re: 2007 PT Cruiser won't start

2006 - 2008 TSb is for no start- Static locks out the ignition and there are several replacement parts that are updated and need replaced

My 06 is parked---same thing.. New ignition switch doesn't help.
Jump starter-- it turns......
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #6 (permalink)  
Old 15 Oct 2015, 08:05 am
Fresh Cruiser
 
Join Date: Oct 2015
Posts: 4
Default Re: 2007 PT Cruiser won't start

Quote:
Originally Posted by Fk5 View Post
I am sure you will get more informed responses, but...

What do you mean by tested fine? Is the battery fully charged? Did you try boosting it? Double/triple check the connections? I'm guessing you did since you pulled the negative, but worth a shot. These things can act kind of whacky when the battery is low or the cables questionable.

I would try briskly (slamming?) the tilt wheel up and down and moving it in and out of park a few times and/or trying to start it in neutral. Probably won't work, but it is free.

Good luck
Battery is new and has been tested just to make sure. I will try replacing the cables this weekend. I did try the tilt wheel up and down and the park a few times. no luck. but thank you for the suggestion.
Reply With Quote
  #7 (permalink)  
Old 15 Oct 2015, 08:07 am
Fresh Cruiser
 
Join Date: Oct 2015
Posts: 4
Default Re: 2007 PT Cruiser won't start

i will try this this weekend thank you!
Reply With Quote
  #8 (permalink)  
Old 15 Oct 2015, 08:07 am
Obsessed Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 5,011
Default Re: 2007 PT Cruiser won't start

Have you just tried thumping the dash above the instrument cluster and see if that helps? I know it sounds stupid, but there could be a loose connection there indicating that you need to pull the cluster and check it .
__________________


Aspire to inspire before you expire.
Reply With Quote
  #9 (permalink)  
Old 15 Oct 2015, 08:10 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,598
Default Re: 2007 PT Cruiser won't start

I would suggest checking the starter relay if you are getting some clicking sounds. Try to find where the clicking sound is coming from if its not the starter relay.

Last edited by ptcruisersteve; 15 Oct 2015 at 08:30 am.
Reply With Quote
  #10 (permalink)  
Old 15 Oct 2015, 08:10 am
Fresh Cruiser
 
Join Date: Oct 2015
Posts: 4
Default Re: 2007 PT Cruiser won't start

Quote:
Originally Posted by LionPT View Post
How new is the battery..??
When you had it tested, did you get it load tested..??

Check these 2 ground wires next to the air box, pull them off & look for corrosion. Also make sure your battery terminals are clean & tight.

i will try this this weekend. Thank you!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote start retrofit for 2007 Touring? TroyO Interior Accessories Forum 1 23 Jan 2014 02:20 am
Help needed: 2007 PT Won't Start: Alarm / RKE Module - SKIM Key Issues bluebossa Tech & Performance Forum 6 05 Oct 2013 11:55 am
2007 diesel cruiser turns over but wont start after front end shunt guitarman Tech & Performance Forum 0 07 Jan 2013 06:37 am
2007 PT Cruiser Overheated now wont start!! kbryant Tech & Performance Forum 15 25 May 2012 03:55 pm
Pt Cruiser 2007 Does not start Selim Tech & Performance Forum 2 06 Feb 2010 09:24 pm


All times are GMT -5. The time now is 05:43 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors