PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2003 pt gruiser gt "clunk/crunch" sound from trans when clutch in

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Mar 2016, 11:20 pm
Fresh Cruiser
 
Join Date: Feb 2016
Posts: 4
Default 2003 pt gruiser gt "clunk/crunch" sound from trans when clutch in

Hi,
I recently bought a 2003 Pt cruiser Gt had about 108k on it owned by a older lady who maintained the car pretty well (wheel bearings, brakes, New suspension, New Gibson exhaust and timing belt/water pump/radiator done at 92k and a ton more.
Car has been great past few weeks, minus the leaky downpipe that I plan on replacing with a 3" outlet and downpipe. I just went to the store got back in and put the clutch pedal all the way to the floor and felt a clunk/crunch like something was moving under my feet as I started to go for reverse, Take the shifter into neutral and hold clutch down and feel/hear something crunching or almost moving making noise under my foot. put it into gear and goes rough, start to move and makes kind of a clunky sound moving slow and go faster goes away. Still shifts while moving easy. Come to a stop, clutch pedal in and starts making the clunk/crunch sound again and operates the same as before. I grab the phone to make a video for you tube and all of a sudden it magically goes away (funny how that works when you need to show someone something huh?) Take it up and down the road a few times and is fine now. Noticed my clutch fluid was a bit low, topped it off and retry and is fine still.

Now, I did notice it does have a very low noise like a tob problem at idle, clutch in and goes away, but it's not noticeable unless you are down by the wheel. I planned on doing the job soon anyways (previous owner never had clutch done) but I'm wondering if this could be the start of the tob going completely? I'm not super familiar with hydraulic tobs, all my cars have been Rwd and Had clutch forks so this fwd, dual mass flywheel and hydraulic tob is all new to me.
Any help would be appreciated, I can handle working on cars, previous toy was a mx83 Toyota cresaida I swapped a Nissan skyline Rb into with 240sx coilovers/suspension, z32 300zx brakes, mk3 supra lsd and a ton of other stuff too, so don't have a problem turning a wrench, just figure I'd ask people who are familiar with these cars. I have been searching, but a lot of people with manual trans have a non turbo (different trans) or I just get a ton of pt reviews, terrible other forums or dead end threads.

Anyways sorry to ramble so long, Amy pointers to trouble shoot/check would be great. if the problem comes back I will immediately grab the phone.
Reply With Quote
  #2 (permalink)  
Old 15 Mar 2016, 10:41 am
Fresh Cruiser
 
Join Date: Feb 2016
Posts: 4
Default Re: 2003 pt gruiser gt "clunk/crunch" sound from trans when clutch in

Well it happended again today, was fine all day and this morning came back. Was actually a lot more noticeable today and harder to get into gear, car is parked for now ordering the clutch kit for it today and start on the adventure tomorrow. Pretty sure it's the ton or clutch getting ready to go.
I'm going to replace rear main seal, axle seals and clean everything up anything else maintenance wise I should look into while in there?
Here's a link to video as well
https://www.youtube.com/watch?app=de...&v=J1b8aTNHdDE

Last edited by Bmxer300zx; 15 Mar 2016 at 10:46 am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get my PT Cruiser to start, lights/radio work, no sound is made when "starting" loraliromance Tech & Performance Forum 81 10 Oct 2015 07:25 pm
Rear end "clunk/thunk" joshuhwha General PT Cruiser Discussions 9 18 Mar 2015 12:40 pm
Turbo "phhsssss" or "whoosh" sound--Normal? Silenceable? Help! Memark General Turbo Discussions 13 24 Nov 2010 10:56 pm
"Seafoam TRANS TUNE" on a automatic Transmission? RedPT07 Tech & Performance Forum 12 21 Sep 2010 11:55 am


All times are GMT -5. The time now is 02:34 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors