PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2007 PT cruiser just cut off while I was driving it

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Apr 2016, 09:25 pm
Fresh Cruiser
 
Join Date: Apr 2016
Posts: 1
Default 2007 PT cruiser just cut off while I was driving it

I was driving my 2007 PT cruiser when it suddenly cut off and would not start again it turned over but didn't start my son used a thing that came up with a code the code was for a cam sensor which I replaced but it still wouldn't start but turns over can someone please help me
Reply With Quote
  #2 (permalink)  
Old 07 Apr 2016, 11:27 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: 2007 PT cruiser just cut off while I was driving it

I would suggest always writing down the engine trouble code so you can post the code when you need help. We need the specific code to give you a proper diagnosis of the problem.

I would suggest taking the camshaft sensor off and see if the camshaft is turning when you are cranking it.

What brand camshaft sensor did you install?

How many miles you have on the engine? Has the timing belt been replaced that you are aware of?

I would suggest you introduce yourself to the forum and post some info about your PT Cruiser.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 07 Apr 2016 at 11:29 pm.
Reply With Quote
  #3 (permalink)  
Old 08 Apr 2016, 06:06 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,328
Default Re: 2007 PT cruiser just cut off while I was driving it

Quote:
Originally Posted by Robin50 View Post
I was driving my 2007 PT cruiser when it suddenly cut off and would not start again it turned over but didn't start my son used a thing that came up with a code the code was for a cam sensor which I replaced but it still wouldn't start but turns over can someone please help me
Your car will run with a bad Camshaft Sensor, something else is wrong.
Pull the camshaft sensor like 'ptcruisersteve' suggested to see if cam is spinning, the timing belt might have broken.
You can also pull out the rubber plug #2 in pic to check.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 pt cruiser radio going in and out while driving miztheatre Tech & Performance Forum 1 02 Mar 2015 12:21 pm
How Many Here Have Been Harped On For Driving A PT Cruiser? GreatWhitePT General PT Cruiser Discussions 32 19 Oct 2014 06:32 pm
2007 Driving Lights (Installation Problem) vinzchlortho Exterior Accessories Forum 3 30 Apr 2008 10:59 pm


All times are GMT -5. The time now is 09:09 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors