PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Horn Not Working

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Apr 2016, 07:50 pm
Young Cruiser
 
Join Date: Feb 2015
Location: New Mexico
Posts: 75
Smile Horn Not Working

I had a number of vandalism attacks on my car in the last 2 years. Last week, my lawyer told me they would stop, semi-officially.

After resting a bit, I tried to work on car problems that had built up. I used my car to jump a stranger's car, and she had some sort of black coil on the left hand side she hooked it up to instead of the positive terminal. After that, other things began to happen.

The horn stopped working-would only work while turning, then would just turn on an not-stop. I replaced with a used horn switch, it got worse. I bought a new horn switch, made sure the switch was hooked up, then found out my drug addict step son had been showing me the rear of the front right headlight instead. I was in the process of replacing the grounding wire for the front right wheel, cut thru again, and then took off the panel. I used some spray electrical cleaning fluid. But, it still does not work.

So, what do I try next? The horn switch is new. I tried connecting the leads to both tabs, no luck. I checked fuse 23 in the TIPM, it's fine.

It had been disconnected to shut it off before, by a guy at autozone.

The Chilton manual said this
HORN DOES NOT SOUND
*
1. Check fuse 23 in the tipm.
1. Replace fuse if inoperative.
*
2. No voltage at horn relay terminals 62 AND 66 and fuse is ok.
2. No voltage, repair TIPM as necessary.
*
3. Open circuit from terminal 65 of the relay to horn switch x3 circuit.
3. Repair circuit as necessary.
*
4. Inoperative or damaged horn.
4. Voltage at horn when horn switch is pressed, replace horn.
*
5. Inoperative horn switch
5. Replace the horn switch.

I have the Haynes manual, what are the terminals listed above? Do I check them, or just get a new horn?
Reply With Quote
  #2 (permalink)  
Old 09 Apr 2016, 08:35 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: Horn Not Working

I would suggest checking the horn before you go out and buy a new one.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn not working, Fuses not blown... 2008 pt cruiser LX psyclon99 Sound and Security Forum 14 13 Jul 2016 06:27 pm
'02 DC, 71k miles, Radio and horn stopped working Bulwapo Sound and Security Forum 10 18 Apr 2014 08:42 pm
Horn not working in '06 RobF Tech & Performance Forum 3 20 Sep 2013 07:11 pm
Clock and horn quit working Frink General PT Cruiser Discussions 16 02 Dec 2012 06:01 pm
07 pt horn quit working lilpt07 General PT Cruiser Discussions 2 27 Jun 2010 10:08 am


All times are GMT -5. The time now is 10:48 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors