PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Pt cruiser throwing 10 codes

 
Like Tree5Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Apr 2016, 08:14 pm
Fresh Cruiser
 
Join Date: Apr 2016
Posts: 7
Default Pt cruiser throwing 10 codes

Hi everyone, my girl just bought an 06 PT GT Convertible automatic non-autostick with 93k miles. As soon as she brought it her driveway the CEL light came on. I scanned it the next day and here's the horror I saw:

P0551- Power Steering Pressure Sensor/Switch Circuit Range/Performance
P0700- Transmission Control System (MIL Request)
P1603- Loss of SDM Serial Data
P0480- Fan 1 Control Circuit
P0513- Incorrect Immobilizer Key
P1188- EOT Sensor Ckt. High Voltage
P0562- System Voltage Low
P0218- Transmission Fluid Overtemperature Condition
P0882- TCM Power Input Signal Low
P1684- Driver 5 Line 4

The ONLY symptom we notice is sometimes the car wont shift. It will go from 0-60 in the same gear wont shift up or down. This only happens sometimes. Radiator fan also works (so I dont know why P0480 is on unless it's for a different fan).
Randomly while the vcm scanner is hooked up several codes will disappear for a second, leaving only these showing:

P0551- Power Steering Pressure Sensor/Switch Circuit Range/Performance
P0700- Transmission Control System (MIL Request)
P1603- Loss of SDM Serial Data
P0480- Fan 1 Control Circuit
P0882- TCM Power Input Signal Low

I'm going to be looking for corroded wiring tomorrow as best I can, any other ideas as to what is going on? Thanks!
Reply With Quote
  #2 (permalink)  
Old 24 Apr 2016, 08:39 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: Pt cruiser throwing 10 codes

I would suggest checking the ground wires going to the inner driver's side fender. there are several ground wires going to a lug and bolted to the inner driver's side fender. The connections get corroded and then you start loosing ground to several modules.

If that is okay I would suggest you check your battery and battery cables. Make sure you do a battery load test with the battery still in the PT Cruiser. Make sure your battery cables are clean on both ends. On the positive battery cable there is additional wire going to it and make sure its making good contact. The PT Cruisers are sensitive to voltage drops and usually you get plenty of engine trouble codes when it happens.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 26 Apr 2016, 09:35 am
Fresh Cruiser
 
Join Date: Apr 2016
Posts: 7
Default Re: Pt cruiser throwing 10 codes

@ptcruisersteve
Thanks for the info, I looked over everything starting with corrosion on grounds, then wires, then the actual connectors. Everything was fine. Then I switched the battery from my car to her car since my battery was much bigger and I New it was working fine. No more problems all day. So we got a new battery and so far all is well, thanks for the info!
Reply With Quote
  #4 (permalink)  
Old 26 Apr 2016, 09:40 am
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,657
Default Re: Pt cruiser throwing 10 codes

I did not read where you cleared all the DTCs using a scan tool at the diagnostic connector and drove the vehicle about 30-50 miles and rechecked for DTC(s)?

Always the first thing that should be done ^^^^^^^^^^^^^^^^^^^^^^^
cruserdad1976 and chuzz like this.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #5 (permalink)  
Old 27 Apr 2016, 10:21 am
Fresh Cruiser
 
Join Date: Apr 2016
Posts: 7
Default Re: Pt cruiser throwing 10 codes

@NitroPT I did do that and they all came back, just forgot to mention it. Second day on the new battery and so far only the Fan code has come back, so going to replace that soon
Reply With Quote
  #6 (permalink)  
Old 27 Apr 2016, 10:37 am
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,657
Default Re: Pt cruiser throwing 10 codes

Quote:
Originally Posted by dailyboostin View Post
@NitroPT I did do that and they all came back, just forgot to mention it. Second day on the new battery and so far only the Fan code has come back, so going to replace that soon
The condition you posted with all the variances in the DTC of which most are not related would have a failing PCM, bad connectability with the PCM connectors or a connectability problem with the battery.

You are most likely posting your own cure by removing and reinstalling the battery ,the simple act disconcerting and re connecting the primary cables was probably one thing that helped improve your connection issue.

If anyone uses another donor vehicle, that battery should be first charged and load tested before using in any other vehicle as a problem resolver to rule out yet another electrical condition being introduced.
chuzz likes this.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #7 (permalink)  
Old 27 Apr 2016, 04:44 pm
Fresh Cruiser
 
Join Date: Apr 2016
Posts: 7
Default Re: Pt cruiser throwing 10 codes

P0551- Power Steering Pressure Sensor/Switch Circuit Range/Performance
P1603- Loss of SDM Serial Data
P0480- Fan 1 Control Circuit

These three codes have returned, along with a new one.

U0101- Lost Communication with TCM


The car is not going into limp mode anymore so far. I have thoroughly checked all the connectors and wiring from the trans to the TCM, Ive taken a wire brush and cleaned all the terminals.
We are having an issue where moments after the key is in the ON position (with the car off) the battery light will pop on. I'm unsure of whether this could have anything to do with the codes. The new battery is a 26R 715ca 575cca
Reply With Quote
  #8 (permalink)  
Old 27 Apr 2016, 05:34 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,267
Default Re: Pt cruiser throwing 10 codes

Here's an interesting little piece on this:

What is the dealer code p1603 for a pt cruiser
__________________
Reply With Quote
  #9 (permalink)  
Old 27 Apr 2016, 09:46 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: Pt cruiser throwing 10 codes

I would suggesting checking the ground wires going to the PCM

Also suggest checking the fused Ignition Switch (Off,Run,Start) circuit wires from the TIPM to the PCM. You might have resistance or a break in the wires involving the Fused Ignition Switch (Off, Run, Start) circuits.

Make sure you check this circuit before considering replacing the PCM. Others have replaced the PCM and still had the problem so you need to verify the Fused Ignition Switch (Off,Run,Start) circuit is working properly.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 27 Apr 2016 at 10:32 pm.
Reply With Quote
  #10 (permalink)  
Old 04 May 2016, 05:39 am
Fresh Cruiser
 
Join Date: Apr 2016
Posts: 7
Default Re: Pt cruiser throwing 10 codes

Sorry haven't been back in a while, just was able to look at the car yesterday. Couldn't find any wiring issues, my mechanic buddy looked at it also and said he was 99.9% positive it needs a pcm. That being said, does anyone know if any pt turbo auto pcm 06 and up will work, or does it need to be an 06?

Last edited by dailyboostin; 04 May 2016 at 05:56 am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
throwing codes 0121 & 0129 cannesman Tech & Performance Forum 3 05 Apr 2015 04:05 pm
PT Throwing Error Codes samxhalo General Turbo Discussions 9 27 Dec 2014 01:28 pm
Help with '01 NO spark/Start/throwing codes.. PLEASE!! domsob1974 Tech & Performance Forum 22 02 Sep 2014 09:26 am
I'm throwing some codes sleepy General Turbo Discussions 1 29 Sep 2012 10:14 pm
WE'RE THROWING IN THE TOWEL !! excelawashguy Vendors & Buyers Forum 5 19 Mar 2006 11:43 am


All times are GMT -5. The time now is 12:11 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors