PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
1 more overheadting problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Apr 2016, 09:27 pm
Fresh Cruiser
 
Join Date: Apr 2016
Posts: 1
Angry 1 more overheadting problem

Hey folks, Newbie here to the pt community. 05 non turbo coupe, purchased new, Florida resident.
Vehicle has 87,000 miles on it all scheduled maintenance completed on time,
3 years ego I installed a radiator and a fan, 3 months ego I had done the timing belt, water pump, tensioner, at 86,500 miles. I went out of town last week and the wife called me to say she had smelled anti freeze in the cabin, I told her most likely her heater core was seeping, She went autozone and bough a bottle of Blue devil Radiator and Block sealer On sale for 29.95 Woo ho what a bargain, NOT! The neighbor eager to help put the stuff in the vehicle and that's when the fun started... She called me the next morning that she had over heated coming home from work and had to be towed home, than she went on to tell me about the blue devil.....I hit the roof. So now i have been home and playing with this over heating issue for 2 days now.My eyes are bleeding from all the threads I read on overheating So with all the knowledge i gained on this forum I went to tackle this problem...I removed the t-sat full of white crystallized material, cleaned the neck, ( bypassed the heater core ) reclaimed anti freeze flushed the block and radiator, got a bunch of white crystal like substance out of the radiator, re filled with Auto zone 50/50 used a hose on the bleeder valve into a bottle to burp the system, let the bottle fill almost full Just to make sure that all the air was out, replaced t-stat and radiator cap, topped off and went for a ride. P.S. checked Fans, High speed and Low speed working fine, A/C on Fan comes on Also checked with Jumpers, both side of the fan low and high speeds Ok. Vehicle parked, temp gauge reaches half way fan comes on...
So i,m good to go.....Its 87 out today i set my trusty trip meter to 0 and zoom zoom zoom A/c cranking Music playing life is great... Wrong again...Didn't even make 8 miles before my temp gauge started climbing Got to 3/4 I shut the A/c off and glided home, Pulled in the driveway put the car in park and watched my temp gauge go back to 1/2... Burped system again, thinking i may have left some more air, Done this 3 times now and over heated at about 10 miles distance....Now its 10 pm and i,m frustrated.. Any help is appreciated. I,m pretty sure at this point that this Blue devil clogged up the radiator...Please keep in mind when i flushed it with a hose I got a good solid water pressure coming out of the bottom hose as well as the bottom bleed valve. Thanks
Reply With Quote
  #2 (permalink)  
Old 24 Apr 2016, 11:26 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,300
Default Re: 1 more overheadting problem

Are you overheating at high speeds or low speeds or both?

Do you hear any bubbling noise coming from under the hood?

Are you burping the coolant system before you bleed the system?

Have you checked your radiator cap? It might not be holding the proper pressure lowering the boiling point?

Have you checked the coolant temperature sensor to see if it working properly? You can use a thermal gun to verify the temperature of the engine.

Is the hose coming from the cap to the reservoir tank sealed and not leaking? If its leaking it can get air into the coolant system.

Are you leaking coolant? If you are not sure I would suggest doing a coolant pressure test. Its important to make sure you don't have any leaks.

By the way welcome to the forum. You should introduce yourself to the forum.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 24 Apr 2016 at 11:40 pm.
Reply With Quote
Reply

Tags
overheat, overheated, overheating engine


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starter problem? Relay problem or others? postbeauty General PT Cruiser Discussions 3 22 Jun 2015 05:52 pm
2001 PT Auto Trans Problem and Engine Rev Problem johnwwjr Tech & Performance Forum 4 18 Apr 2015 10:00 am
AC problem became Overheating problem BilltheBrewer Tech & Performance Forum 1 23 Jul 2014 11:31 pm
Window problem and AC problem kaypriest Tech & Performance Forum 30 04 Jul 2014 07:42 am
is it a balljoint problem or a wheel bearing problem? phtech Tech & Performance Forum 2 05 Mar 2011 04:33 pm


All times are GMT -5. The time now is 03:12 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors