PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2008 Cruiser Cam and Crank position sensors

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 May 2016, 02:52 pm
Fresh Cruiser
 
Join Date: May 2016
Location: Las Vegas
Posts: 2
Default 2008 Cruiser Cam and Crank position sensors

Driving kids to school about a month ago and the car suddenly died. Used a code reader that flashed codes for both Cam position and Crank position sensors, changed both with no change. Found after further inspection that the timing belt broke as well. Changed belt, pulley and tensioner since the replacement kit I bought came with everything, also changed the water pump since I was already in there. Ultimately after many busted knuckles and long nights the job is done. Car started and ran maybe 2-3 mins, started sputtering and running very rough then shuts off. Checked codes again and both Cam and Crank codes flashed again... Any suggestions, this' driving me nuts
Reply With Quote
  #2 (permalink)  
Old 21 May 2016, 03:03 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,300
Default Re: 2008 Cruiser Cam and Crank position sensors

After you replaced the timing belt did you rotate it several times to make sure the timing marks were right on? Many members have gotten the timing off by one tooth on the intake cam sprocket.

First thing I would suggest is to put the old crankshaft and camshaft sensor back in the PT Cruiser. We don't know if the new crankshaft and camshaft sensors are working properly
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 21 May 2016 at 03:45 pm.
Reply With Quote
  #3 (permalink)  
Old 21 May 2016, 03:57 pm
Fresh Cruiser
 
Join Date: May 2016
Location: Las Vegas
Posts: 2
Default Re: 2008 Cruiser Cam and Crank position sensors

Yes, I rotated the timing belt 2 full rotations and the timing was still good. I'll try replacing with the two old sensors and see what happens. Thanks for the suggestion
Reply With Quote
  #4 (permalink)  
Old 22 May 2016, 07:37 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,706
Default Re: 2008 Cruiser Cam and Crank position sensors

If you didn't use genuine MOPAR sensors and got those at your local Autobone, there's a very good chance that one or the other new sensor is bad. I don't recommend buying ANY electrical parts from Autobone. Having worked for them for 5 years, I can testify to the fact that a LOT of electrical parts come back as defective.
__________________


Aspire to inspire before you expire.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 PT Cruiser-No Crank No Start solution alexthegreat Tech & Performance Forum 1 30 Jun 2014 01:22 pm
TRADE....New Coolant Reservoir, New Coil, 2 New Throttle Position sensors VegasPTGT Classifieds: For Sale/Trade 2 11 Dec 2013 01:57 pm
TRADE....New Coil and 2 Throttle Position sensors VegasPTGT Classifieds: For Sale/Trade 0 22 Nov 2013 12:32 pm
2008 PT Cruiser crankshaft position sensor bigkhawk Welcome New PT Cruiser Members 7 18 Jul 2013 07:13 pm
2008 PT Cruiser CRANKSHAFT position sensor bigkhawk General PT Cruiser Discussions 1 16 Jul 2013 02:05 pm


All times are GMT -5. The time now is 03:46 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors