PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Fan wont turn on/ac wont work at idle (hear compressor click)/temp shows ok

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Jun 2016, 12:42 am
Cool Cruiser
 
Join Date: May 2013
Location: 20 minutes from downtown Los angeles
Posts: 213
Default Fan wont turn on/ac wont work at idle (hear compressor click)/temp shows ok

Okay so main issue was that the ac stopped working at idle. I hear the compressor try to start something. Like it spools up and it won't start. It will only blow air from outside. Not cooled.

I read the links as much as I could and I thought it was a bad fan. I bought a tyc one with the 4 prongs and relays. Ac does now work at idle but I never saw the fan turn on. I left the engine idling for 10 minutes and the temperature gauge never went past halfway. What could be the issue?

I never have done a coolant flush. I see that may be an issue. I only topped it off with zerex g-05.

I don't have any check engine lights nor do I see the temperature gauge go high or move around. It starts low, then after a few minutes of driving it warms up and stays in the middle.

Is everything okay? Why won't the fan turn on?

I'm taking it to a dealership at the end of the month for the timing belt, water pump, and transmission flush. Should I ask them to replace the ECT (is that the right abbreviation? Lol)

2006 base pt cruiser with 100k miles
__________________
--2006 pt cruiser non turbo owner. Completely stock... For now.
Reply With Quote
  #2 (permalink)  
Old 08 Jun 2016, 10:27 am
rsrocket1's Avatar
Fanatic Cruiser
 
Join Date: Mar 2016
Location: Sacramento, CA
Posts: 756
Default Re: Fan wont turn on/ac wont work at idle (hear compressor click)/temp shows ok

After a 15 minute or longer drive in the heat of the day with the A/C on, leave the engine and A/C running, lift the hood and look at the fan. With decent light, do you see the fan blades stopped? It might be tough because the blades are black. You could also put a sheet of paper in front of the radiator or a wet hand and feel if air is being drawn in. On high speed, there should be no doubt, low speed is a little tougher. Try it both with the A/C on and off.

If you are not getting an overheating condition and the A/C is working fine in stop and go traffic, your new fan is probably working correctly.
Reply With Quote
  #3 (permalink)  
Old 09 Jun 2016, 08:26 pm
Cool Cruiser
 
Join Date: May 2013
Location: 20 minutes from downtown Los angeles
Posts: 213
Default Re: Fan wont turn on/ac wont work at idle (hear compressor click)/temp shows ok

You're right. Even with a flashlight during the day, I couldn't see the blades moving. But I put a piece of paper in front of the grill and it stays on through suction. Fan is working!

Weird how I never got a high temperature though...
__________________
--2006 pt cruiser non turbo owner. Completely stock... For now.
Reply With Quote
  #4 (permalink)  
Old 09 Jun 2016, 08:49 pm
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: Fan wont turn on/ac wont work at idle (hear compressor click)/temp shows ok

You wouldn't want to get a high temperature. Slightly below the half mark is about normal. On a cold engine, turn on the a/c, the fan should immediately be running.

When you have the timing belt work done, IMO, you should also consider replacing: timing belt, water pump, idler pulley, tensioner, cam seals, crank seal, center engine mount.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HEADLIGHTS WONT TURN ON beanpt Tech & Performance Forum 15 29 Apr 2018 12:01 am
Turn signals wont work Rami76 Tech & Performance Forum 13 16 Apr 2015 07:44 am
01 PT cruiser wont start. Just hearing it click Vinwin Tech & Performance Forum 8 21 Sep 2013 01:48 pm
Headlights wont turn on but highbeams work uhhmm ok invidious Tech & Performance Forum 4 08 Jun 2009 11:25 pm
car wont turn on. fvillota General PT Cruiser Discussions 12 06 Apr 2009 10:56 pm


All times are GMT -5. The time now is 03:15 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors