PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Need some help with my 2001 Cruiser

 
Like Tree2Likes
  • 2 Post By ptcruisersteve

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Jun 2016, 12:21 pm
Fresh Cruiser
 
Join Date: Nov 2012
Location: Greensboro,nc
Posts: 7
Unhappy Need some help with my 2001 Cruiser

Hello everyone. I'm sorta new here, this is my first post.
I'm having problems with my car. Last year it died on me and I assumed it was the alternator. Had it changed thought everything was good. Battery light came on and hasn't gone off since after changing, the battery cables, the pcm, and a fuse. The OBD gave me a trouble code PO622.
I haven't had time to look at the alternator yet due to time and tools. (A decent jack.) Before I do, Is there something I need to reset? If so, where is it? The company that I bought the PCM from was supposed to do any and all programming. If I find that the wires are bad to the alternator, Is there a replacement set I could get? Please don't tell me I'm gonna have to buy the wire kit for the ENTIRE engine. Hated paying $123 for those battery cables. This car was cool in the beginning, but after having to have the timing belt replaced, bent valves, and stuff. Engine motor mounts, the radiator and I did have that phantom thing with the fog lights coming on and staying on. (Took out the fuse.) Haven't replaced that because of that part in the steering column that needs to be replaced. Lastly, the airbag light comes and goes off, but lately it stays on. I can live with that or it will be the last thing I address. I'M SERIOUSLY STARTING TO HATE THIS CAR!
Sorry this was long, but any help will be appreciated. Wish I had taken care of things sooner, but money was/is an issue.
Reply With Quote
  #2 (permalink)  
Old 09 Jun 2016, 12:56 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,267
Default Re: Need some help with my 2001 Cruiser

The code you are getting is P0622 - Generator Field Control Circuit Malfunction.

On your PT, the PCM works as the voltage regular. It turns the alternator on when the voltage gets too low and turns it off when it gets too high. This is done via the wires that plug into the back of the alternator.

You could have one of several things going on here. And chances are you did not need to replace both the alternator and the PCM. Your true likely issue may have just been the original alternator or wiring.

The best thing to do is start with what is simple and inexpensive and work your way up from there. If me, I'd start by disconnected the battery. Then I would removed and clean the large plug on the 2001 PCM. Then I would remove and clean the plug on the alternator. There are wires that run directly between these two plugs. I would inspect them and make sure they are in good shape. I would then put it all back together and see if the system is charging. I wouldn't trust the trouble light for this. Instead I would take a multi-meter and measure the voltage across the battery terminals while the PT is running. It should be around 12.5 volts or higher.

If no joy, I would remove the battery, have it fully charged and load-tested. If I didn't have my own charger and load testers, I'd take it to a parts store where they do this for free. The likelihood this is a battery problem is low. But at this point, I would want to rule this out before doing things that are harder and more expensive.

After this, I would suspect either the new alternator or PCM. But only after I did the things mentioned first.
__________________

Last edited by Handy_Cruiser; 09 Jun 2016 at 12:58 pm.
Reply With Quote
  #3 (permalink)  
Old 09 Jun 2016, 01:04 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: Need some help with my 2001 Cruiser

Just to be sure check to see if the wire harness from the crankshaft sensor to the PCM did not drop down from the engine block and might be hitting the half shaft burning through the wires and shorting the wires to ground. This is common with the 2001 PT Cruisers.
soyomb and Handy_Cruiser like this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #4 (permalink)  
Old 09 Jun 2016, 02:42 pm
VOS's Avatar
VOS VOS is offline
Cool Cruiser
 
Join Date: Mar 2015
Posts: 248
Default Re: Need some help with my 2001 Cruiser

Not sure which is the "large plug" of the two that go to the SBEC

This might help to check the wires:
Attached Files
File Type: zip POWERTRAIN CONTROL MODULE.zip (57.7 KB, 15 views)
Reply With Quote
  #5 (permalink)  
Old 09 Jun 2016, 07:05 pm
Fresh Cruiser
 
Join Date: Nov 2012
Location: Greensboro,nc
Posts: 7
Thumbs up Re: Need some help with my 2001 Cruiser

Thank you guys for your help! I will post later with the results!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 PT Cruiser LE commosutra Tech & Performance Forum 11 16 Sep 2014 08:35 pm
2001 PT Cruiser bscruizer Tech & Performance Forum 2 30 Jun 2014 10:18 pm
2001 PT Cruiser whirlinwilly Tech & Performance Forum 2 21 Apr 2014 03:37 pm
2001 PT Cruiser Teckspeed General PT Cruiser Discussions 10 02 Jul 2011 08:44 pm


All times are GMT -5. The time now is 05:58 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors