PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Need your thoughts/input on some codes and some issues...

 
Like Tree1Likes
  • 1 Post By ptcruisersteve

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Jun 2016, 07:15 pm
Fresh Cruiser
 
Join Date: Jul 2015
Posts: 10
Default Need your thoughts/input on some codes and some issues...

2006 2.4L NA Non-turbo, AUTO, 126,000 miles.

Hello all,

So in October of last year, I had made a trip from PA down to VA and it was a straight trip, not a lot of stopping except for gas. With that in mind, about an hour and half from my destination, I hit DC traffic and with the stop and go I eventually realized that my car was overheating... so I turned on the heater at full blast and then tried to let it cool down ....

So after that all happened, I ended up replacing my radiator fan thinking that it was faulty or worn out (since I've read that it happens a lot after 100k miles) and it appears that the low-speed of the fan is the issue...

Soon after the radiator fan issue, my drivers side low-beam headlight stopped working (even after replacing the bulb).

Fast forward to now: I have obtained an OBD-II scanner and have the following codes showing up:
P0218 - Powertrain Transmission Fluid Over Temperature Condition
P0714 - Powertrain Transmission Fluid Temporature Sensor Circuit INtermittent
P1684 - Powertrain (Battery disconnected in the last 50 restarts )

Also, I have noticed that while driving 40+ my car will "lightly lurch" forward as if there was a sudden boost of power and then other times will be the opposite ... a small loss of power (nothing drastic either way).



At this point, I'm starting to think that I need to replace the TIPM since that controls the headlights and that's seemingly one of the big issues, but also is probably the reason that my low-speed radiator doesn't come on, even though I've replaced the relay with a known good relay.


With these types of issues, and from the reading that I've done over the last few months, it seems to me that I either need a new PCM or TIPM ... one or both of them might be bad.


What is everyone's thoughts on this situation? Do I need to start thinking about getting a new vehicle?

Let me know if you need more info and I'll update this OP.

Last edited by dottee; 15 Jun 2016 at 07:18 pm.
Reply With Quote
  #2 (permalink)  
Old 15 Jun 2016, 07:20 pm
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,706
Default Re: Need your thoughts/input on some codes and some issues...

I seriously doubt that you need a new TIPM/PCM. Sounds to me like you need to replace a couple of sensors on the transmission. To get to them, you'll have to remove the airbox, battery and battery tray. As for the headlight, check your grounds. It may just be coincidental. As for the overheating issue, did you replace the thermostat and radiator cap? If not, they're cheap investments and if you have a lot of miles on the originals, it sure as hell won't hurt anything.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #3 (permalink)  
Old 15 Jun 2016, 08:36 pm
Fresh Cruiser
 
Join Date: Jul 2015
Posts: 10
Default Re: Need your thoughts/input on some codes and some issues...

I can definitely check the grounds, I replaced the radiator cap but not the thermostat yet. However, that wouldn't fix the no low-speed on radiator. As for the sensors, I can probably check those out without too much issue since I've been in that area before and am familiar.
Reply With Quote
  #4 (permalink)  
Old 15 Jun 2016, 09:20 pm
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: Need your thoughts/input on some codes and some issues...

My scan module sometimes picks up the same transmission codes (see below pic), but I was told by a dealership when I inquired about the transmission codes that the '06 does not have a transmission temp sensor. The P1684 just indicates that the battery has been recently disconnected.



As for your headlight and "lurching" issue, try disconnecting your battery negative terminal and leave it disconnected for at least 15 mins. Then reconnect it and do the transmission "quick learn" procedure (post #1 in link below). That may fix some of the shifting issues. It might also bring back the headlight by resetting the TIPM.

Transmission Relearn Process. How to Avoid it?

Have you had the timing belt work done yet on your PT? Are you the original vehicle owner?

Last edited by rckstein; 15 Jun 2016 at 09:44 pm.
Reply With Quote
  #5 (permalink)  
Old 15 Jun 2016, 09:27 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,300
Default Re: Need your thoughts/input on some codes and some issues...

Has the engine been overheating lately?

Anytime you overheat an engine the thermostat should always be replaced as the heat could change the thermostat allowing it not to work properly anymore.

I would suggest checking your transmission fluid level. Has the transmission oil and filter been changed lately?
rckstein likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #6 (permalink)  
Old 15 Jun 2016, 10:23 pm
Fresh Cruiser
 
Join Date: Jul 2015
Posts: 10
Default Re: Need your thoughts/input on some codes and some issues...

Quote:
Originally Posted by rckstein View Post
try disconnecting your battery negative terminal and leave it disconnected for at least 15 mins. ......It might also bring back the headlight by resetting the TIPM.
Oh, I've already had it disconnected for about an hour before, and it hasn't made a difference.

Quote:
Originally Posted by rckstein View Post
I'll have to take a look at that and see where I can do that... not something I can do easily in the city... lol

Quote:
Originally Posted by rckstein View Post
Have you had the timing belt work done yet on your PT? Are you the original vehicle owner?
I do not know if timing belt has been done, I'll ask my grandparents if they remember or not... I'm the second owner.
Reply With Quote
  #7 (permalink)  
Old 15 Jun 2016, 10:25 pm
Fresh Cruiser
 
Join Date: Jul 2015
Posts: 10
Default Re: Need your thoughts/input on some codes and some issues...

Quote:
Originally Posted by ptcruisersteve View Post
Has the engine been overheating lately?

Anytime you overheat an engine the thermostat should always be replaced as the heat could change the thermostat allowing it not to work properly anymore.

I would suggest checking your transmission fluid level. Has the transmission oil and filter been changed lately?
If I don't have the heater on, yes, it will start to overheat.

And I'll see about changing the thermostat, makes sense.

And I'll check the tranny fluid as well because I know that hasn't been checked nor changed in a while.
Reply With Quote
  #8 (permalink)  
Old 16 Jun 2016, 01:34 pm
Regular Cruiser
 
Join Date: Mar 2011
Posts: 164
Default Re: Need your thoughts/input on some codes and some issues...

Any chance the headlight issue is caused by the famous multi function switch on the left side of the steering column?
Reply With Quote
  #9 (permalink)  
Old 18 Jun 2016, 01:32 pm
edk edk is offline
Fresh Cruiser
 
Join Date: Jul 2013
Location: Florida - Central West Coast
Posts: 1
Default Re: Need your thoughts/input on some codes and some issues...

I had to replace the headlight relay switch on my 2004 not so long ago. It was a fairly easy job - even for a girl!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mech issues, multiple codes Painkiller7 Tech & Performance Forum 6 07 Sep 2015 09:31 am
2001 PT Cruiser codes 340 1391 340 not at once whats your thoughts MJKnight Tech & Performance Forum 10 25 Jun 2015 03:56 pm
Electrical issues ie. fog lights engine codes 04 PT turbo 1abidehandy Tech & Performance Forum 2 08 May 2014 05:46 pm
Codes, codes, codes... Desperately need engine light help... cdc3jj General PT Cruiser Discussions 9 01 Sep 2012 07:52 am
more error codes after new input/output sensors swordfish Tech & Performance Forum 0 07 Jul 2010 12:05 pm


All times are GMT -5. The time now is 03:13 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors