PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Compressor not turning on

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 22 Jun 2016, 06:22 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 11
Default Compressor not turning on

Hello everyone! It's been awhile since I have been on this site. A few years ago I was having issues with my AC, and thanks to this site figured out it was the fan. After fixing that issue My car still had a little bit of a rough idle, but hey everything else was fine. I have owned this car for 4 years and up until a month ago I had drove it everyday. So what happened was my car was due to be inspected and I needed to change my break pads and the camshaft sensor to pass inspection. (Although I did replace that sensor when I first got the car. Does it go bad that often?) So my fiancÚ did the brakes,spark plugs, and serpentine belt. When he started the car to make sure belt was working, the AC was blowing out hot air. He can not for the life of him figure out why it's doing that now. Then my car started throwing two codes instead of the one. The camshaft sensor code and P0123. He tried disconnecting the battery, but now the codes are not showing up but compressor is still not engaging. He Replaced one of the switches today but that wasn't it. So now my poor car is just sitting in my driveway😢Does anyone think the camshaft sensor or throttle body could be the culprit? Or something he did with spark plugs? And help or suggestions would be greatly appreciated. It is a 2008 pt cruiser.
Reply With Quote
  #2 (permalink)  
Old 22 Jun 2016, 06:34 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Compressor not turning on

The camshaft sensor nor spark plugs have nothing to do with your compressor not working. First and easiest, get yourself a container of A/C Pro at any car store. Hook it up to see if a small charge will get you back in business. Worked for me. No problem for years then it started to blow cool (not cold) air. Topped it off with the A/C Pro and all is well.

Reply With Quote
  #3 (permalink)  
Old 22 Jun 2016, 06:39 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 11
Default Re: Compressor not turning on

Sorry I forgot to put mention that was the first thing we tried. It won't work since the compressor will not turn on at all. The can doesn't get cold and it won't read the pressure.🙁
Reply With Quote
  #4 (permalink)  
Old 22 Jun 2016, 06:43 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 11
Default Re: Compressor not turning on

What about the P0123 code? Would that have anything to do with it?
Reply With Quote
  #5 (permalink)  
Old 22 Jun 2016, 06:55 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Compressor not turning on

Should have nothing to do with the A/C

P0123 Throttle Position Sensor/Switch A Circuit High Input : OBD-II Trouble Code
Reply With Quote
  #6 (permalink)  
Old 22 Jun 2016, 07:14 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,328
Default Re: Compressor not turning on

Quote:
Originally Posted by daydreamer311 View Post
Hello everyone! It's been awhile since I have been on this site. A few years ago I was having issues with my AC, and thanks to this site figured out it was the fan. After fixing that issue My car still had a little bit of a rough idle, but hey everything else was fine. I have owned this car for 4 years and up until a month ago I had drove it everyday. So what happened was my car was due to be inspected and I needed to change my break pads and the camshaft sensor to pass inspection. (Although I did replace that sensor when I first got the car. Does it go bad that often?) So my fiancÚ did the brakes,spark plugs, and serpentine belt. When he started the car to make sure belt was working, the AC was blowing out hot air. He can not for the life of him figure out why it's doing that now. Then my car started throwing two codes instead of the one. The camshaft sensor code and P0123. He tried disconnecting the battery, but now the codes are not showing up but compressor is still not engaging. He Replaced one of the switches today but that wasn't it. So now my poor car is just sitting in my driveway😢Does anyone think the camshaft sensor or throttle body could be the culprit? Or something he did with spark plugs? And help or suggestions would be greatly appreciated. It is a 2008 pt cruiser.

Check the plug that goes to the A/C, maybe he knocked it off when changing the belt.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #7 (permalink)  
Old 22 Jun 2016, 07:26 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 11
Default Re: Compressor not turning on

From what we can tell everything is plugged in that has to do with compressor. Checked the voltage to the compressive. Replaced low pressure switch. Changed out fan relays, Tried freon.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C reads NO Pressure, blows warm, no fan turning, no compressor kick on flafishergal General PT Cruiser Discussions 9 30 Apr 2014 05:09 pm
Ac compressor Jimmyo Tech & Performance Forum 12 23 May 2012 04:27 am
A/C Compressor Oil RaceWilson General PT Cruiser Discussions 0 28 Apr 2012 05:30 pm
a/c compressor fattmann Tech & Performance Forum 1 20 Mar 2012 10:24 am
Turning the AC compressor off during defrost mode? DJmart General PT Cruiser Discussions 6 15 Mar 2008 10:13 pm


All times are GMT -5. The time now is 10:15 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors