PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
P0508 and revving to 3k at startup

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Jun 2016, 09:12 pm
Fresh Cruiser
 
Join Date: May 2016
Posts: 4
Default P0508 and revving to 3k at startup

I've been having all sorts of new fun issues with my 2005 PT. I got a reman PCM and I'm experiencing some new behavior I've not seen before. Besides the P0508 code, when I start the car up (even when warm), it revs to about 2900 RPM before settling down to ~1k RPM idle. It never did that with my old PCM! Very weird. My IAC valve is fairly new, I have new seals on the intake manifold (both at the head and between the lower and upper manifold pieces), I can't find any obvious leaks from spraying water around intake air components, it's getting rather confusing.

Any experience with this is greatly appreciated!
Reply With Quote
  #2 (permalink)  
Old 30 Jun 2016, 06:29 am
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,336
Default Re: P0508 and revving to 3k at startup

Where di you get your PCM from? I got 3 or 4 from the same company before one actually worked (but only for 10 months)
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #3 (permalink)  
Old 30 Jun 2016, 12:40 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: P0508 and revving to 3k at startup

What problems were you having with the original PCM?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #4 (permalink)  
Old 30 Jun 2016, 02:28 pm
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,816
Default Re: P0508 and revving to 3k at startup

FWIW, 3k is where my car revs up to when it has a massive (ahem) vacuum leak. It will then settle down to 1200-1400. Double check all your vacuum lines and the lines to the booster. Pull the one on top of the throttle body off and it will behave much like that.
__________________
2003 GT 5 speed
162,000 miles
Reply With Quote
  #5 (permalink)  
Old 02 Jul 2016, 10:27 pm
Fresh Cruiser
 
Join Date: May 2016
Posts: 4
Default Re: P0508 and revving to 3k at startup

Quote:
Originally Posted by ptcruisersteve View Post
What problems were you having with the original PCM?
The speedometer stopped working. I checked the wire harness for continuity and replaced the trans output speed sensor (a cheap enough part) and still no speedometer. The new PCM fixed that problem... While introducing yet more issues.

Quote:
Originally Posted by JoeX View Post
Where di you get your PCM from? I got 3 or 4 from the same company before one actually worked (but only for 10 months)
All Computer Resources out of Florida. The first PCM they sent me was absolute garbage, came from them with numerous trans controller faults and wouldn't shift out of 3rd gear when it warmed up. They replaced that one with this one, which controls the trans a lot better, but now I have this weird issue.

Quote:
Originally Posted by Fk5 View Post
FWIW, 3k is where my car revs up to when it has a massive (ahem) vacuum leak. It will then settle down to 1200-1400. Double check all your vacuum lines and the lines to the booster. Pull the one on top of the throttle body off and it will behave much like that.
And I'm on the same page, absolutely. The really weird thing is that I've gone over the vacuum lines pretty finely and can't see any issues. I've put a hand vacuum pump on each of the 3 vacuum hookups on the intake and they all seem to hold a 20-25 psi vacuum. It's kinda boggling my mind.

Worse yet, I was pulling into a parking space at a hardware store today and just as I was getting ready to stop and put it into park, the car revved with any accelerator pedal input and scared the everloving piss outta me. Had to jam on the brakes to make it stop. Are there any non-obvious places for vacuum to leak?

Last edited by ArtemisGoldfish; 02 Jul 2016 at 10:31 pm.
Reply With Quote
  #6 (permalink)  
Old 02 Jul 2016, 10:46 pm
HippysChick's Avatar
Young Cruiser
 
Join Date: Jun 2016
Location: Space Coast, Florida
Posts: 78
Default Re: P0508 and revving to 3k at startup

Did you check your PCV valve? (I think that's the name of it.)

Our 07 PTC had a sticking valve - that may actually have been one genuine error that wasn't related to the Saga of the TIPM.
__________________
https://www.facebook.com/photo.php?fbid=10151892189824122&l=627caad7f3

Previous PT Cruiser: 2007 Touring Edition (non-Turbo) in Ocean Pearl.

Current Cruiser: 2007 Limited Edition Turbo, chrome trim package, Cool Vanilla (husband's car).

Now driving a 2014 Ford Escape SE 2.0 Ecoboost, Deep Impact blue (perhaps not the best name choice for a vehicle of mine!)
Reply With Quote
  #7 (permalink)  
Old 03 Jul 2016, 12:17 pm
Fresh Cruiser
 
Join Date: May 2016
Posts: 4
Default Re: P0508 and revving to 3k at startup

Quote:
Originally Posted by HippysChick View Post
Did you check your PCV valve? (I think that's the name of it.)

Our 07 PTC had a sticking valve - that may actually have been one genuine error that wasn't related to the Saga of the TIPM.
I'll pull it out and check it, but I replaced it not but maybe 3 or 4 months ago.
Reply With Quote
  #8 (permalink)  
Old 03 Jul 2016, 12:30 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,336
Default Re: P0508 and revving to 3k at startup

If you didn't have that high rev issue before , you should'n have with the new PCM. I got a bad one from them too, they refunded my money.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #9 (permalink)  
Old 03 Jul 2016, 12:37 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: P0508 and revving to 3k at startup

When did you replace the original PCM with the reman PCM?

Do you still have the original PCM?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply

Tags
p0508


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
P0508 / P0579 - codes won't go away MrSpkr Tech & Performance Forum 1 02 Nov 2015 01:57 pm
p0420 p0508 cocacola144 Tech & Performance Forum 25 09 Apr 2012 07:35 pm
No idle and codes P2074 and P0508 Cat22 Tech & Performance Forum 2 19 Oct 2011 05:57 pm
'04 limited turbo throws code p0522 and p0508 Blugirl Tech & Performance Forum 5 06 Dec 2010 04:24 am
Revving Problem? GuyOwen Tech & Performance Forum 2 17 Nov 2001 11:58 pm


All times are GMT -5. The time now is 09:49 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors