PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
P0551 Code My car does not have sensor

 
Like Tree2Likes
  • 2 Post By ptcruisersteve

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 31 Jul 2016, 12:34 am
Fresh Cruiser
 
Join Date: Apr 2016
Posts: 3
Default P0551 Code My car does not have sensor

Hello all. I need some help. I have a 2005 PT with about 68,000 miles and the check engine light has been on for a few months. I need to take care of it now because I need to get a smog check. I had a friend check it out to replace the sensor and I do not have one. We checked for leaks and there are none. What should I look for now? Any advice will help.

Thanks
Reply With Quote
  #2 (permalink)  
Old 31 Jul 2016, 01:01 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: P0551 Code My car does not have sensor

P0551 - Power Steering Pressure Switch Circuit Failure:

Possible Causes:
1. Power Steering Pressure Switch sense circuit is open or is shorted to ground
2. Power Steering Pressure Switch ground circuit is open
3. Power Steering Pressure Switch is damaged or it has failed
4. PCM has failed

Has the power steering unit been replaced with one from a junk yard?
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 31 Jul 2016 at 02:03 am.
Reply With Quote
  #3 (permalink)  
Old 31 Jul 2016, 01:17 am
Fresh Cruiser
 
Join Date: Apr 2016
Posts: 3
Default Re: P0551 Code My car does not have sensor

It has not been replaced at all. The only thing I have had to replace on the car is the clutch and camshaft position sensor. I am not sure what else to look for I was ready to replace it. Do you think dirty power steering fluid can cause it? I have been researching and most people just replace it and fixed.
Reply With Quote
  #4 (permalink)  
Old 31 Jul 2016, 01:48 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: P0551 Code My car does not have sensor

Quote:
Originally Posted by yoshimom View Post
It has not been replaced at all. The only thing I have had to replace on the car is the clutch and camshaft position sensor. I am not sure what else to look for I was ready to replace it. Do you think dirty power steering fluid can cause it? I have been researching and most people just replace it and fixed.
Does your friend know where the power steering pressure switch is located?

It should be mounted on the rear of the rack on the driver's side.

Did you check to make sure the power steering fluid level is okay?

PSswitch 2004 2005 power steering.jpg
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 31 Jul 2016 at 02:07 am.
Reply With Quote
  #5 (permalink)  
Old 31 Jul 2016, 02:02 am
Fresh Cruiser
 
Join Date: Apr 2016
Posts: 3
Default Re: P0551 Code My car does not have sensor

That is a great question. I thought they did but I might have to take a look myself. I will do some research and watch some youtube videos and tackle it tomorrow. I know it should be a simple fix. I hope it is.

Thanks for the picture.

Last edited by yoshimom; 31 Jul 2016 at 02:18 am.
Reply With Quote
  #6 (permalink)  
Old 31 Jul 2016, 02:22 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: P0551 Code My car does not have sensor

Did your friend go under the PT Cruiser to see it?

__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Code P0551 ????????? Baranca General PT Cruiser Discussions 2 12 Oct 2014 09:16 am
error code p0551 Ellenlyle General PT Cruiser Discussions 4 24 Jan 2014 02:32 pm
Code P0551 twodees Tech & Performance Forum 3 11 Mar 2013 10:50 am
Code p0551 LNBNDN Tech & Performance Forum 4 26 Oct 2011 08:51 am
Code P0551 - How Serious? BB General PT Cruiser Discussions 8 17 Aug 2005 11:12 pm


All times are GMT -5. The time now is 11:51 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors