PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Issue with the rad fan

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04 Sep 2016, 02:34 pm
whiteclaw's Avatar
Cool Cruiser
 
Join Date: Mar 2012
Location: United Kingdom
Posts: 422
Default Issue with the rad fan

So I thought it had gone kaput, car overheated the other day but was idling for ages and no sign the fan was working at all. Tried the car again, and no fan came on, however, car never overheated and then I heard it and could see it working again.

So my guess is, one of the relays maybe gone? I replaced the slow fan relay today, ordered the one for the high speed.

I had a code 1489
__________________
Chrysler PT Cruiser 2001, Automatic, No Mods, Right hand drive. 2.0

Reply With Quote
  #2 (permalink)  
Old 04 Sep 2016, 02:54 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,336
Default Re: Issue with the rad fan

Quote:
Originally Posted by whiteclaw View Post
So I thought it had gone kaput, car overheated the other day but was idling for ages and no sign the fan was working at all. Tried the car again, and no fan came on, however, car never overheated and then I heard it and could see it working again.

So my guess is, one of the relays maybe gone? I replaced the slow fan relay today, ordered the one for the high speed.

I had a code 1489
My guess is that you will be changing the fan shortly, when they are about the end of the life (brushes about gone) they will work les and less...
IHO
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #3 (permalink)  
Old 04 Sep 2016, 03:12 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,300
Default Re: Issue with the rad fan

P1489 - High Speed Radiator Fan Relay Circuit Malfunction:

Possible Causes:

1. High speed fan radiator relay control circuit is open or shorted to ground
2. High speed fan radiator relay power circuit is open
3. High speed fan radiator fan relay is damaged or has failed
4. PCM has failed

I am suggesting you check the wiring going to the high speed relay. Physically make sure the wiring is not touching ground or has cracks in it. You might just have a faulty high speed fan relay.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 04 Sep 2016 at 03:15 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Issue geeminator Tech & Performance Forum 1 21 May 2016 01:34 pm
Fan Issue mopardude Tech & Performance Forum 2 05 Apr 2012 05:22 am
AC Issue - Help if possible falconut Tech & Performance Forum 13 19 Aug 2011 12:40 pm
HID issue ilee941 Exterior Accessories Forum 3 12 Mar 2011 09:10 pm
A/C issue. hermtm2 General PT Cruiser Discussions 9 26 Jul 2008 08:40 pm


All times are GMT -5. The time now is 03:12 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors