PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
High speed fan coming on all the time....

 
Like Tree3Likes
  • 1 Post By CREWZIN
  • 1 Post By Fk5
  • 1 Post By ptcruisersteve

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Sep 2016, 11:33 am
thecabinguy's Avatar
Cool Cruiser
 
Join Date: Aug 2013
Location: Prescott, AZ
Posts: 272
Default High speed fan coming on all the time....

I had my radiator fan replaced in early 2015 on my '05 Touring, and I have always been a little suspicious of something. With my old fan, the high speed would come on with the A/C or defrost settings selected, otherwise I don't recall it coming on in normal driving with them off. This car in all the years I have owned it to this day has never overheated in any way. The highest on the temp gauge has been exactly 1/2. However, I have become to realize that, with me checking, I cannot ever seem to catch this newer fan ever running on the low speed. At an idle, for instance, even if just for a couple of minutes, the high speed fan will come on with its roar just like if the A/C was on. On my '02 this does not happen at all. The low speed will come on under these exact same circumstances, so the fans on the two cars do not work exactly the same way. To date I have not been overly concerned as both cars run the temp half way on the gauge like always. Just concerned that if my high speed speed on the '05 is running when the low speed should be, wouldn't I wear out the high speed sooner, hence replacing the fan that much sooner? Sorry if I seem to go on and on but just am trying to cover all bases. Thanks for any info that can be helpful.
__________________
Prescott, Arizona, home of forested mountains, 5 lakes (well, four lakes and one big pond), and Arizona's Christmas City (my home 6,000 feet elevation) - 2005 Touring & 2002 Limited - both patriot blue & factory stock
Reply With Quote
  #2 (permalink)  
Old 09 Sep 2016, 11:40 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: High speed fan coming on all the time....

If you had a good scanner, you could run the fan through it's routine and see if the low speed is working, or if you know someone at a shop or a friend with one. You probably know you can't hear or see when the low speed is on. Very quiet and hard to actually see it. When I was testing mine I put a couple paint dabs on the blades so I could readily see it turning.
thecabinguy likes this.
Reply With Quote
  #3 (permalink)  
Old 09 Sep 2016, 12:07 pm
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,828
Default Re: High speed fan coming on all the time....

When I swapped out my radiator (along with a ton of other stuff) I didn't have the plug in perfectly and anytime that I started my car the fan would come on high. I undid the plug, cleaned it up and seated it right and it has been (knock wood) good ever since.

My car is an '03 turbo with the pulse with modulation fan control, so take this FWIW.
thecabinguy likes this.
__________________
2003 GT 5 speed
162,000 miles
Reply With Quote
  #4 (permalink)  
Old 09 Sep 2016, 12:08 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: High speed fan coming on all the time....

If the low speed relay circuit is open or or the low speed fan relay is missing it's possible the high speed on the radiator fan will be on all the time. I would suggest checking the low speed fan relay and see if its working properly. If the low speed fan relay is working properly then you need to check the low speed on the radiator fan to see if that is working properly.
thecabinguy likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Locating Radiator Fan relays High Speed and Low Speed CashReject Tech & Performance Forum 14 06 May 2017 12:12 am
fan tests ok not coming on low or high, have new relays! azdave General PT Cruiser Discussions 38 24 Apr 2015 01:17 pm
high speed fan relay wwwthis General Turbo Discussions 7 19 Sep 2014 08:23 pm
Fan speed when a/c on? And a/c pressure going high RacerX125 General PT Cruiser Discussions 4 09 Jun 2014 03:39 pm
Rad fan only high speed Shieldwolf Tech & Performance Forum 8 17 Jun 2012 12:06 am


All times are GMT -5. The time now is 05:44 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors