PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Power Steering gone AWOL

 
Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Sep 2016, 01:30 am
Sinbad's Avatar
Fanatic Cruiser
 
Join Date: Sep 2016
Posts: 535
Default Power Steering gone AWOL

Morning all, kind of a new user but I've been lurking since I bought the money pit (I'll do a better introduction of me and the PT later, but I have to work to pay for it )

Long story short: cam belt replaced, all good - took the car back in because the parts place didn't have the long serpentine belt and the bloke said he'd fit iut when it turned up. This was two days later, and everything was hunky dory.

They put the new belt on, drove it out and........ no power steering

They put the old belt back on, and the power steering worked for..... about 5 minutes.

I took it away because I was due to drive it across France on holiday and couldn't spare the time or the aggravation so I drove it without PS, having changed the fluid, cleaned out the guaze filter, bled it, checked rack switch etc etc - all the usual suspects - with no result.

The pump has made no noises at all, and pumps well (ie, fluid is circulating back into the pot and pressure looks OK - so there should be *something* by the way of assistance...)

I'm now down to grasping at straws...

Is there a speed sensor somewhere on a PT that might have gone dead on me or have dodgy wiring? It's about all I can think off... that a sensor is telling the computer that I'm "at speed" even when I'm standing still, and so has cut power assistance...???

It's an '01 LHD import 2.0ltr manual, and there's no codes coming up for anything.... so, over to the experts....

Regs, Sinbad
Reply With Quote
  #2 (permalink)  
Old 24 Sep 2016, 02:08 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: Power Steering gone AWOL

Welcome to the forum.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 24 Sep 2016, 06:00 am
Sinbad's Avatar
Fanatic Cruiser
 
Join Date: Sep 2016
Posts: 535
Default Re: Power Steering gone AWOL

Thanks Steve
Reply With Quote
  #4 (permalink)  
Old 24 Sep 2016, 10:42 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: Power Steering gone AWOL

Have you checked the screen in the reservoir?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #5 (permalink)  
Old 24 Sep 2016, 11:59 am
Sinbad's Avatar
Fanatic Cruiser
 
Join Date: Sep 2016
Posts: 535
Default Re: Power Steering gone AWOL

Quote:
Originally Posted by ptcruisersteve View Post
Have you checked the screen in the reservoir?
Yep. Soaked it in petrol for an hour then washed it through with a brush and brake cleaner. Not as clean as a whistle but as near as damn it - and the PAS was working fine, so I'm doubting whether it would have just blocked.

I really suspect some sensor or switch somewhere has jacked it in. It's the only logical explanation, because there's no leaks and the pump works just as it did before and hasn't failed or started to - it makes no noise whatsoever and fluid is circulating just as it should.

PITA....
Reply With Quote
  #6 (permalink)  
Old 24 Sep 2016, 12:19 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: Power Steering gone AWOL

Is your engine light on? If so do you have an OBDII Scan Tool to find what codes it has triggered?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #7 (permalink)  
Old 24 Sep 2016, 01:03 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,632
Default Re: Power Steering gone AWOL

Welcome to the forum
__________________
Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #8 (permalink)  
Old 24 Sep 2016, 01:17 pm
Sinbad's Avatar
Fanatic Cruiser
 
Join Date: Sep 2016
Posts: 535
Default Re: Power Steering gone AWOL

Quote:
Originally Posted by ptcruisersteve View Post
Is your engine light on? If so do you have an OBDII Scan Tool to find what codes it has triggered?

Nope. No engine light and no codes apart from Ye Olde "Battery disconnected 50 starts ago" thing.
Reply With Quote
  #9 (permalink)  
Old 24 Sep 2016, 01:18 pm
Sinbad's Avatar
Fanatic Cruiser
 
Join Date: Sep 2016
Posts: 535
Default Re: Power Steering gone AWOL

Quote:
Originally Posted by NitroPT View Post
Welcome to the forum
Cheers nitro
Reply With Quote
  #10 (permalink)  
Old 24 Sep 2016, 01:21 pm
Sinbad's Avatar
Fanatic Cruiser
 
Join Date: Sep 2016
Posts: 535
Default Re: Power Steering gone AWOL

Does the pump have some kind of pressure relief valve that might be stuck open?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Steering Gone SkyCaptain Tech & Performance Forum 5 15 Dec 2015 12:28 pm
Power Steering-it takes power just to steer it 05PTGT General Turbo Discussions 8 29 Jan 2013 08:37 pm
Power steering ??? Hayworth Tech & Performance Forum 4 22 Nov 2009 06:09 pm
Help...No power steering scottw General PT Cruiser Discussions 17 21 May 2008 09:13 pm
ATF + 4 or 5 for power steering? quicksilverdon General PT Cruiser Discussions 2 21 Feb 2005 05:00 pm


All times are GMT -5. The time now is 08:05 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors