PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
PCM/SKIM issues

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Sep 2016, 11:38 am
Fresh Cruiser
 
Join Date: Sep 2016
Posts: 3
Default PCM/SKIM issues

New here, so I'm hoping this is the right place for this.

I have a 2007, Non-Turbo, Touring Edition with about 177k.

I'm having this issue where I put the key in and the car starts, runs for about a second or two, and dies. The red security light starts flashing when it dies. It used to do it every once in a while (every 20 starts or so), but now it's doing it every time. Shows a code P0513, which is invalid SKIM key.

I've done a little reading both here and other forums, and it sounds like a problem with the PCM. I've found replacement ones on eBay for $120 or so, which say they will program it to my VIN.

But I have heard that there is a separate programming that needs to be done for the SKIM key, and some places say to simply have the key chip reprogrammed. I don't wanna buy the PCM if I can just have the key fixed, or have a new key made.

Does anyone have any suggestions as to what I should do first? I want to get this fixed as cheaply as possible.
Reply With Quote
  #2 (permalink)  
Old 27 Sep 2016, 12:14 pm
VsandFords's Avatar
Senior Cruiser
 
Join Date: Apr 2014
Location: Gladewater, Texas
Posts: 1,893
Default Re: PCM/SKIM issues

I don't have an answer for your problem. I just wanted to say, welcome to the forum. There is someone here that will be able to help with this.
__________________
Life is just a bowl of jello, full of fruits and nuts.

2001 LE, auto, billet grille, tall shifter, polished aluminum spare, K&N filter and Hedman hedder. Why a header? Because it makes me happy!


Reply With Quote
  #3 (permalink)  
Old 27 Sep 2016, 12:32 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: PCM/SKIM issues

Welcome to the forum.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #4 (permalink)  
Old 27 Sep 2016, 02:15 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,263
Default Re: PCM/SKIM issues

Quote:
Originally Posted by mtylr0810 View Post
New here, so I'm hoping this is the right place for this.

I have a 2007, Non-Turbo, Touring Edition with about 177k.

I'm having this issue where I put the key in and the car starts, runs for about a second or two, and dies. The red security light starts flashing when it dies. It used to do it every once in a while (every 20 starts or so), but now it's doing it every time. Shows a code P0513, which is invalid SKIM key.

I've done a little reading both here and other forums, and it sounds like a problem with the PCM. I've found replacement ones on eBay for $120 or so, which say they will program it to my VIN.

But I have heard that there is a separate programming that needs to be done for the SKIM key, and some places say to simply have the key chip reprogrammed. I don't wanna buy the PCM if I can just have the key fixed, or have a new key made.

Does anyone have any suggestions as to what I should do first? I want to get this fixed as cheaply as possible.

Welcome to the forum from the great sovereign state of Arkansas!

Your issue may be the PCM, SKIM, sentry key or the wiring harness in between.

First, if you have a second sentry key, try it. There's chance the SKIM will detect the second key where it no longer detects the first one.

If no joy, you may find it difficult to go further with this your self. Without a DRBIII scan tool or other similar system, it becomes almost impossible to diagnose this issue at home except for changing out parts and hoping for the best. And the only way I would attempt this is if a I had another PCM, SKIM and sentry key that were already mated together. Just purchasing a another PCM (flashed to your VIN) is going to be a gamble since the problem may not be the PCM at all.

In this instance, I believe the cheaper and likely better solution may be to take your PT to a shop with the proper diagnostic tools. Luckily, some shops have this equipment now so you do not necessarily have to go to the dealership like you would have just a few years before.
__________________
Reply With Quote
  #5 (permalink)  
Old 27 Sep 2016, 02:41 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: PCM/SKIM issues

Quote:
Originally Posted by mtylr0810 View Post
New here, so I'm hoping this is the right place for this.

I have a 2007, Non-Turbo, Touring Edition with about 177k.

I'm having this issue where I put the key in and the car starts, runs for about a second or two, and dies. The red security light starts flashing when it dies. It used to do it every once in a while (every 20 starts or so), but now it's doing it every time. Shows a code P0513, which is invalid SKIM key.

I've done a little reading both here and other forums, and it sounds like a problem with the PCM. I've found replacement ones on eBay for $120 or so, which say they will program it to my VIN.

But I have heard that there is a separate programming that needs to be done for the SKIM key, and some places say to simply have the key chip reprogrammed. I don't wanna buy the PCM if I can just have the key fixed, or have a new key made.

Does anyone have any suggestions as to what I should do first? I want to get this fixed as cheaply as possible.
P0513 - Invalid SKIM Key.

Possible Causes:

1. Incorrect VIN in PCM
2. Invalid SKIM key not present ( Sentry Key Immobilizer Module (SKIM)
3. No communication with SKIM
4. No VIN programmed in the PCM
5. PCM
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 27 Sep 2016 at 04:34 pm.
Reply With Quote
  #6 (permalink)  
Old 27 Sep 2016, 04:18 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,336
Default Re: PCM/SKIM issues

There is a TSB on this problem. Cannot find it right now..
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #7 (permalink)  
Old 27 Sep 2016, 04:33 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: PCM/SKIM issues

There is 26 confirmed fixes on the information below.

1. Vehicle was towed in for a no start condition. The vehicle will not crank or start....
2006 Chrysler PT Cruiser 2.4L, Vin B
Test Details... Confirmed Fix Details...

Tests/Procedures: 1. Check the codes in the Powertrain Control Module (PCM). 2. If there is a P0513, check the codes in the Sentry Key Remote Entry Module (Skreem), Sentry Key Immobilizer Module (SKIM) or Wireless ...

26 Confirmed fixes

Security Key Remote Electronic Entry Module (SKREEM)
Sentry Key Immobilizer System (SKIM) Key


9 - Sentry Key Immobilizer (SKIM) Key
3 - Ignition Lock Cylinder Housing
2 - Fuse #33
2 - Security Key Remote Electronic Entry Module (SKREEM)
1 - Ignition Lock Cylinder Housing, Ignition Switch
1 - Keyless Entry
1 - Security Key Remote Electronic Entry Module (SKREEM), Sentry Key Immobilizer (SKIM) Key
1 - Ignition Key(s), Security Key Remote Electronic Entry Module (SKREEM)
1 - Powertrain Control Module (PCM), Security Key Remote Electronic Entry Module (SKREEM)
1 - Ignition Switch
1 - Powertrain Control Module (PCM)
1 - Ignition Lock Cylinder
1 - Battery Disconnect/Reconnect
1 - Ignition Lock Cylinder, Ignition Switch
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #8 (permalink)  
Old 28 Sep 2016, 03:12 pm
Fresh Cruiser
 
Join Date: Sep 2016
Posts: 3
Default Re: PCM/SKIM issues

GUYS! A BREAKTHROUGH!

The problem isn't 100% fixed but I'm going to put this here in case it helps anyone.

I had noticed that if I turned the key to the on position, but didn't start the car, I could wait to see if the security light came on. No light = no problem starting, but if the light flashed, I knew not to even bother starting the engine because it wasn't going to work. So...

I was messing around and noticed if I pushed the key into the ignition really hard while I was turning it, the whole ignition cylinder would push in a couple centimeters. No security light. Doing this allowed me to start the car no problem!

Obviously the problem isn't really fixed, but I least I have a workaround to be able to use my car while I try to fix it. Still shows code P0513.

I can get a new ignition for relatively cheap. Does anyone have thoughts as to whether or not that's where the issue is? I plan on taking it to a mechanic with a drbiii this weekend, but any extra input is totally welcome.
Reply With Quote
  #9 (permalink)  
Old 28 Sep 2016, 07:12 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,263
Default Re: PCM/SKIM issues

Quote:
Originally Posted by mtylr0810 View Post
GUYS! A BREAKTHROUGH!

The problem isn't 100% fixed but I'm going to put this here in case it helps anyone.

I had noticed that if I turned the key to the on position, but didn't start the car, I could wait to see if the security light came on. No light = no problem starting, but if the light flashed, I knew not to even bother starting the engine because it wasn't going to work. So...

I was messing around and noticed if I pushed the key into the ignition really hard while I was turning it, the whole ignition cylinder would push in a couple centimeters. No security light. Doing this allowed me to start the car no problem!

Obviously the problem isn't really fixed, but I least I have a workaround to be able to use my car while I try to fix it. Still shows code P0513.

I can get a new ignition for relatively cheap. Does anyone have thoughts as to whether or not that's where the issue is? I plan on taking it to a mechanic with a drbiii this weekend, but any extra input is totally welcome.
Based on what you've said, it sounds like the plastic shaft on the lock cylinder is not fully going into the ignition switch. So the ignition switch is not turning far enough during start up. It could also be the ignition switch itself. And by the pushing in, it allow the ignition switch to turn just a little further.

If me, I'd remove the steering column cover and see if I can tell what's going on when you press in on the lock cylinder. It's a pretty simple setup once you see it.
__________________
Reply With Quote
  #10 (permalink)  
Old 28 Sep 2016, 11:57 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,298
Default Re: PCM/SKIM issues

If the lock cylinder came loose enough causing the rod going to the ignition actuator to fall somewhat short there might be some damage to the ignition actuator. Check the ignition actuator.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PCM and skim for sale DODGETHIS Classifieds: For Sale/Trade 9 08 Feb 2015 01:47 pm
Help needed: 2007 PT Won't Start: Alarm / RKE Module - SKIM Key Issues bluebossa Tech & Performance Forum 6 05 Oct 2013 11:55 am
Skim key stu88 Tech & Performance Forum 15 17 Aug 2013 04:01 am
SKIM Woes wirelessdog Sound and Security Forum 4 14 Jul 2012 08:54 pm
SKIM 99PlyNeon General PT Cruiser Discussions 0 30 Jul 2011 08:01 pm


All times are GMT -5. The time now is 10:28 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors