PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
PT cruiser engine ticking at 1000 to 1500 rpm

 
Like Tree12Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Nov 2016, 04:49 pm
Regular Cruiser
 
Join Date: Sep 2016
Posts: 166
Default PT cruiser engine ticking at 1000 to 1500 rpm

My PT cruiser has started to tick when I drive at 1000-1500 rpm, it stops right after that, please help me find the cause as I am scared I will cause damage to my engine
Reply With Quote
  #2 (permalink)  
Old 23 Nov 2016, 05:29 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: PT cruiser engine ticking at 1000 to 1500 rpm

Quote:
Originally Posted by kcabe1 View Post
My PT cruiser has started to tick when I drive at 1000-1500 rpm, it stops right after that, please help me find the cause as I am scared I will cause damage to my engine
we are gonna need some info
year
miles
what has been done
when was last oil change
what kind of oil and filter
it is really loude or just sorta loud
Reply With Quote
  #3 (permalink)  
Old 23 Nov 2016, 05:58 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,759
Default Re: PT cruiser engine ticking at 1000 to 1500 rpm

Re: PT cruiser engine ticking at 1000 to 1500 rpm



"BOMB" ruuuuun!!!!!!!!


__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #4 (permalink)  
Old 23 Nov 2016, 09:26 pm
Young Cruiser
 
Join Date: Sep 2016
Location: Southern Oregon
Posts: 83
Default Re: PT cruiser engine ticking at 1000 to 1500 rpm

Quote:
Originally Posted by NitroPT View Post
Re: PT cruiser engine ticking at 1000 to 1500 rpm



"BOMB" ruuuuun!!!!!!!!


Well, that made me laugh pretty good.
JimBippy likes this.
Reply With Quote
  #5 (permalink)  
Old 26 Nov 2016, 11:54 am
Regular Cruiser
 
Join Date: Sep 2016
Posts: 166
Default Re: PT cruiser engine ticking at 1000 to 1500 rpm

2001, 96,900 miles, new engine 5,000 miles ago, about to get an oil change, oil pressure light comes on when slowing down sometimes, ticking sounds like it's coming from the top end, I opened the valve covers, no damage or wear visibly
Reply With Quote
  #6 (permalink)  
Old 26 Nov 2016, 12:11 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,759
Default Re: PT cruiser engine ticking at 1000 to 1500 rpm

Quote:
Originally Posted by kcabe1 View Post
2001, 96,900 miles, new engine 5,000 miles ago, about to get an oil change, oil pressure light comes on when slowing down sometimes, ticking sounds like it's coming from the top end, I opened the valve covers, no damage or wear visibly
You say "NEW" engine? At 5k miles it should still be under a warranty?
The oil sender may need to be checked?

You can also send a sample of the engine oil in to see if you are getting metals which can indicated parts damage and perhaps which part.

Blackstone Labs

I would suggest to use an audio diagnostic tool or make a simple one with a hose screw and Philips driver to better locate exactly where the noise you are concerned is coming from.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #7 (permalink)  
Old 26 Nov 2016, 02:28 pm
Regular Cruiser
 
Join Date: Sep 2016
Posts: 166
Default Re: PT cruiser engine ticking at 1000 to 1500 rpm

Thank you! I'm about to take it for an oil change and see what happens, because i tried to do it myself and that's when the ticking started I think, but the oil light has been coming on intermittently so maybe the pressure is low?
Reply With Quote
  #8 (permalink)  
Old 26 Nov 2016, 02:44 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,759
Default Re: PT cruiser engine ticking at 1000 to 1500 rpm

Quote:
Originally Posted by kcabe1 View Post
.......the oil light has been coming on intermittently ......
I try not guess at problems members have on forums but the oil sensor has been reported to fail in the example of intermittently posting the light. I have replaced a couple oil sensors on mine and others PT's that I tested to be faulty. There are also other members that have had the same observance about the oil light and followed by replacing it to resolve the problem.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #9 (permalink)  
Old 26 Nov 2016, 03:30 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,369
Default Re: PT cruiser engine ticking at 1000 to 1500 rpm

Quote:
Originally Posted by kcabe1 View Post
Thank you! I'm about to take it for an oil change and see what happens, because i tried to do it myself and that's when the ticking started I think, but the oil light has been coming on intermittently so maybe the pressure is low?
The oil change is likely a good first step.

You symptoms sound a lot like low oil pressure. While under load at low RPM's, the oil pressure may be becoming too low and one or more lifter may be collapsing and cause chatter. This chatter may improve or go away with a simple change to a quality correct weight oil. And even if it doesn't, you've then eliminated that potential cause.

If it doesn't clear up with the oil change, please post again and we can go further down this road. First we will need to assure it's valve chatter that you are hearing. And if so, we can give you some options to check true oil pressure yourself.
__________________
Reply With Quote
  #10 (permalink)  
Old 26 Nov 2016, 03:50 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,759
Default Re: PT cruiser engine ticking at 1000 to 1500 rpm

haha!
This response is more for SPLNeon

I purposely run 2 quarts low of oil when I run my Cruiser at the track. I never do and it is not likely you will not get any upper end noise and you may find the ET low a tenth or 2.
The oil pump design on the 2.4 is ridiculously over engineered and can and does supply more than enough oil volume and pressure to the top end. Also if you look a lubrication chart the top end completely gets oil to all parts before returning to the sump and can be supplied oil for most normal driving conditions even if the oil pressure was lower than specification.


oil choice:
The choice of motor oil and what viscosity has more to how the engine is run and under what temperatures. I would only recommend at least to choose a detergent oil. Single viscosity motor oil as an example only Valvoline SAE 30 (no W=winter) can be used with no problems as long as you consider the ambient operating temperatures when choosing motor oil.
chuzz likes this.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN

Last edited by NitroPT; 26 Nov 2016 at 03:54 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
04 PT Cruiser engine ticking / tapping at idle Bandit2014 Tech & Performance Forum 0 22 Feb 2016 04:48 pm
2007 PT Cruiser, Good Car with Bad Engine, 78k miles, $1000 themightyquinn Classifieds: For Sale/Trade 1 03 Apr 2015 06:01 am
Engine ticking Evile Tech & Performance Forum 10 27 Sep 2012 09:45 pm
engine will not rev above 1500 in park bbccdc Tech & Performance Forum 5 23 Mar 2012 10:47 am
Cruiser engine makes ticking sound Markwin Tech & Performance Forum 11 06 Mar 2010 12:15 pm


All times are GMT -5. The time now is 03:05 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors