PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
'05 2.4 "B" VIN Connecting Rod Bolts

 
Like Tree1Likes
  • 1 Post By rob302

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Dec 2016, 12:16 am
Fresh Cruiser
 
Join Date: Oct 2013
Location: Slightly past nowhere, Texas
Posts: 34
Default '05 2.4 "B" VIN Connecting Rod Bolts

Can anyone here confirm the nature of the conn rod bolts in this series engine?

I'm noticing a light knock starting right around 3000rpm on a 105K engine; I expect I'll be needing to replace some rod bearings.

Only issue is it seems nobody stocks the rod bolts. Not NAPA, not RockAuto; even my local dealership has to order with some lag time. Even the master overhaul kits for this engine only include head bolts.

Thing is; even though the manual I have says not to reuse, I've built more than a few engines... and 20 ft/lbs + 90 sounds more like TTA, not TTY. I'm thinking my manual may be for later years, and not approriate.

So can anybody here confirm whether these bolts are in fact supposed to be TTY? Or are they just playing the "Thou shalt cover thine own arse" game with this particular requirement?


Cheers,

mnem

Last edited by mnementh; 14 Dec 2016 at 12:24 am.
Reply With Quote
  #2 (permalink)  
Old 14 Dec 2016, 11:13 am
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,504
Default Re: '05 2.4 "B" VIN Connecting Rod Bolts

you should get 3x that mileage out of that shortblock. if it was so neglected and abused that it already needs rod bearings, it likely needs a lot more than just rod bearings. i would expect the noise might not be what you expect.

alldata also lists 20 ft/lbs + 1/4turn and says not to reuse the bolts...for your year and vin
Handy_Cruiser likes this.

Last edited by rob302; 14 Dec 2016 at 11:18 am.
Reply With Quote
  #3 (permalink)  
Old 14 Dec 2016, 02:25 pm
SPLNeon's Avatar
Fanatic Cruiser
 
Join Date: Sep 2014
Location: Canada
Posts: 711
Default Re: '05 2.4 "B" VIN Connecting Rod Bolts

Fwiw, you can use ARP rod bolts for ls1 bowtie with cracked cap. Research it for the part numbers
__________________
THE UNDISPUTED KING OF THE PARKING LOT

Competition's paying the price.

03 PT GT. DSI canned tune, Weight redux, MH Racemaster Slicks/Rota Slipstream 15" 11.95 at 118.41mph 1/4 mile
96 SOHC Neon Turbo
08 CSRT4. Realtune MS1K v1 pcm stg0 NSRT4 Injectors.
Reply With Quote
  #4 (permalink)  
Old 15 Dec 2016, 03:45 pm
Fresh Cruiser
 
Join Date: Oct 2013
Location: Slightly past nowhere, Texas
Posts: 34
Default Re: '05 2.4 "B" VIN Connecting Rod Bolts

Thanks for the feedback guys... I guess we'll see what I find when I get it apart. I'm still highly skeptical. A lot of "service manuals" confuse TTA with TTY.

Vehicle has not been abused since I've owned it; full-synthethic 5W-30 every 4K since ~60K and I just put it in drive and let it go. Prior owners were definitely not kind to Franken-Cruiser, however; it was an insurance total-out with both front and rear-end damage. I'm still finding stuff they bashed up and never fixed on the poor thing.

Right now I'm mostly back-burnering the noise issue as I continue to troubleshoot a severe poor performance issue; I'm pretty sure it's a failed cat as it just set a hard 0402 code and O sensors are only a couple years old. Will see once I have it up in the air; get my stethoscope after the noise and IR thermometer after the cat.


Cheers and Merry Christmas to all!
Reply With Quote
  #5 (permalink)  
Old 24 Dec 2016, 02:31 pm
Fresh Cruiser
 
Join Date: Oct 2013
Location: Slightly past nowhere, Texas
Posts: 34
Default Re: '05 2.4 "B" VIN Connecting Rod Bolts

Brown Santa delivered my new Cat yesterday; after much wriggling and grinding and MIG work, got it installed and only scraped off two knuckles in the process.

Still waiting on new 0 sensors; hopefully Monday or Tuesday. In the meantime I think I'm gonna go fly a quadcopter or three.


mnem
Merry Christmas to all!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Whining Noise, Damp Bolts by Radiator and A/C Valve and Unknown "Drainage" hole? DauntlessDS Tech & Performance Forum 3 26 Aug 2016 06:53 pm
Whining Noise, Damp Bolts by Radiator and A/C Valve and Unknown "Drainage" hole? DauntlessDS Tech & Performance Forum 0 23 Aug 2016 05:49 pm
The "Handy" NOPI Strut Bar Install: Part "Deux" (2) Handy_Cruiser Tech & Performance Forum 2 01 Aug 2015 10:37 pm
Turbo "phhsssss" or "whoosh" sound--Normal? Silenceable? Help! Memark General Turbo Discussions 13 24 Nov 2010 10:56 pm


All times are GMT -5. The time now is 04:15 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors