PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

need help

 
Like Tree1Likes
  • 1 Post By busababy

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 25 Dec 2016, 12:44 am
Fresh Cruiser
 
Join Date: Dec 2016
Location: Orange Park, Florida
Posts: 1
Cool need help

My PT cruiser just started stalling out at stops. Had it towed. Now I have a new fuel pump, new alternator and new battery. Now the car will drive 10-12 miles, stall out but restart after 20-30 minutes. When it stalls out and off the temp gauge goes to the HOT spot but while it is driving the temp gauge stays at the half mark. What in tarnation is wrong with my PT????? Please help and tell me it's something with less $$$$ attached. Thank you.
Handy_Cruiser likes this.
Reply With Quote
  #2 (permalink)  
Old 25 Dec 2016, 12:55 am
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 6,404
Default Re: It

Welcome to the forum.

We will need to know the year model, edition and mileage of your PT. Also, does the check engine light come on and do you have any trouble codes?
__________________
Reply With Quote
  #3 (permalink)  
Old 25 Dec 2016, 01:37 am
rckstein's Avatar
Obsessed Cruiser
 
Join Date: Dec 2010
Location: Euless, TX
Posts: 6,404
Default Re: It

Welcome to the forum
__________________

'06 Touring Edition NA Automatic
139K Miles / Electric Blue Pearl
USMC '83 - '93
Reply With Quote
  #4 (permalink)  
Old 25 Dec 2016, 07:17 am
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 3,481
Default Re: It

Quote:
Originally Posted by busababy View Post
My PT cruiser just started stalling out at stops. Had it towed. Now I have a new fuel pump, new alternator and new battery. Now the car will drive 10-12 miles, stall out but restart after 20-30 minutes. When it stalls out and off the temp gauge goes to the HOT spot but while it is driving the temp gauge stays at the half mark. What in tarnation is wrong with my PT????? Please help and tell me it's something with less $$$$ attached. Thank you.

Have someone check that both fans speeds are working.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Nexus 5X, Nexus 4, Nexus 7 (2013)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:05 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors