PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Oil light again...

 
Like Tree7Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Dec 2016, 10:02 am
Young Cruiser
 
Join Date: Jul 2014
Location: Clayton, NC
Posts: 73
Question Oil light again...

Hello all,

I have an 07 base model and as some of you may remember, I had my oil light come on a month ago during Thanksgiving weekend. I ended up having AAA tow it to my regular mechanic who has been working on the family cars for years now. They ended up changing the oil but it didn't the problem and then they changed the oil sending unit. That ended up fixing the problem... until last night when the light came back on and the car has oil. Could it be the sending unit going bad again or could it possibly be something else?
__________________

2007 Base model in Cool Vanilla 145,000+ miles
My mods: LED headlights and a K&N Intake
Reply With Quote
  #2 (permalink)  
Old 26 Dec 2016, 11:12 am
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,519
Default Re: Oil light again...

i would blame the sending unit or the connector/wire attached to it. i'd call the people that fixed it. you've been using them for service for years and i would doubt they'll give you any trouble about it.

Reply With Quote
  #3 (permalink)  
Old 26 Dec 2016, 11:32 am
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: Oil light again...

Can you find out what brand of sending unit your mechanic installed?
Reply With Quote
  #4 (permalink)  
Old 26 Dec 2016, 12:01 pm
Cool Cruiser
 
Join Date: Oct 2016
Location: Amboy, Indiana
Posts: 226
Wink Re: Oil light again...

Quote:
Originally Posted by smittey5656 View Post
Hello all,
Could it be the sending unit going bad again or could it possibly be something else?
I think you should get an actual oil pressure gauge reading by connecting directly to the engine either done by yourself or your mechanic. Considering your mileage that's the route I would go just for peace of mind knowing the actual oil psi, particularly at engine idle. Then compare that reading to specification.
Reply With Quote
  #5 (permalink)  
Old 26 Dec 2016, 12:11 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,757
Default Re: Oil light again...

This is common (Re:" Oil light again"...)when the oil sensor is replaced and the connectors are not thoroughly cleaned on a PT Cruiser. You may simply need to remove it clean it and reinstall it. Brand has absolutely NOTHING to do with it!! As it has already been mentioned to be working for several hundred miles. Keep in mind that it is easy to damge a any sendor or sensor during installation which may not be apparent for many months or miles.

Also check for engine codes using a scanning tool at the diagnostic connector. Note and than clear them recheck after a day or so. If you are having a shop check them than drive for about a 1/2 and return to the shop for a recheck.
I have been through this with a few(many) members on this forum. I would not spend the money on another one until you first do that.

It is not necessary to check the oil pressure manually on a Chrysler 2.4. When the pump fails you will know it. Tic, tic, tic, ticing away on the top end components. The oil pump is very well designed and seldom fails or for that matter wears out.

The oil goes from the pump directly to the top end (head) valve train components first and than to the lower engine reciprocating assembly.

The real exception (within reason)to this would be if you recently damaged your sump.....
or of routinely driven 10's of thousands of miles between oil changes.
VsandFords, chuzz and Carnut like this.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN

Last edited by NitroPT; 26 Dec 2016 at 12:16 pm.
Reply With Quote
  #6 (permalink)  
Old 26 Dec 2016, 12:23 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,346
Default Re: Oil light again...

My oil light would come on and I found If I turned the key to on then off then started the car it would act normal. No light.

Only in America.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #7 (permalink)  
Old 26 Dec 2016, 12:55 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,757
Default Re: Oil light again...

Quote:
Originally Posted by JoeX View Post
My oil light would come on and I found If I turned the key to on then off then started the car it would act normal. No light.

Only in America.
This report ^^^^ is also not uncommon...
That is a indication of a dirty connector and/or a sensor damaged or beginning to fail.

In the extreme or at least to note the health and connect-ability of the PCM.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN

Last edited by NitroPT; 26 Dec 2016 at 12:57 pm.
Reply With Quote
  #8 (permalink)  
Old 26 Dec 2016, 01:27 pm
Young Cruiser
 
Join Date: Jul 2014
Location: Clayton, NC
Posts: 73
Default Re: Oil light again...

Thank you everyone so far on your input, I will call them tomorrow once they reopen after the holiday to give them the suggestions so far. I appreciate all the information Everyone is willing to give!!
__________________

2007 Base model in Cool Vanilla 145,000+ miles
My mods: LED headlights and a K&N Intake
Reply With Quote
  #9 (permalink)  
Old 27 Dec 2016, 04:04 pm
Young Cruiser
 
Join Date: Jul 2014
Location: Clayton, NC
Posts: 73
Default Re: Oil light again...

Just got off the phone with the Shop and they found that the part was defective and ordered a genuine chrysler to replace it. They also found that my radiator cap was leaking so they replaced that as well and I will be getting it back tomorrow.
__________________

2007 Base model in Cool Vanilla 145,000+ miles
My mods: LED headlights and a K&N Intake
Reply With Quote
  #10 (permalink)  
Old 27 Dec 2016, 04:51 pm
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: Oil light again...

Quote:
Originally Posted by smittey5656 View Post
Just got off the phone with the Shop and they found that the part was defective and ordered a genuine chrysler to replace it. They also found that my radiator cap was leaking so they replaced that as well and I will be getting it back tomorrow.
Just curious, did they tell you what brand of sending unit they installed the first time?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS Light, Parking Brake Light, Traction Control Light kupothechocobo General PT Cruiser Discussions 9 28 Feb 2017 01:56 pm
Left Side Break Light / Blinker / Reverse Light MaxJoseph Tech & Performance Forum 6 07 Nov 2015 05:18 pm
Showing ABS light, Brake light, Traction light on Dash fox50h Tech & Performance Forum 19 18 Feb 2014 11:40 pm
Check engine light: Amber Light: power loss dbleclk Turbo Performance 2 06 Jul 2011 06:12 am
Mork's Tail Light and Reverse Light Tint Progress Morkeste Exterior Accessories Forum 30 23 Jun 2011 12:20 pm


All times are GMT -5. The time now is 03:10 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors