PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
P1604 and P0622

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Feb 2017, 09:53 pm
Fresh Cruiser
 
Join Date: Apr 2014
Location: Midlothian, TX
Posts: 31
Default P1604 and P0622

Help! I was driving my wife's '03 Cruiser (2.4L non-turbo) home from work today. I stopped in a store, came back out, when i tried to start it, it turned over but didn't start. Tried again, same thing. Tried a third time, same thing and a pop (backfire?). Fourth time it started; check engine light came on. Throwing codes P1604 and P0622.

Not sure if related, but I know that over the past few weeks, when I've used the car's alarm to find it in the parking lot, the chirps have been getting fainter and fainter.

finally, I'm seeing the check oil light come on at idle (sometimes); it goes away when I give it some gas (whether in Drive or neutral).

Any thoughts? Are these related to one another?
Reply With Quote
  #2 (permalink)  
Old 04 Feb 2017, 11:05 am
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,519
Default Re: P1604 and P0622

i would have the battery tested, clean and inspect the cables, and see if the wiring is oily at the computer. sometimes the oil pressure switch can leak and force oil through the sensor connector, into the wiring harness, and up near the computer, which could cause poor connections and a weird issue like you describe.

just a(n educated) guess.... since for some reason you have 30 views and no replies
Reply With Quote
  #3 (permalink)  
Old 04 Feb 2017, 01:30 pm
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,814
Default Re: P1604 and P0622

I agree with Rob about the battery. And I'd also have the alternator checked. If you go to Autozone or O'Reilly, they'll do a complete charging system test for you in the car. No need to remove parts. And that damned oil pressure switch leak up the wire is not that common, but just common enough that the suggestion to check it is a damn good one.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #4 (permalink)  
Old 05 Feb 2017, 12:20 am
Fresh Cruiser
 
Join Date: Apr 2014
Location: Midlothian, TX
Posts: 31
Default Re: P1604 and P0622

Thanks, guys. I'll check it out tomorrow and report back.
Reply With Quote
  #5 (permalink)  
Old 05 Feb 2017, 05:45 pm
Fresh Cruiser
 
Join Date: Apr 2014
Location: Midlothian, TX
Posts: 31
Default Re: P1604 and P0622

Okay - battery cables have some corrosion, which is surprising since they were replace about a year ago. All lines into the PCM are clean and free of oil. Going to jump start it and head to autozone.
Attached Images
File Type: jpg IMG_2505.jpg (92.3 KB, 12 views)
File Type: jpg IMG_2506.jpg (89.5 KB, 7 views)
File Type: jpg IMG_2507.jpg (89.9 KB, 7 views)
Reply With Quote
  #6 (permalink)  
Old 05 Feb 2017, 08:15 pm
Odin's Avatar
Fresh Cruiser
 
Join Date: Jan 2017
Posts: 36
Default Re: P1604 and P0622

The oil light going on and off definitely sounds like the the oil pressure sensor. Mine did the same thing. Under acceleration the light goes off, but went on when coasting or braking.
Reply With Quote
  #7 (permalink)  
Old 05 Feb 2017, 10:52 pm
Fresh Cruiser
 
Join Date: Apr 2014
Location: Midlothian, TX
Posts: 31
Default Re: P1604 and P0622

Okay; Autozone says bad battery, good alternator. We will replace battery tomorrow.
Reply With Quote
  #8 (permalink)  
Old 05 Feb 2017, 10:53 pm
Fresh Cruiser
 
Join Date: Apr 2014
Location: Midlothian, TX
Posts: 31
Default Re: P1604 and P0622

Quote:
Originally Posted by Odin View Post
The oil light going on and off definitely sounds like the the oil pressure sensor. Mine did the same thing. Under acceleration the light goes off, but went on when coasting or braking.
Odin, where is that sensor? I've noticed a minor oil leak; wonder if that is related.
Reply With Quote
  #9 (permalink)  
Old 05 Feb 2017, 11:36 pm
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,519
Default Re: P1604 and P0622

It's in the back of the engine. Here's a picture HOW TO: oil pressure sensor replacement
Fk5 likes this.
Reply With Quote
  #10 (permalink)  
Old 05 Feb 2017, 11:44 pm
Odin's Avatar
Fresh Cruiser
 
Join Date: Jan 2017
Posts: 36
Default Re: P1604 and P0622

It's on the back of the engine, about half way up and a little to the driver side. You can really only see it from underneath. Look for a yellow connector. Here is a video that helped me when I did it. Also, a 3 inch extension for the 1/2 inch ratchet made removing and replacing the sensor a ton easier.

https://youtu.be/XaoeZDmTjvc

This topic has a good diagram as well.
Oil Pressure Light?
Fk5 likes this.

Last edited by Odin; 05 Feb 2017 at 11:52 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New alternator not charging, how to check ECM? P0622 imalittleturt Tech & Performance Forum 20 19 May 2018 12:41 pm
Codes P0480, P0622 - seems erratic Jester1 Turbo Performance 10 26 Aug 2017 12:03 pm
P0622 Code and Battery light on!! Mike0x4u General Turbo Discussions 24 11 Jan 2017 09:21 pm


All times are GMT -5. The time now is 09:27 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors