PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Dancing Speedo & Lumpy Engine

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Aug 2017, 06:38 pm
Fresh Cruiser
 
Join Date: Aug 2016
Posts: 4
Default Dancing Speedo & Lumpy Engine

Hi Guys,
Got a bit of an issue going on with my 2.2 CRD and have no idea where to start in regards to resolving it. About a week ago the speedo began behaving erratically, suddenly dropping down to zero when i came off the revs to change gear and then shooting up to the correct road speed when bringing the revs back on. The car has also begun to kangaroo slightly whilst not under acceleration but this is mild at the moment and has not got any worse in the last week. I have scanned for fault codes with the OBD2 and it reports no faults, but, doing the ignition code check it throws up a P0833. Google says clutch pedal position switch B but looking through the codes on the forum sticky post P0833 does not exist. Any help would be greatly appreciated as i don't want to start second guessing the issue and start changing switches and /or sensors that might otherwise be OK.
Thanking you in advance, all the best... Mark.
Reply With Quote
  #2 (permalink)  
Old 22 Aug 2017, 01:06 pm
Regular Cruiser
 
Join Date: Jan 2005
Location: .
Posts: 149
Default Re: Dancing Speedo & Lumpy Engine

My GT has an intermittent speedo. Mine drops out typically if I idle too long while the engine is cold. However, it will also do it at highway speeds and then come back 10 minutes later. I will often get several misfires when the speedo isn't working and the MIL will come on. I was ignoring it for the last two months because my car throws lots of BS codes. I still suspect an electrical issue (e.g. bad ground connection) but I'm not sure where. What is weird is that the odometer still works without the speedo.
__________________
\'03 GT - No mods
\'05 Convertible Touring Ed. - No mods
Reply With Quote
  #3 (permalink)  
Old 22 Aug 2017, 04:53 pm
Fresh Cruiser
 
Join Date: Aug 2016
Posts: 4
Default Re: Dancing Speedo & Lumpy Engine

Yeah, my rev counter has no issues and works normally throughout... It leads me to think that its either a rouge sensor or something in the computer that is going poot... Hoping that someone in here will have had the same issue to assist in diagnosing it... Also, odd that the car has thrown up the P0833 code but the OBD2 sees nothing...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lumpy Idle colint General PT Cruiser Discussions 8 30 May 2017 07:06 pm
Transmission slammed in 1st gear, spedo dancing, engine cutting out. jetmax General PT Cruiser Discussions 15 22 Feb 2015 12:09 pm
HELP! Gauges dancing & will not crank! It's possessed! Joytheboytoy Tech & Performance Forum 11 21 Sep 2013 07:43 pm
RED LIGHT IN SPEEDO?? drumrooster Tech & Performance Forum 1 20 Jul 2011 08:17 am
Speedo & Tach jumping when engine is turned off. ShayP Tech & Performance Forum 1 20 Jun 2011 12:46 pm


All times are GMT -5. The time now is 08:03 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors