PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Codes P0573 & P0501 help

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 Oct 2017, 09:38 am
Young Cruiser
 
Join Date: Mar 2016
Location: Tampa FL
Posts: 51
Default Codes P0573 & P0501 help

05 PT GT 5Spd

Getting the P0573 brake switch A circuit high

Brake lights work correctly. Brand new battery,
I've disconnected the battery to let the ecm reset multiple times, cleared the codes with my reader a few times.
Still comes back, so obviously I have to figure this out.
Not much help on Google.
Sometimes, the CEL doesn't come on for a few minutes
And sometimes, the TRAC/ABS lights come on (but not very often)
I'm also always getting an accompanying P0501 vehicle speed sensor code, but that's because my Speedo sensor is on its way out. Only works when you are on the gas. Otherwise it falls to 0 or twitches. Already did the gauges test. Gauges are good.

What am I looking for?
Please get technical
Reply With Quote
  #2 (permalink)  
Old 20 Oct 2017, 10:15 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,338
Default Re: Codes P0573 & P0501 help

Quote:
Originally Posted by bricks4584 View Post
05 PT GT 5Spd

Getting the P0573 brake switch A circuit high

Brake lights work correctly. Brand new battery,
I've disconnected the battery to let the ecm reset multiple times, cleared the codes with my reader a few times.
Still comes back, so obviously I have to figure this out.
Not much help on Google.
Sometimes, the CEL doesn't come on for a few minutes
And sometimes, the TRAC/ABS lights come on (but not very often)
I'm also always getting an accompanying P0501 vehicle speed sensor code, but that's because my Speedo sensor is on its way out. Only works when you are on the gas. Otherwise it falls to 0 or twitches. Already did the gauges test. Gauges are good.

What am I looking for?
Please get technical
I would suggest that your P0573 code could be triggered due to the vehicle speed code being triggered. The PCM looks at the speed and triggers the P0573 if it is out of range. Recommend you fix the cause of P0501 first.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Please P0501, FL0007, EE13, BLO1 BlackPhantomZ28 Tech & Performance Forum 5 14 Nov 2015 10:16 pm
manual trans. code p0501 - speedometer not working shelbyzman Tech & Performance Forum 3 02 Jan 2014 04:26 pm
Dash codes--not the usual OBD codes--help! chitowncruiser General PT Cruiser Discussions 5 01 Mar 2013 11:56 pm
Codes, codes, codes... Desperately need engine light help... cdc3jj General PT Cruiser Discussions 9 01 Sep 2012 07:52 am
CODES codes codes... Anyone know what these codes may mean are wrong? rksnow1 Tech & Performance Forum 10 16 Jun 2012 11:06 pm


All times are GMT -5. The time now is 05:26 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors