PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Cooling fan

 
Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Oct 2017, 11:50 am
oldthom's Avatar
Regular Cruiser
 
Join Date: Aug 2017
Location: Lockhart, Texas
Posts: 126
Default Cooling fan

My old cooling fan had low speed only so I bought a new fan off eBay and changed it out. The new fan works with high and low speeds but drags the engine down to a rough idle no matter what speed it is running. MY OLD FAN DID NOT DO THIS. I disconnected the battery and cleaned out the IAC and throttle body, checked everything in the way of a possible vacuum leak and it still does this. With the old fan the idle stayed smooth just no high speed. I am ready to try another fan unit. Can anyone recommend a quality cooling fan? Is Dorman the brand I want? Or is there a better one on the market? I replaced the IAC motor with a new OEM from Chrysler and it didn't help. What fan have you used??
__________________
2004 LE "Dolly" 61K miles
Reply With Quote
  #2 (permalink)  
Old 28 Oct 2017, 12:45 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,332
Default Re: Cooling fan

Does the engine run rough with and without the A/C on with the engine cold?
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 28 Oct 2017 at 12:47 pm.
Reply With Quote
  #3 (permalink)  
Old 28 Oct 2017, 02:18 pm
oldthom's Avatar
Regular Cruiser
 
Join Date: Aug 2017
Location: Lockhart, Texas
Posts: 126
Default Re: Cooling fan

Just with the AC on. Otherwise it runs smooth
__________________
2004 LE "Dolly" 61K miles
Reply With Quote
  #4 (permalink)  
Old 28 Oct 2017, 02:43 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,332
Default Re: Cooling fan

Are you getting a diagnostic code P0481?

Have you had any problems with the A/C before replacing the radiator fan?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #5 (permalink)  
Old 28 Oct 2017, 02:47 pm
oldthom's Avatar
Regular Cruiser
 
Join Date: Aug 2017
Location: Lockhart, Texas
Posts: 126
Default Re: Cooling fan

Steve; I ran it without the fan and the AC on. It ran fine. I'm thinking I got a fan that has a brush problem or short that causes it to draw to much power. I choose to replace the fan with a better brand. I now realize I should not have asked folks to recommend a brand name, it's kind of putting them on the spot. I'll choose one and go with it. Thanks.
__________________
2004 LE "Dolly" 61K miles
Reply With Quote
  #6 (permalink)  
Old 28 Oct 2017, 02:49 pm
oldthom's Avatar
Regular Cruiser
 
Join Date: Aug 2017
Location: Lockhart, Texas
Posts: 126
Default Re: Cooling fan

Just seen your last reply. No, no problems at all. No codes as of this morning, I checked with a scanner.
__________________
2004 LE "Dolly" 61K miles
Reply With Quote
  #7 (permalink)  
Old 28 Oct 2017, 09:13 pm
Fresh Cruiser
 
Join Date: Oct 2017
Posts: 3
Question Re: Cooling fan

Would like to find some one that can tell me what the TIPM module does for the grounding of the high speed fan wire and activate the fan n relay.
I have trouble shot all the way back to the dark blue / w pink tracer wire to the termination enters the TIPM module. I can ground the wire at this point and the fan works just as it should.
There is a code P0481. I am not sure what to look at or for next. Any and all advice is greatly appreciated.
Reply With Quote
  #8 (permalink)  
Old 28 Oct 2017, 09:20 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,332
Default Re: Cooling fan

Quote:
Originally Posted by Sweep View Post
Would like to find some one that can tell me what the TIPM module does for the grounding of the high speed fan wire and activate the fan n relay.
I have trouble shot all the way back to the dark blue / w pink tracer wire to the termination enters the TIPM module. I can ground the wire at this point and the fan works just as it should.
There is a code P0481. I am not sure what to look at or for next. Any and all advice is greatly appreciated.
Welcome to the forum.

Please start a new thread on your issue. In the meantime go to the welcome thread and introduce yourself.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #9 (permalink)  
Old 28 Oct 2017, 09:26 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,332
Default Re: Cooling fan

Quote:
Originally Posted by oldthom View Post
Steve; I ran it without the fan and the AC on. It ran fine. I'm thinking I got a fan that has a brush problem or short that causes it to draw to much power. I choose to replace the fan with a better brand. I now realize I should not have asked folks to recommend a brand name, it's kind of putting them on the spot. I'll choose one and go with it. Thanks.
I usually buy Dorman radiator fan at Rockauto,com.
oldthom likes this.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 28 Oct 2017 at 09:30 pm.
Reply With Quote
  #10 (permalink)  
Old 29 Oct 2017, 01:43 am
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,347
Default Re: Cooling fan

IF your fan was pulling more than the designed AMPs the wiring to the fan would most likely
get warm or hot and start showing signs of heat like burning .
The ground is constant to the fan, check you left fender grounds , if they are oxidized redo
the grounds, I cut the grounds back about an inch and soldered the grounds to new eyelets.
Check battery cables for corrosion.

Sorry not good at typing at 3 in the morning
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh

Last edited by JoeX; 29 Oct 2017 at 12:50 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cooling fan! jcamp General Turbo Discussions 13 18 Jul 2016 08:58 am
cooling fan wlwhockey101 General PT Cruiser Discussions 2 02 Mar 2016 11:00 am
Installed and new cooling fan and cooling temp sensor & still the fan doesn't kick in rdvarona Southeast PT Forum 18 31 May 2013 09:14 pm
AC cooling fan-what now Cajunsim Tech & Performance Forum 3 24 May 2013 11:34 am
Cooling Fan StealthyK Tech & Performance Forum 2 12 Apr 2011 02:16 am


All times are GMT -5. The time now is 06:30 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors