PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Engine cuts out !!

 
Like Tree6Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 31 Oct 2017, 04:28 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,231
Default Re: Engine cuts out !!

Quote:
Originally Posted by hotrodbobby View Post
Hi Steve.......just posted my info so unsure how many people get to see it ? Im ok on a pc but never been on forums and threads etc.....never get time haha. To be honest I panicked a bit and unsure if all the lights went off as I was more concerned in getting the car off the roundabout.
Its 2007
Manual.
Appreciate you getting back to me.......Im in the Uk so time difference will dictate our reply's I suppose. Been checking out as much as I can on youtube etc and my brain has gone into overload hahaa The Cam Sensor keeps coming up, so I will try and get the error codes from the car asap..thanks.....Bob
Have you had a chance to check the wiring going to the Camshaft sensor and the connector at the Camshaft Sensor?

Look forward to the diagnostic trouble codes.
hotrodbobby likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #12 (permalink)  
Old 01 Nov 2017, 02:08 pm
Regular Cruiser
 
Join Date: May 2016
Location: GA
Posts: 165
Default Re: Engine cuts out !!

I'd also give the battery and terminals a good look. The lights and guages cutting off and on might be due to corroded battery terminals, bad battery or something wrong in the charging system. Can you still start the car?
hotrodbobby likes this.
__________________
08 PT Cruiser Limited - 82K (Original Owner)
14 Ram 1500 -Big Horn

Semper Fi (USMC 96-01)

"Insanity: Doing the same thing over and over again and expecting different results." -Einstein
Reply With Quote
  #13 (permalink)  
Old 01 Nov 2017, 02:11 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,231
Default Re: Engine cuts out !!

Quote:
Originally Posted by Grasshopper77 View Post
I'd also give the battery and terminals a good look. The lights and guages cutting off and on might be due to corroded battery terminals, bad battery or something wrong in the charging system. Can you still start the car?
Be sure to check for engine trouble codes before disconnecting the battery.
Grasshopper77 likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #14 (permalink)  
Old 04 Nov 2017, 01:19 pm
Fresh Cruiser
 
Join Date: Oct 2017
Posts: 8
Default Re: Engine cuts out !!

Hi Steve ! Here we go again haha.....just found this reply...apologies ! Been reading up on everything and managed to check OBD which came back as no error codes and came up as " DONE ". So decided to go back to basics and took the battery out which sits under the passenger seat on my car. Weird how it sits on its side ? Its an Optima battery.
The earth pole was corroded but cleaned up ok and then put copious amount of Vaseline on. Put it all back together again and the car wouldn't start !!! Never rains but it pours ! Everything else would work on the car but not fire up, so took the battery over to local garage and got it checked.......reading on machine said " Replace Battery ".
Readout on machine:
Volts 11,70v.......Measured 228A En.......Rating 700A En......Battery Temp Above 0 C
Over my head I'm afraid !
So decided to try and charge it tonight and see if it will hold a charge and start.
Did notice that I could not get the OBD back up again, just to see if there was an error code. Thanks for keeping in touch guys ! Bob
Reply With Quote
  #15 (permalink)  
Old 04 Nov 2017, 01:23 pm
Fresh Cruiser
 
Join Date: Oct 2017
Posts: 8
Default Re: Engine cuts out !!

Thanks Grasshopper......think I may have answered most of the questions asked...appreciated !
Reply With Quote
  #16 (permalink)  
Old 04 Nov 2017, 02:04 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,231
Default Re: Engine cuts out !!

Quote:
Originally Posted by hotrodbobby View Post
Hi Steve ! Here we go again haha.....just found this reply...apologies ! Been reading up on everything and managed to check OBD which came back as no error codes and came up as " DONE ". So decided to go back to basics and took the battery out which sits under the passenger seat on my car. Weird how it sits on its side ? Its an Optima battery.
The earth pole was corroded but cleaned up ok and then put copious amount of Vaseline on. Put it all back together again and the car wouldn't start !!! Never rains but it pours ! Everything else would work on the car but not fire up, so took the battery over to local garage and got it checked.......reading on machine said " Replace Battery ".
Readout on machine:
Volts 11,70v.......Measured 228A En.......Rating 700A En......Battery Temp Above 0 C
Over my head I'm afraid !
So decided to try and charge it tonight and see if it will hold a charge and start.
Did notice that I could not get the OBD back up again, just to see if there was an error code. Thanks for keeping in touch guys ! Bob
I am suggesting you might have a bad cell in the battery. I would suggest replacing the battery as the battery is the most important part of the Pt Cruiser. Without a good battery it can leave you walking.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #17 (permalink)  
Old 04 Nov 2017, 03:28 pm
Sinbad's Avatar
Cool Cruiser
 
Join Date: Sep 2016
Posts: 241
Default Re: Engine cuts out !!

Quote:
Originally Posted by hotrodbobby View Post
Thanks Grasshopper......think I may have answered most of the questions asked...appreciated !
Right....

1) Don't buy a new battery yet, because you'll want to shop around, as the Gel battery in a CRD is a chinese fortune - none of them 60 quid specials for us poor CRD bastards

2) Put it back in and if you can, beg borrow or steal a second battery that you can *eventually* (not yet) set up IN PARALLEL (- to -, + to + ) with a set of jump leads onto the old battery - assuming you havent got another motor for a jump or an AC battery boost.
It's probably worth taking the passenger seat out before you start - it makes things easy - and you aint going anywhere anyway

3) Go to the front, RHS - take out the air cleaner box - jubilee clip to the fat hose out of it, then wriggle and pull upwards. Bit of jiggery pokery to get the "spouts" on the RHS and front of the air box out of their cut-outs, but it will come...

4) Down the RHS inner wing towards the front, is down the RHS of the air box (if the air box was still in) there you'll find your cars 'poota.
Make sure that:
a) it's properly bolted down (3 10mm AF if I remember) and if it's not, do it - cleaning the earths as you go
b) check that the plugs into it (on the front edge) are both sound and both connected fully and properly.

If it all looks good, put the airbox back on.

Find a) camshaft sensor and b) crankshaft sensor and check wiring.

Take the SMALL back seat out, sit in the drivers seat, turn the ignition on and *listen*.... can you hear the fuel pump whirring?
If not, check fuses connections anything applicable / obvious

If it's whirring, check you have fuel to each injector (google for how on a common rail, it's all over youtube)

To check the fuel is getting to the injectors, take off the engine cover (2 10mm AF rear) and pull straight up)

This exposes the injectors and their fuel lines and wot not - assume you have a smartphone? Take a picture and post it on here (click the paperclip up top to add an attachment)

Here's hoping you havent been stung by some sh*te and you haven't got the dreaded Merc Black Death....

We'll see... come back as soon as you can
Reply With Quote
  #18 (permalink)  
Old 04 Nov 2017, 03:43 pm
Sinbad's Avatar
Cool Cruiser
 
Join Date: Sep 2016
Posts: 241
Default Re: Engine cuts out !!

Just re-read properly (I'm a fakkir for skim reading ) - I doubt you need to check for fuel at the injectors right now, but take the cover off and post a pic anyway. It will be informative.

We have the same model / spec and year of car BTW, so that might help comparing stuff.

How many miles, and what service history did you get with it?
Reply With Quote
  #19 (permalink)  
Old 04 Nov 2017, 03:50 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,231
Default Re: Engine cuts out !!

Quote:
Originally Posted by Sinbad View Post
Right....

1) Don't buy a new battery yet, because you'll want to shop around, as the Gel battery in a CRD is a chinese fortune - none of them 60 quid specials for us poor CRD bastards

2) Put it back in and if you can, beg borrow or steal a second battery that you can *eventually* (not yet) set up IN PARALLEL (- to -, + to + ) with a set of jump leads onto the old battery - assuming you havent got another motor for a jump or an AC battery boost.
It's probably worth taking the passenger seat out before you start - it makes things easy - and you aint going anywhere anyway

3) Go to the front, RHS - take out the air cleaner box - jubilee clip to the fat hose out of it, then wriggle and pull upwards. Bit of jiggery pokery to get the "spouts" on the RHS and front of the air box out of their cut-outs, but it will come...

4) Down the RHS inner wing towards the front, is down the RHS of the air box (if the air box was still in) there you'll find your cars 'poota.
Make sure that:
a) it's properly bolted down (3 10mm AF if I remember) and if it's not, do it - cleaning the earths as you go
b) check that the plugs into it (on the front edge) are both sound and both connected fully and properly.

If it all looks good, put the airbox back on.

Find a) camshaft sensor and b) crankshaft sensor and check wiring.

Take the SMALL back seat out, sit in the drivers seat, turn the ignition on and *listen*.... can you hear the fuel pump whirring?
If not, check fuses connections anything applicable / obvious

If it's whirring, check you have fuel to each injector (google for how on a common rail, it's all over youtube)

To check the fuel is getting to the injectors, take off the engine cover (2 10mm AF rear) and pull straight up)

This exposes the injectors and their fuel lines and wot not - assume you have a smartphone? Take a picture and post it on here (click the paperclip up top to add an attachment)

Here's hoping you havent been stung by some sh*te and you haven't got the dreaded Merc Black Death....

We'll see... come back as soon as you can
Not a good idea to start diagnosing a problem with a bad battery.
Sinbad likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #20 (permalink)  
Old 04 Nov 2017, 03:57 pm
Sinbad's Avatar
Cool Cruiser
 
Join Date: Sep 2016
Posts: 241
Default Re: Engine cuts out !!

Quote:
Originally Posted by ptcruisersteve View Post
Not a good idea to start diagnosing a problem with a bad battery.
It's good enough for now if he's got a cutting out scenario and it's starting the car Steve.

Yes, he more than likely needs a new battery, although we don't know, and 11.7v in a gaff that likes selling batteries is... well... maybe marginal when we don't know how much work it had done before he took it there - but the CRD batteries are an arm and a leg, and he should give himself a chance to shop around rather than go out and buy the first one he can.

You can get a decent battery for the petrol over in Europe for 50 / 50 - for the CRD you can get striped and pay 250 / ... or find them as low as 120...
Reply With Quote
Reply

Tags
dashboard lights, engine light flashing


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Cuts out alanrw Tech & Performance Forum 65 09 Jul 2016 02:58 pm
Engine cranks, but cuts off. LemonOnWheels General PT Cruiser Discussions 4 15 Mar 2014 12:47 pm
PT engine cuts out when starting with AC on mmhendrie Tech & Performance Forum 12 22 Jul 2013 11:04 pm
engine cuts off while driving leesa47 Tech & Performance Forum 2 19 Apr 2012 12:14 pm
Engine cuts in and out at 2200 RPM tomrinsb Tech & Performance Forum 21 13 Oct 2008 05:50 pm


All times are GMT -5. The time now is 04:09 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors