PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Nov 2017, 09:06 pm
Regular Cruiser
 
Join Date: Oct 2017
Posts: 102
Default Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

hi i have created a new thread..my last one got too confusing please disregard other thread i created ..

. i have a 2001 pt cruiser 2.4L non turbo with issues with power to fan connector at the fan motor.


i will try to sum up my situation as best i can so hopefully will make it easier for someone to help with root cause. ..of why i cant get power to high speed fan connector at the fan motor at all and only get power to low speed fan connector at the fan motor under certain condition.

1. low speed mode on radiator fan inoperable tested via 12v direct power
2. high speed mode on radiator fan good tested via 12v direct power
3 can not get power to high speed fan connector at all under any condition i have tried...when temp reaches 228F per scan tool high speed feed receives no power
4. it appears i get 12v power to low speed fan connector (on and off) at appropriate temperatures

5 all fuses in pdc and under dash good

6 high speed and low speed relays tested good via multimeter resistance and 12v test

7 continuity from relays to fan connector wires good

8 ground continuity from fan connector good

9 12v present per schematics to relays good

10 no check engine light on or codes while car is running with both high and low relays installed.

11. if i remove low speed relay the check engine light comes on and i get code p1490

12 if i remove high speed relay i get no check engine light and no codes

13 if i remove both high and low relays check engine light comes on and i get one code only p1490

14 if i remove low speed relay the high speed fan should by default power on and it doesnt.

15 per chrysler technician high speed fan connector should receive power once temp is reached regardless if low speed fan is wokring or not and my high speed fan connector never recieves power.

16 ECT seems to be functioning .. tested via multimeter..as temp got hotter resistance dropped...

17 have not done any testing on PCM

18 coolant level ok

19 ac in this vehicle is inoperable and was bypassed many years ago..and ac relay was removed many years ago and is not present

20 all fan wiring is to original specs.

Last edited by Shelby5041; 14 Nov 2017 at 06:11 pm. Reason: new data update
Reply With Quote
  #2 (permalink)  
Old 11 Nov 2017, 09:24 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,207
Default Re: Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

I would suggest checking the engine coolant temperature sensor to see if it is working properly. In my opinion the PCM is receiving information it does not like and not grounding the high speed relay.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 11 Nov 2017, 09:26 pm
rckstein's Avatar
Obsessed Cruiser
 
Join Date: Dec 2010
Location: Euless, TX
Posts: 11,979
Default Re: Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

From the Service Manual:



It says "RADIATOR FAN WILL NOT OPERATE" it does not specify high or low speed.

That's where you need to start from.
__________________

'06 Touring Edition NA Automatic
150k Miles / Electric Blue Pearl
USMC '82 - '93
Reply With Quote
  #4 (permalink)  
Old 12 Nov 2017, 10:15 am
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Posts: 14,160
Default Re: Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

so we just start a new thread if we dont like how the other thread we started relating to the same subject??

Reply With Quote
  #5 (permalink)  
Old 12 Nov 2017, 01:47 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,207
Default Re: Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

Here is the link for the first thread on this issue.

2001 ptcruiser radiator fan not coming on overheat at idle
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #6 (permalink)  
Old 12 Nov 2017, 02:02 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,207
Default Re: Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

Quote:
Originally Posted by ptcruisersteve View Post
I would suggest checking the engine coolant temperature sensor to see if it is working properly. In my opinion the PCM is receiving information it does not like and not grounding the high speed relay.
I would suggest checking the sensor wire (tan/black) from the ECT (coolant temp sensor) to PCM pin #26 with an ohm meter. Make sure you have good contact on both ends.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #7 (permalink)  
Old 13 Nov 2017, 10:54 am
Regular Cruiser
 
Join Date: Oct 2017
Posts: 102
Default Re: Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

nitro i started a new thread because previous thread was causing too much confusion for everyone ..it was too hard to follow .. i dont know how to delete it...

i have included real data so if someone can help that would be great

today i hooked up my mulimeter to the ECT terminal with ect removed...using ohms

as vehicle warmed up the resistance was continuously dropping as engine got hotter.....with ect removed at initial cold start this did cause check engine light to come on and temp warning light came on and also i immediately got power to low speed fan connector at fan motor.

so this does seem like pcm is functioning in this test.
Reply With Quote
  #8 (permalink)  
Old 13 Nov 2017, 11:04 am
Regular Cruiser
 
Join Date: Oct 2017
Posts: 102
Default Re: Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

ok steve i will try but not sure how i get to pin 26 on pcm...very unfamilair with pcm and layout..
Reply With Quote
  #9 (permalink)  
Old 13 Nov 2017, 03:22 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,207
Default Re: Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

You can look it up in a factory shop manual. We don't have a factory shop manual for the specific 2001 Pt Cruiser so you would need to see if the 01 to 04 Pt Cruiser generalized shop manual might help you attached in the thread below.

Free 01-04 PT cruiser shop manual
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #10 (permalink)  
Old 14 Nov 2017, 03:22 pm
Regular Cruiser
 
Join Date: Oct 2017
Posts: 102
Default Re: Power to radiator fan connector issues 2001 pt cruiser 2.4L non turbo

hi

can anyone confirm temp at which high speed fan should turn on 2001 pt cruiser 2.4L non turbo

i did some testing today using my new scanner and may have some ok news as well as not ok news..

steve... per scanner i have no permanent codes and no current codes so thats not the issue here

but i was able to come up with some ideas of what is going on with low speed circuit. I believe high speed circuit communication between pcm and relay is bad. and i believe communication between low speed circuit and pcm is good.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
RADIATOR FAN CONNECTOR WON'T DISCONNECT barnett468 Tech & Performance Forum 8 20 Mar 2017 12:10 pm
2001 Cruiser AC issues help! invidious General PT Cruiser Discussions 13 05 Jul 2015 08:25 pm
What is this connector in-between the radiator & front bumper for? ingram87 General PT Cruiser Discussions 8 16 Jan 2015 10:33 pm
Picture of radiator fan assembly 4 wire connector a417latino General Turbo Discussions 12 22 Jul 2014 09:22 am
Radiator/Cooling Fan Check & Connector Fix alexptla General PT Cruiser Discussions 4 01 Nov 2011 06:59 pm


All times are GMT -5. The time now is 08:10 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors